summaryrefslogtreecommitdiffstats
path: root/recipes/ostree/ostree.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-12-07 08:49:47 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-12-07 08:49:47 +0200
commit85e2dbf78e6ba044fea744367f16ccd1808c1810 (patch)
tree87b31ac6c770274cf7e219c312b32d9d25af8b40 /recipes/ostree/ostree.bb
parent3587c4fb32e5046729608513bf4c189e846fefd4 (diff)
parentc97f13c28d29bd71c98043f709a5875606300142 (diff)
downloadmeta-boot2qt-85e2dbf78e6ba044fea744367f16ccd1808c1810.tar.gz
Merge remote-tracking branch 'origin/dizzy' into dev
* origin/dizzy: Use openembedded mirror from github nitrogen6x: add u-boot binary back to the image ostree: Add TLS support ostree: patch upstream project ostree: Add GNUPG to runtime dependencies. Revert "Build nativesdk-ostree" Remove unused b2qt-update-framework Conflicts: conf/distro/include/nitrogen6x.conf recipes/ostree/ostree.bb scripts/manifest.xml scripts/manifest_fido.xml Change-Id: Ie3884fa026fc8b8d7d05a9bff4b2beb124e4fd03
Diffstat (limited to 'recipes/ostree/ostree.bb')
-rw-r--r--recipes/ostree/ostree.bb19
1 files changed, 14 insertions, 5 deletions
diff --git a/recipes/ostree/ostree.bb b/recipes/ostree/ostree.bb
index acd8305..49060b6 100644
--- a/recipes/ostree/ostree.bb
+++ b/recipes/ostree/ostree.bb
@@ -28,13 +28,18 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
28inherit autotools pkgconfig systemd 28inherit autotools pkgconfig systemd
29 29
30SRC_URI = " \ 30SRC_URI = " \
31 git://github.com/GNOME/ostree.git;tag=v2015.9 \ 31 git://github.com/GNOME/ostree.git \
32 file://0001-Don-t-require-boot-uEnv.txt-for-u-boot-support.patch \ 32 file://0001-Allow-updating-files-on-the-boot-partition.patch \
33 file://0002-u-boot-Merge-ostree-s-and-systems-uEnv.txt.patch \
34 file://0003-Allow-updating-files-in-root-of-boot.patch \
33 " 35 "
34 36
37SRCREV = "efdb4d8f443768e59529c299290bee8b1f8f93c3"
38
35S = "${WORKDIR}/git" 39S = "${WORKDIR}/git"
36 40
37DEPENDS = "glib-2.0 e2fsprogs gpgme attr libsoup-2.4 libgsystem libassuan xz" 41DEPENDS = "glib-2.0 e2fsprogs gpgme attr libsoup-2.4 libgsystem libassuan xz"
42RRECOMMENDS_${PN} += "gnupg"
38 43
39PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 44PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
40PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,," 45PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,,"
@@ -42,7 +47,13 @@ PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/
42SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service" 47SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
43FILES_${PN} += "${systemd_unitdir}/system/" 48FILES_${PN} += "${systemd_unitdir}/system/"
44 49
45EXTRA_OECONF = "--with-dracut --without-selinux --without-libarchive --with-grub2=no --enable-gtk-doc-html=no" 50EXTRA_OECONF = "--with-dracut \
51 --without-selinux \
52 --without-libarchive \
53 --with-grub2=no \
54 --enable-gtk-doc-html=no \
55 --with-soup \
56 --enable-libsoup-client-certs"
46 57
47do_configure_prepend() { 58do_configure_prepend() {
48 cd ${S} 59 cd ${S}
@@ -57,5 +68,3 @@ do_install_append() {
57 # this of course is a broken configure.ac logic. 68 # this of course is a broken configure.ac logic.
58 rm -rf ${D}${libdir}/dracut/ 69 rm -rf ${D}${libdir}/dracut/
59} 70}
60
61BBCLASSEXTEND = "native nativesdk"