summaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-09-23 13:04:47 +0300
committerSamuli Piippo <samuli.piippo@digia.com>2014-09-25 15:22:26 +0300
commit01603689e8dd2d3c5be0f41d41b3543452903f03 (patch)
tree47c0d3b74c92d5891da42c48e799317a8672d253 /recipes/linux
parent0dded51636b689237af7fdcda1719790c7fb3aa7 (diff)
downloadmeta-boot2qt-01603689e8dd2d3c5be0f41d41b3543452903f03.tar.gz
Move meta-fsl-arm specific files to separate layer
Create new layer for recipes and files that required only when meta-fsl-arm and meta-fsl-arm-extra layers are used. For now, the bblayers.conf template still includes the new layer as well. Change-Id: I01a0019ebaea3e1532f106e076f7608fb7aa86c6 Reviewed-by: Eirik Aavitsland <eirik.aavitsland@digia.com>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-boundary_3.10.17.bbappend42
-rw-r--r--recipes/linux/linux-imx_3.10.17.bbappend35
2 files changed, 0 insertions, 77 deletions
diff --git a/recipes/linux/linux-boundary_3.10.17.bbappend b/recipes/linux/linux-boundary_3.10.17.bbappend
deleted file mode 100644
index da33ff5..0000000
--- a/recipes/linux/linux-boundary_3.10.17.bbappend
+++ /dev/null
@@ -1,42 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# kernel image files are not needed in the image
24RDEPENDS_kernel-base = ""
25
26do_configure_prepend() {
27 # Use multitouch protocol for touchscreen that support it
28 echo "CONFIG_TOUCHSCREEN_EGALAX_SINGLE_TOUCH=n" >> ${WORKDIR}/defconfig
29 echo "CONFIG_TOUCHSCREEN_FT5X06_SINGLE_TOUCH=n" >> ${WORKDIR}/defconfig
30
31 # FunctionFS for adb
32 echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
33
34 # Enable USB serial support
35 echo "CONFIG_USB_SERIAL=m" >> ${WORKDIR}/defconfig
36 echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${WORKDIR}/defconfig
37 echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig
38 echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig
39
40 # fix imx-vpu break on video decoding
41 echo "CONFIG_VMSPLIT_2G=y" >> ${WORKDIR}/defconfig
42}
diff --git a/recipes/linux/linux-imx_3.10.17.bbappend b/recipes/linux/linux-imx_3.10.17.bbappend
deleted file mode 100644
index df01b62..0000000
--- a/recipes/linux/linux-imx_3.10.17.bbappend
+++ /dev/null
@@ -1,35 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# kernel image files are not needed in the image
24RDEPENDS_kernel-base = ""
25
26do_configure_prepend() {
27 # FunctionFS for adb
28 echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
29
30 # Enable USB serial support
31 echo "CONFIG_USB_SERIAL=m" >> ${WORKDIR}/defconfig
32 echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${WORKDIR}/defconfig
33 echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig
34 echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig
35}