summaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-09-23 12:34:23 +0300
committerSamuli Piippo <samuli.piippo@digia.com>2014-09-25 15:22:18 +0300
commit0dded51636b689237af7fdcda1719790c7fb3aa7 (patch)
treee3eb3b08771005311ca9157882ff2dad6cb733f8 /recipes/linux
parent841eaa73863184bba6c805fc622e242f367609f7 (diff)
downloadmeta-boot2qt-0dded51636b689237af7fdcda1719790c7fb3aa7.tar.gz
Move meta-ti specific files to separate layer
Create new layer for recipes and files that required only when meta-ti layer is used. For now, the bblayers.conf template still includes the new layer as well. Change-Id: Iab8f6b3a61578e7a9579066ae7facca5a9a1f33b Reviewed-by: Eirik Aavitsland <eirik.aavitsland@digia.com>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-am335x-psp_3.2.bbappend40
-rw-r--r--recipes/linux/linux-mainline_3.2.bbappend42
-rw-r--r--recipes/linux/linux-ti-staging/usb-serial.cfg4
-rw-r--r--recipes/linux/linux-ti-staging_3.12.bbappend28
4 files changed, 0 insertions, 114 deletions
diff --git a/recipes/linux/linux-am335x-psp_3.2.bbappend b/recipes/linux/linux-am335x-psp_3.2.bbappend
deleted file mode 100644
index fd7dd31..0000000
--- a/recipes/linux/linux-am335x-psp_3.2.bbappend
+++ /dev/null
@@ -1,40 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23do_configure_append() {
24 # FunctionFS for adb
25 echo "CONFIG_USB_LIBCOMPOSITE=y" >> ${S}/.config
26 echo "CONFIG_USB_FUNCTIONFS=m" >> ${S}/.config
27 echo "CONFIG_USB_FUNCTIONFS_ETH=n" >> ${S}/.config
28 echo "CONFIG_USB_FUNCTIONFS_RNDIS=n" >> ${S}/.config
29 echo "CONFIG_USB_FUNCTIONFS_GENERIC=y" >> ${S}/.config
30
31 echo "CONFIG_DEVTMPFS=y" >> ${S}/.config
32
33 # Enable USB serial support
34 echo "CONFIG_USB_SERIAL=m" >> ${S}/.config
35 echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${S}/.config
36 echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${S}/.config
37 echo "CONFIG_USB_SERIAL_PL2303=m" >> ${S}/.config
38
39 yes '' | oe_runmake oldconfig
40}
diff --git a/recipes/linux/linux-mainline_3.2.bbappend b/recipes/linux/linux-mainline_3.2.bbappend
deleted file mode 100644
index 9e195dc..0000000
--- a/recipes/linux/linux-mainline_3.2.bbappend
+++ /dev/null
@@ -1,42 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23do_configure_prepend() {
24 # Builtin network driver, so networking is initialized correctly during boot
25 echo "CONFIG_USB_NET_SMSC95XX=y" >> ${WORKDIR}/defconfig
26
27 # FunctionFS for adb
28 echo "CONFIG_USB_FUNCTIONFS_ETH=n" >> ${WORKDIR}/defconfig
29 echo "CONFIG_USB_FUNCTIONFS_RNDIS=n" >> ${WORKDIR}/defconfig
30 echo "CONFIG_USB_FUNCTIONFS_GENERIC=y" >> ${WORKDIR}/defconfig
31
32 # Enable USB serial support
33 echo "CONFIG_USB_SERIAL=m" >> ${WORKDIR}/defconfig
34 echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${WORKDIR}/defconfig
35 echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig
36 echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig
37
38 # Remove beagleboard logo
39 if [ -e ${WORKDIR}/${LOGO_SIZE}/logo_linux_clut224.ppm ]; then
40 rm ${WORKDIR}/${LOGO_SIZE}/logo_linux_clut224.ppm
41 fi
42}
diff --git a/recipes/linux/linux-ti-staging/usb-serial.cfg b/recipes/linux/linux-ti-staging/usb-serial.cfg
deleted file mode 100644
index 8f0688e..0000000
--- a/recipes/linux/linux-ti-staging/usb-serial.cfg
+++ /dev/null
@@ -1,4 +0,0 @@
1CONFIG_USB_SERIAL=m
2CONFIG_USB_SERIAL_GENERIC=y
3CONFIG_USB_SERIAL_FTDI_SIO=m
4CONFIG_USB_SERIAL_PL2303=m
diff --git a/recipes/linux/linux-ti-staging_3.12.bbappend b/recipes/linux/linux-ti-staging_3.12.bbappend
deleted file mode 100644
index b2d6104..0000000
--- a/recipes/linux/linux-ti-staging_3.12.bbappend
+++ /dev/null
@@ -1,28 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
24SRC_URI += "\
25 file://usb-serial.cfg \
26 "
27KERNEL_CONFIG_FRAGMENTS += "${WORKDIR}/usb-serial.cfg"
28KERNEL_DEVICETREE_b2qt = "am335x-evm.dtb am335x-evmsk.dtb am335x-bone.dtb am335x-boneblack.dtb"