summaryrefslogtreecommitdiffstats
path: root/recipes/hunspell
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-01-23 13:37:29 +0200
committerSamuli Piippo <samuli.piippo@digia.com>2014-01-30 12:28:40 +0200
commitf9d3810c97a637bea23b36c71aafcd00b01670d6 (patch)
treebe08c9fbfc9aecc0373d42361c75bc9fa8ae0e19 /recipes/hunspell
parent20a3734c0da057a51aadc89e3dba163367611dc5 (diff)
downloadmeta-boot2qt-f9d3810c97a637bea23b36c71aafcd00b01670d6.tar.gz
Recipe for hunspell
Add new recipe for hunspell and include it to image and toolchain Change-Id: I724aca8e3da378a0b59e57a0b00f03e9137b48f0 Reviewed-by: Rainer Keller <rainer.keller@digia.com>
Diffstat (limited to 'recipes/hunspell')
-rw-r--r--recipes/hunspell/hunspell_1.3.2.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/recipes/hunspell/hunspell_1.3.2.bb b/recipes/hunspell/hunspell_1.3.2.bb
new file mode 100644
index 0000000..c9d6aba
--- /dev/null
+++ b/recipes/hunspell/hunspell_1.3.2.bb
@@ -0,0 +1,51 @@
1#############################################################################
2##
3## Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Hunspell"
24LICENSE = "LGPLv2"
25LIC_FILES_CHKSUM = "file://${WORKDIR}/hunspell-${PV}/COPYING;md5=ed3a37b3ba6d6be3e08ab45987cf1b88"
26
27SRC_URI = "http://downloads.sourceforge.net/hunspell/hunspell-${PV}.tar.gz \
28 http://ftp.halifax.rwth-aachen.de/gentoo/distfiles/myspell-en_GB-20081002.zip \
29 http://downloads.sourceforge.net/project/ayaspell/hunspell-ar/20080110/hunspell-ar_20080110.tar.gz \
30 "
31
32SRC_URI[md5sum] = "69990932920960eb765fd35883640124"
33SRC_URI[sha256sum] = "88d9eebbe05de29d17f4420ebaec9249441ce01d61b5d6c7ecba040e250e2d91"
34
35PR = "r0"
36
37inherit autotools gettext
38
39PACKAGES += "${PN}-dicts"
40RRECOMMENDS_${PN} += "${PN}-dicts"
41FILES_${PN}-dicts = "${datadir}/hunspell"
42
43do_install_append() {
44 install -m 0755 -d ${D}${datadir}/hunspell
45
46 install -m 0755 ${WORKDIR}/hunspell-ar_20080110/ar.dic ${D}${datadir}/hunspell/ar_EG.dic
47 install -m 0755 ${WORKDIR}/hunspell-ar_20080110/ar.aff ${D}${datadir}/hunspell/ar_EG.aff
48
49 install -m 0755 ${WORKDIR}/en_GB.dic ${D}${datadir}/hunspell
50 install -m 0755 ${WORKDIR}/en_GB.aff ${D}${datadir}/hunspell
51}