summaryrefslogtreecommitdiffstats
path: root/recipes/fonts
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-03-02 13:08:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-03-12 14:12:31 +0000
commit344c2f97025c6504ec986600498121bb83aaeb8f (patch)
tree3d7ec602603cb083b7c8e998eddca543ce17e57c /recipes/fonts
parentd9985542d7617b43ec7180c7ade0c4f64db82b42 (diff)
downloadmeta-boot2qt-344c2f97025c6504ec986600498121bb83aaeb8f.tar.gz
Split meta-boot2qt layer
Move distro specific recipes to own layer and leave only new recipes and bbclasses to meta-boot2qt layer. This makes it easier to include meta-boot2qt to your own distro layer to get access e.g., QDB and QBSP recipes that might be useful even without boot2qt distro. Task-number: QTBUG-65871 Change-Id: I6c353774dd1668b00f2d05aa262ad866b90bdef6 Reviewed-by: Timo Aarnipuro <timo.aarnipuro@qt.io>
Diffstat (limited to 'recipes/fonts')
-rw-r--r--recipes/fonts/otf-noto_git.bb52
-rw-r--r--recipes/fonts/ttf-devanagari_2.94.0.bb53
-rw-r--r--recipes/fonts/ttf-freefont_20120503.bb49
-rw-r--r--recipes/fonts/ttf-opensans.bb51
4 files changed, 0 insertions, 205 deletions
diff --git a/recipes/fonts/otf-noto_git.bb b/recipes/fonts/otf-noto_git.bb
deleted file mode 100644
index 093ee33..0000000
--- a/recipes/fonts/otf-noto_git.bb
+++ /dev/null
@@ -1,52 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30SUMMARY = "Noto Sans CJK"
31SECTION = "fonts"
32HOMEPAGE = "http://www.google.com/get/noto"
33LICENSE = "OFL-1.1"
34LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=55719faa0112708e946b820b24b14097"
35
36INHIBIT_DEFAULT_DEPS = "1"
37
38inherit allarch fontcache
39
40PV = "1.004"
41SRC_URI = "git://github.com/googlei18n/noto-cjk.git"
42SRCREV = "40d9f5b179a59a06b98373c76bdc3e2119e4e6b2"
43
44S = "${WORKDIR}/git"
45
46do_install() {
47 install -m 0755 -d ${D}${datadir}/fonts/otf/noto
48 install -m 0644 ${S}/NotoSansCJKsc-Regular.otf ${D}${datadir}/fonts/otf/noto
49}
50
51PACKAGES = "${PN}"
52FILES_${PN} += "${datadir}/fonts/otf/noto"
diff --git a/recipes/fonts/ttf-devanagari_2.94.0.bb b/recipes/fonts/ttf-devanagari_2.94.0.bb
deleted file mode 100644
index ee0ea06..0000000
--- a/recipes/fonts/ttf-devanagari_2.94.0.bb
+++ /dev/null
@@ -1,53 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30SUMMARY = "Lohit Devanagari Fonts"
31SECTION = "fonts"
32HOMEPAGE = "https://fedorahosted.org/lohit/"
33LICENSE = "OFL-1.1"
34LIC_FILES_CHKSUM = "file://${WORKDIR}/lohit-devanagari-ttf-${PV}/OFL.txt;md5=7dfa0a236dc535ad2d2548e6170c4402"
35
36INHIBIT_DEFAULT_DEPS = "1"
37
38inherit allarch fontcache
39
40SRC_URI = "https://releases.pagure.org/lohit/lohit-devanagari-ttf-${PV}.tar.gz"
41
42SRC_URI[md5sum] = "57527ee536a18b443cf786d4b8fd5ec8"
43SRC_URI[sha256sum] = "a6618aeb1d25df46d3c22e528c38ea1d1147654e19904497a1e97f4684c55353"
44
45do_install() {
46 install -m 0755 -d ${D}${datadir}/fonts/truetype/lohit
47 install -m 0755 -d ${D}${sysconfdir}/fonts/conf.d/
48 install -m 0644 ${WORKDIR}/lohit-devanagari-ttf-${PV}/66-lohit-devanagari.conf ${D}${sysconfdir}/fonts/conf.d/
49 install -m 0644 ${WORKDIR}/lohit-devanagari-ttf-${PV}/Lohit-Devanagari.ttf ${D}${datadir}/fonts/truetype/lohit
50}
51
52PACKAGES = "${PN}"
53FILES_${PN} += "${datadir}/fonts/truetype/lohit"
diff --git a/recipes/fonts/ttf-freefont_20120503.bb b/recipes/fonts/ttf-freefont_20120503.bb
deleted file mode 100644
index abf9562..0000000
--- a/recipes/fonts/ttf-freefont_20120503.bb
+++ /dev/null
@@ -1,49 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "GNU FreeFont is a free family of scalable outline fonts"
31HOMEPAGE = "http://savannah.gnu.org/projects/freefont"
32LICENSE = "GPLv3"
33LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
34
35require recipes-graphics/ttf-fonts/ttf.inc
36
37inherit allarch fontcache
38
39S = "${WORKDIR}/freefont-${PV}"
40
41SRC_URI = "http://ftp.gnu.org/gnu/freefont/freefont-ttf-${PV}.zip"
42
43SRC_URI[md5sum] = "879b76d2e3c8003d567b555743f39154"
44SRC_URI[sha256sum] = "7c85baf1bf82a1a1845d1322112bc6ca982221b484e3b3925022e25b5cae89af"
45
46PACKAGES = "${PN}-sans ${PN}-mono ${PN}-serif"
47FILES_${PN}-sans = "${datadir}/fonts/truetype/FreeSans*.ttf"
48FILES_${PN}-mono = "${datadir}/fonts/truetype/FreeMono*.ttf"
49FILES_${PN}-serif = "${datadir}/fonts/truetype/FreeSerif*.ttf"
diff --git a/recipes/fonts/ttf-opensans.bb b/recipes/fonts/ttf-opensans.bb
deleted file mode 100644
index 1d581ac..0000000
--- a/recipes/fonts/ttf-opensans.bb
+++ /dev/null
@@ -1,51 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30SUMMARY = "Open Sans Fonts"
31SECTION = "fonts"
32HOMEPAGE = "https://fonts.google.com"
33LICENSE = "Apache-2.0"
34LIC_FILES_CHKSUM = "file://apache/opensans/LICENSE.txt;md5=d273d63619c9aeaf15cdaf76422c4f87"
35
36INHIBIT_DEFAULT_DEPS = "1"
37
38inherit allarch fontcache
39
40SRC_URI = "git://github.com/google/fonts"
41SRCREV = "beaec0837bd21524b57ecb435158f9011fc03999"
42
43S = "${WORKDIR}/git"
44
45do_install() {
46 install -m 0755 -d ${D}${datadir}/fonts/truetype/opensans
47 install -m 0644 apache/opensans/*.ttf ${D}${datadir}/fonts/truetype/opensans
48}
49
50PACKAGES = "${PN}"
51FILES_${PN} += "${datadir}/fonts/truetype/opensans"