summaryrefslogtreecommitdiffstats
path: root/recipes/fonts/ttf-opensans.bb
diff options
context:
space:
mode:
authorGatis Paeglis <gatis.paeglis@digia.com>2014-10-02 10:40:51 +0200
committerGatis Paeglis <gatis.paeglis@digia.com>2014-10-07 12:00:15 +0300
commit4240ef58f339d11ae8cd2540c001085a711da90d (patch)
tree43615fb618da89227e33a464131538b008df4dea /recipes/fonts/ttf-opensans.bb
parente2ef75f16d54d30945bef4ff761bc1151f47f015 (diff)
downloadmeta-boot2qt-4240ef58f339d11ae8cd2540c001085a711da90d.tar.gz
Install fonts with help of Yocto recipes
Install fonts with help of Yocto recipes instead of installing fonts from many "random" shell scripts and b2qt-launcher repository. Change-Id: I906d022cfab1dfabeca1a8cd0b4c39cc8a886842 Task-number: QTEE-757 Reviewed-by: Samuli Piippo <samuli.piippo@digia.com> Reviewed-by: Kalle Viironen <kalle.viironen@digia.com>
Diffstat (limited to 'recipes/fonts/ttf-opensans.bb')
-rw-r--r--recipes/fonts/ttf-opensans.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/fonts/ttf-opensans.bb b/recipes/fonts/ttf-opensans.bb
new file mode 100644
index 0000000..ad40b81
--- /dev/null
+++ b/recipes/fonts/ttf-opensans.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Open Sans Fonts"
2SECTION = "fonts"
3HOMEPAGE = "https://www.google.com/fonts"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE.txt;md5=d273d63619c9aeaf15cdaf76422c4f87"
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9inherit allarch fontcache
10
11SRC_URI = "https://www.google.com/fonts/download?kit=3hvsV99qyKCBS55e5pvb3ltkqrIMaAZWyLYEoB48lSQ;downloadfilename=Open_Sans.zip"
12# Google packs fonts package on demand which results in unpredictable md5sum, so disable checksum check
13BB_STRICT_CHECKSUM = ""
14
15do_install() {
16 install -m 0644 -d ${D}${datadir}/fonts/truetype/opensans
17 install -m 0644 ${WORKDIR}/*.ttf ${D}${datadir}/fonts/truetype/opensans
18}
19
20PACKAGES = "${PN}"
21FILES_${PN} += "${datadir}/fonts/truetype/opensans"