diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2018-03-02 13:08:39 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2018-03-12 14:12:31 +0000 |
commit | 344c2f97025c6504ec986600498121bb83aaeb8f (patch) | |
tree | 3d7ec602603cb083b7c8e998eddca543ce17e57c /recipes/base-files | |
parent | d9985542d7617b43ec7180c7ade0c4f64db82b42 (diff) | |
download | meta-boot2qt-344c2f97025c6504ec986600498121bb83aaeb8f.tar.gz |
Split meta-boot2qt layer
Move distro specific recipes to own layer and leave only new recipes
and bbclasses to meta-boot2qt layer. This makes it easier to include
meta-boot2qt to your own distro layer to get access e.g., QDB and
QBSP recipes that might be useful even without boot2qt distro.
Task-number: QTBUG-65871
Change-Id: I6c353774dd1668b00f2d05aa262ad866b90bdef6
Reviewed-by: Timo Aarnipuro <timo.aarnipuro@qt.io>
Diffstat (limited to 'recipes/base-files')
-rw-r--r-- | recipes/base-files/base-files/blacklist.conf | 1 | ||||
-rw-r--r-- | recipes/base-files/base-files_3.0.14.bbappend | 44 |
2 files changed, 0 insertions, 45 deletions
diff --git a/recipes/base-files/base-files/blacklist.conf b/recipes/base-files/base-files/blacklist.conf deleted file mode 100644 index a8b8885..0000000 --- a/recipes/base-files/base-files/blacklist.conf +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | blacklist evbug | ||
diff --git a/recipes/base-files/base-files_3.0.14.bbappend b/recipes/base-files/base-files_3.0.14.bbappend deleted file mode 100644 index 1dc5501..0000000 --- a/recipes/base-files/base-files_3.0.14.bbappend +++ /dev/null | |||
@@ -1,44 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
31 | SRC_URI += "\ | ||
32 | file://blacklist.conf \ | ||
33 | " | ||
34 | |||
35 | do_install_append() { | ||
36 | ln -s /home/root ${D}/root | ||
37 | echo ${MACHINE_HOSTNAME} > ${D}${sysconfdir}/hostname | ||
38 | |||
39 | install -m 0755 -d ${D}${sysconfdir}/modprobe.d | ||
40 | install -m 0644 ${WORKDIR}/blacklist.conf ${D}${sysconfdir}/modprobe.d | ||
41 | |||
42 | # Add quotes around command expansion, since tty may return "not a tty" | ||
43 | sed -i 's#test `tty | cut -c1-8`#test "`tty | cut -c1-8`"#' ${D}${sysconfdir}/profile | ||
44 | } | ||