summaryrefslogtreecommitdiffstats
path: root/recipes/alsa
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2013-10-22 14:32:56 +0300
committerSamuli Piippo <samuli.piippo@digia.com>2013-10-24 15:42:05 +0300
commit713306041324f18fd546fbf99cd7d15ec1eeb6f2 (patch)
treea4d29129910aa0a2f4bb6980aa12a0db3954bde8 /recipes/alsa
parentf35bcc5ed220e748241c1e06bcd1ab6a7c99e10d (diff)
downloadmeta-boot2qt-713306041324f18fd546fbf99cd7d15ec1eeb6f2.tar.gz
Sound support for Raspberry Pi
Load appropriate kernel module and setup correct alsa configuration. Sound is routed to HDMI by default, so include amixer util that can be used to switch to analog output: amixer cset numid=3 1 Change-Id: I1a975992a45ea2a11ce44ded8b1649488e676341 Reviewed-by: Pasi Petäjäjärvi <pasi.petajajarvi@digia.com>
Diffstat (limited to 'recipes/alsa')
-rw-r--r--recipes/alsa/alsa-state.bbappend1
-rw-r--r--recipes/alsa/alsa-state/raspberrypi/asound.conf9
2 files changed, 10 insertions, 0 deletions
diff --git a/recipes/alsa/alsa-state.bbappend b/recipes/alsa/alsa-state.bbappend
new file mode 100644
index 0000000..72d991c
--- /dev/null
+++ b/recipes/alsa/alsa-state.bbappend
@@ -0,0 +1 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/recipes/alsa/alsa-state/raspberrypi/asound.conf b/recipes/alsa/alsa-state/raspberrypi/asound.conf
new file mode 100644
index 0000000..83f7f9a
--- /dev/null
+++ b/recipes/alsa/alsa-state/raspberrypi/asound.conf
@@ -0,0 +1,9 @@
1pcm.!default {
2 type hw
3 card 0
4}
5
6ctl.!default {
7 type hw
8 card 0
9}