summaryrefslogtreecommitdiffstats
path: root/recipes/adbd/adbd.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2013-06-20 15:36:33 +0300
committerSamuli Piippo <samuli.piippo@digia.com>2013-06-24 08:39:36 +0300
commit29f971bec6ad8bbbf3f6bbcf1ab67f1f4e0b59ff (patch)
treefa3d68640bc264e52a8c5265bc730a2d37d68866 /recipes/adbd/adbd.bb
parentfdb102b8b6bf1e0f2807502eaa83cb7818009b6e (diff)
downloadmeta-boot2qt-29f971bec6ad8bbbf3f6bbcf1ab67f1f4e0b59ff.tar.gz
Include Android Debug Bridge Daemon (adbd) to images
Change-Id: I00108d36be95e42b8aa9674d1a86ea7e3a5bcf55 Reviewed-by: Rainer Keller <rainer.keller@digia.com>
Diffstat (limited to 'recipes/adbd/adbd.bb')
-rw-r--r--recipes/adbd/adbd.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/adbd/adbd.bb b/recipes/adbd/adbd.bb
new file mode 100644
index 0000000..1cc8882
--- /dev/null
+++ b/recipes/adbd/adbd.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "Android Debug Bridge Daemon"
2HOMEPAGE = "http://developer.android.com/tools/help/adb.html"
3SECTION = "libs"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://ThirdPartyProject.prop;md5=4e5987c5919a36739dc8f76a4e35d9eb"
6
7PR = "r0"
8SRCREV = "android-4.2.2_r1.2"
9
10SRC_URI = "git://android.googlesource.com/platform/system/core;protocol=https;tag=${SRCREV} \
11 file://adbd.patch \
12 file://Makefile.adbd \
13 file://adb-init \
14 "
15
16S = "${WORKDIR}/git"
17
18FILES_${PN} += "${bindir}/adbd"
19
20do_compile() {
21 make -C adb -f ${WORKDIR}/Makefile.adbd
22}
23
24do_install() {
25 install -m 0755 -d ${D}${bindir}/
26 install -m 0755 ${WORKDIR}/git/adb/adbd ${D}${bindir}/
27
28 install -m 0755 -d ${D}${sysconfdir}/init.d
29 install -m 0755 ${WORKDIR}/adb-init ${D}${sysconfdir}/init.d/
30}
31
32INITSCRIPT_NAME = "adb-init"
33INITSCRIPT_PARAMS = "defaults 96"
34
35inherit update-rc.d