diff options
author | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2016-02-15 15:20:56 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2016-02-18 14:05:08 +0000 |
commit | e13c34792ea3d6626262daa3ecae4c7566a5bd11 (patch) | |
tree | 234856c0000e014145315acdd760f0e34150863f /recipes-qt | |
parent | 878f786665113af2bd61a6df2739157dbf15b630 (diff) | |
download | meta-boot2qt-e13c34792ea3d6626262daa3ecae4c7566a5bd11.tar.gz |
add wayland demo compositor
Change-Id: I720676f6edb1789f4d073a58539e2fe929582f0e
Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r-- | recipes-qt/b2qt-addons/democompositor_git.bb | 43 | ||||
-rw-r--r-- | recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb | 1 |
2 files changed, 44 insertions, 0 deletions
diff --git a/recipes-qt/b2qt-addons/democompositor_git.bb b/recipes-qt/b2qt-addons/democompositor_git.bb new file mode 100644 index 0000000..0d2c3db --- /dev/null +++ b/recipes-qt/b2qt-addons/democompositor_git.bb | |||
@@ -0,0 +1,43 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | DESCRIPTION = "Boot to Qt Wayland Demo Compositor" | ||
23 | LICENSE = "QtEnterprise" | ||
24 | LIC_FILES_CHKSUM = "file://main.cpp;md5=56e7f80d726792929d5d089852de7cde;beginline=1;endline=39" | ||
25 | |||
26 | inherit qmake5 sdk-sources | ||
27 | |||
28 | SRC_URI = " \ | ||
29 | git://codereview.qt-project.org/tqtc-boot2qt/demos;branch=${BRANCH};protocol=ssh;sdk-uri=5.5/Boot2Qt/sources/b2qt-demos \ | ||
30 | " | ||
31 | |||
32 | SRCREV = "b6217fb2bb7702324da2a9f3f45be4a60e6ffe6c" | ||
33 | BRANCH = "5.6" | ||
34 | |||
35 | S = "${WORKDIR}/git/wayland/democompositor/" | ||
36 | |||
37 | DEPENDS = "qtbase qtwayland" | ||
38 | RDEPENDS_${PN} = "qtwayland (>= 5.7)" | ||
39 | |||
40 | do_install_append() { | ||
41 | install -d -m0775 ${D}/usr/bin | ||
42 | install -m0775 ${B}/democompositor ${D}/usr/bin | ||
43 | } | ||
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb index 2676e6e..7f0867e 100644 --- a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb +++ b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb | |||
@@ -31,4 +31,5 @@ RDEPENDS_${PN} += " \ | |||
31 | b2qt-utils \ | 31 | b2qt-utils \ |
32 | b2qt-launcher \ | 32 | b2qt-launcher \ |
33 | b2qt-demos \ | 33 | b2qt-demos \ |
34 | democompositor \ | ||
34 | " | 35 | " |