summaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-01-20 16:04:20 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-01-21 07:12:54 +0000
commitf8e5db89d7168f4ef3ceda33ebd3695c448435af (patch)
tree2befe3f7772a0a88d86167e66497f9faf95429d0 /recipes-qt
parent11058276e3382057eaafe95ee1549f49db00bf43 (diff)
downloadmeta-boot2qt-f8e5db89d7168f4ef3ceda33ebd3695c448435af.tar.gz
qtquickcontrols2: add recipe
Change-Id: I9692be2720f801af9c543796e78615cf3c185177 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb1
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb1
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb39
3 files changed, 41 insertions, 0 deletions
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
index a638ce7..66e0d75 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
@@ -47,6 +47,7 @@ RDEPENDS_${PN} += " \
47 qtlocation-dev \ 47 qtlocation-dev \
48 qtmultimedia-dev \ 48 qtmultimedia-dev \
49 qtquickcontrols-dev \ 49 qtquickcontrols-dev \
50 qtquickcontrols2-dev \
50 qtsensors-dev \ 51 qtsensors-dev \
51 qtserialbus-dev \ 52 qtserialbus-dev \
52 qtserialport-dev \ 53 qtserialport-dev \
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb b/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
index f565b24..b4e1d9e 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
@@ -43,6 +43,7 @@ RDEPENDS_${PN} += " \
43 qtlocation \ 43 qtlocation \
44 qtmultimedia \ 44 qtmultimedia \
45 qtquickcontrols \ 45 qtquickcontrols \
46 qtquickcontrols2 \
46 qtsensors \ 47 qtsensors \
47 qtserialbus \ 48 qtserialbus \
48 qtserialport \ 49 qtserialport \
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
new file mode 100644
index 0000000..e09985c
--- /dev/null
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -0,0 +1,39 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23require recipes-qt/qt5/qt5.inc
24require recipes-qt/qt5/qt5-git.inc
25
26LICENSE = "GFDL-1.3 & (LGPL-3.0 | GPL-3.0)"
27LIC_FILES_CHKSUM = " \
28 file://LICENSE.LGPLv3;md5=8ba7f2099d17d636d5fcc8303bb17587 \
29 file://LICENSE.GPLv3;md5=40f9bf30e783ddc201497165dfb32afb \
30 file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
31"
32
33DEPENDS += "qtbase qtxmlpatterns qtdeclarative qtgraphicaleffects"
34
35SRCREV = "47b3a29210042c22627a04445055bdacf1f9c722"
36
37FILES_${PN}-qmldesigner += " \
38 ${OE_QMAKE_PATH_QML}/*/*/*/designer \
39"