summaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-08-22 10:21:53 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-08-22 11:08:38 +0000
commit90bf1f50f69b9cbf0fcc709c53f617e8b68533d0 (patch)
tree651f56702756768a69ae2075b8a5637ecfe44aaa /recipes-qt
parent0f967048d5bd99ffacfb9893b76818293aaaa8a0 (diff)
downloadmeta-boot2qt-90bf1f50f69b9cbf0fcc709c53f617e8b68533d0.tar.gz
Remove automotive recipes
Automotive was released (and supported) in the jethro Change-Id: Iab8560b4b0d530e872eef585c635b45274a4507b Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/automotive/gammaray_git.bb29
-rw-r--r--recipes-qt/automotive/neptune-ui/neptune.service11
-rw-r--r--recipes-qt/automotive/neptune-ui_git.bb62
-rw-r--r--recipes-qt/automotive/qtapplicationmanager_git.bb58
-rw-r--r--recipes-qt/automotive/qtivi_git.bb37
-rw-r--r--recipes-qt/automotive/qtwebbrowser_git.bb40
-rw-r--r--recipes-qt/images/b2qt-automotive-qt5-image.bb50
-rw-r--r--recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb31
8 files changed, 0 insertions, 318 deletions
diff --git a/recipes-qt/automotive/gammaray_git.bb b/recipes-qt/automotive/gammaray_git.bb
deleted file mode 100644
index 033e534..0000000
--- a/recipes-qt/automotive/gammaray_git.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1SUMMARY = "GammaRay Qt introspection probe"
2HOMEPAGE = "http://www.kdab.com/gammaray"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE.GPL.txt;md5=5996517d53e3c2722d457fb633e970ed"
6
7inherit cmake_qt5
8
9SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}"
10
11BRANCH = "2.4"
12SRCREV = "4995051c9d6733ce3eabb486283160bf31c87c10"
13PV = "2.5.50+git${SRCPV}"
14
15DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity"
16
17S = "${WORKDIR}/git"
18
19EXTRA_OECMAKE += " -DGAMMARAY_BUILD_UI=OFF"
20
21FILES_${PN}-dev += " \
22 /usr/lib/cmake/* \
23 /usr/mkspecs/modules/* \
24"
25FILES_${PN}-dbg += " \
26 /usr/lib/.debug/* \
27 /usr/lib/gammaray/*/*/.debug \
28 /usr/lib/gammaray/*/*/styles/.debug \
29"
diff --git a/recipes-qt/automotive/neptune-ui/neptune.service b/recipes-qt/automotive/neptune-ui/neptune.service
deleted file mode 100644
index 9d7881c..0000000
--- a/recipes-qt/automotive/neptune-ui/neptune.service
+++ /dev/null
@@ -1,11 +0,0 @@
1[Unit]
2Description=Neptune
3After=systemd-user-sessions.service
4
5[Service]
6ExecStart=/usr/bin/appcontroller /usr/bin/appman -r -c /opt/am/config.yaml -c am-config.yaml --dbus none Main1280x800.qml
7Restart=on-failure
8WorkingDirectory=/opt/neptune
9
10[Install]
11WantedBy=multi-user.target
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb
deleted file mode 100644
index 7987958..0000000
--- a/recipes-qt/automotive/neptune-ui_git.bb
+++ /dev/null
@@ -1,62 +0,0 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22DESCRIPTION = "Neptune IVI UI"
23LICENSE = "GPLv3"
24LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=024d61f4545fb889faa57982553ce094"
25
26inherit qt5-module systemd
27
28SRC_URI = " \
29 git://codereview.qt-project.org/qt-apps/neptune-ui;branch=${BRANCH};protocol=http \
30 file://neptune.service \
31 "
32
33SRCREV = "b3f10d156349727310ec30b27d01e639cce4f570"
34BRANCH = "master"
35
36S = "${WORKDIR}/git"
37
38DEPENDS = "qtbase qtdeclarative"
39RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard \
40 ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}"
41
42do_configure_prepend() {
43 echo "qml.path = /opt/neptune" >> ${S}/neptuneui.pro
44}
45
46do_install_append() {
47 install -m 0755 -d ${D}${systemd_unitdir}/system
48 install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/
49
50 install -m 0644 ${S}/Main*.qml ${D}/opt/neptune
51 install -m 0644 ${S}/am-config.yaml ${D}/opt/neptune
52}
53
54PACKAGES =+ "${PN}-apps"
55RRECOMMENDS_${PN} += "${PN}-apps"
56
57FILES_${PN}-apps += "/opt/neptune/apps"
58FILES_${PN} += "\
59 /opt/neptune \
60 "
61
62SYSTEMD_SERVICE_${PN} = "neptune.service"
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb
deleted file mode 100644
index 502dd06..0000000
--- a/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ /dev/null
@@ -1,58 +0,0 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22DESCRIPTION = "Qt component for application lifecycle management"
23LICENSE = "GPLv3"
24LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=311507adb75495acc0b61d69109485ce"
25
26inherit qmake5
27
28SRC_URI = " \
29 git://codereview.qt-project.org/qt/qtapplicationmanager;branch=${BRANCH};protocol=ssh \
30 "
31
32SRCREV = "b7578378b578788c2ae9c60708a2908d3b090c16"
33BRANCH = "dev"
34
35DEPENDS = "qtbase qtdeclarative libyaml libarchive \
36 ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
37
38S = "${WORKDIR}/git"
39
40EXTRA_QMAKEVARS_PRE += "\
41 -config force-singleprocess \
42 -config enable-dummydata \
43 -config enable-ivi-logging \
44 -config install-prefix=/usr \
45 -config systemd-workaround \
46 "
47
48do_install_append() {
49 install -m 0755 -d ${D}/opt/am/
50 install -m 0644 ${S}/template-opt/am/config.yaml ${D}/opt/am/
51}
52
53FILES_${PN} += "\
54 /opt/am \
55 ${libdir}/appman \
56 ${datadir}/dbus-1"
57FILES_${PN}-dbg += "${libdir}/appman/.debug"
58FILES_${PN}-dev += "${OE_QMAKE_PATH_LIBS}/*.prl"
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb
deleted file mode 100644
index 038a0c4..0000000
--- a/recipes-qt/automotive/qtivi_git.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22DESCRIPTION = "Qt IVI"
23LICENSE = "LGPL-3.0"
24LIC_FILES_CHKSUM = "file://header.LGPL3-PELAGICORE;md5=0f5beb4df202cb6ef5cbc5296f3a3fa4"
25
26inherit qt5-module
27
28SRC_URI = " \
29 git://codereview.qt-project.org/qt/qtivi;branch=${BRANCH};protocol=ssh \
30 "
31
32SRCREV = "2d378320dc07b8b3ac9a9ce89b7f7a99caa72f8a"
33BRANCH = "dev"
34
35S = "${WORKDIR}/git"
36
37DEPENDS = "qtbase qtdeclarative"
diff --git a/recipes-qt/automotive/qtwebbrowser_git.bb b/recipes-qt/automotive/qtwebbrowser_git.bb
deleted file mode 100644
index 25494bf..0000000
--- a/recipes-qt/automotive/qtwebbrowser_git.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22DESCRIPTION = "Qt Web Browser"
23LICENSE = "GPLv3"
24LIC_FILES_CHKSUM = "file://src/main.cpp;md5=e78c6c33aa5ec2464456b72daf61ef9c;beginline=1;endline=36"
25
26inherit qmake5 sdk-sources
27
28SRC_URI = " \
29 git://codereview.qt-project.org/qt-apps/tqtc-qtwebbrowser;branch=${BRANCH};protocol=ssh;sdk-uri=5.6/Src/qtwebbrowser \
30 "
31
32SRCREV = "2e18b419a7084b1e39bf8749855768a1002e34de"
33BRANCH = "dev"
34
35S = "${WORKDIR}/git"
36
37DEPENDS = "qtbase qtdeclarative qtwebengine"
38
39FILES_${PN} += "/data/user/qt/qtwebbrowser"
40FILES_${PN}-dbg += "/data/user/qt/qtwebbrowser/.debug"
diff --git a/recipes-qt/images/b2qt-automotive-qt5-image.bb b/recipes-qt/images/b2qt-automotive-qt5-image.bb
deleted file mode 100644
index 004c2e8..0000000
--- a/recipes-qt/images/b2qt-automotive-qt5-image.bb
+++ /dev/null
@@ -1,50 +0,0 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22DESCRIPTION = "B2Qt Automotive Qt5 image"
23LICENSE = "QtEnterprise"
24LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9"
25PR = "r0"
26
27DEPLOY_CONF_TYPE = "Automotive"
28
29IMAGE_FEATURES += "\
30 package-management \
31 ssh-server-dropbear \
32 tools-debug \
33 debug-tweaks \
34 hwcodecs \
35 "
36
37inherit core-image
38inherit bootfs-image
39
40MACHINE_EXTRA_INSTALL_QT ?= ""
41
42IMAGE_INSTALL += "\
43 ${MACHINE_EXTRA_INSTALL_QT} \
44 packagegroup-b2qt-embedded-base \
45 packagegroup-b2qt-embedded-tools \
46 ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \
47 ${@base_contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \
48 packagegroup-b2qt-qt5-modules \
49 packagegroup-b2qt-automotive-addons \
50 "
diff --git a/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb b/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb
deleted file mode 100644
index 945a330..0000000
--- a/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22DESCRIPTION = "B2Qt embedded Qt5 SDK toolchain"
23
24LICENSE = "QtEnterprise"
25LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9"
26
27inherit populate_b2qt_qt5_sdk
28
29TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host"
30TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target \
31 packagegroup-b2qt-automotive-qt5-toolchain-target"