summaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-08-22 16:17:30 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-08-24 10:54:52 +0000
commite245c1dc8fe450fe9aeb5e505c90ba6dadf365d1 (patch)
tree8a0c7296e7f6655e620427d7f05e6a7adad3c258 /recipes-qt
parentaf902739757f9581473009ad8668fc64cc92e279 (diff)
downloadmeta-boot2qt-e245c1dc8fe450fe9aeb5e505c90ba6dadf365d1.tar.gz
Reuse qt5-git.inc in automotive recipes
Instead of using codereview.qt-project.org directly, reuse qt5-git.inc from meta-qt5 that defines git url to be used which simplyfies the recipes. Also cleanup unnecessary use of sdk-sources for opened repos. Change-Id: I80e02c9aba600eb41e2618f377e878fd8ecead11 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/automotive/neptune-ui_git.bb12
-rw-r--r--recipes-qt/automotive/qmllive-target_git.bb43
-rw-r--r--recipes-qt/automotive/qtapplicationmanager_git.bb10
-rw-r--r--recipes-qt/automotive/qtivi_git.bb10
-rw-r--r--recipes-qt/automotive/qtwebbrowser_git.bb11
5 files changed, 50 insertions, 36 deletions
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb
index 70f213b..66703c6 100644
--- a/recipes-qt/automotive/neptune-ui_git.bb
+++ b/recipes-qt/automotive/neptune-ui_git.bb
@@ -31,17 +31,17 @@ DESCRIPTION = "Neptune IVI UI"
31LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1" 31LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=bc0cb4bfd3f72b3fe47b2b2d0d89762c" 32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=bc0cb4bfd3f72b3fe47b2b2d0d89762c"
33 33
34inherit qt5-module sdk-sources systemd 34inherit qt5-module systemd
35require recipes-qt/qt5/qt5-git.inc
35 36
36SRC_URI = " \ 37QT_MODULE = "qt-apps-neptune-ui"
37 git://codereview.qt-project.org/qt-apps/neptune-ui;branch=${BRANCH};protocol=http \ 38QT_MODULE_BRANCH = "master"
39
40SRC_URI += " \
38 file://neptune.service \ 41 file://neptune.service \
39 " 42 "
40 43
41SRCREV = "3d36a7b8e53770c91db60cec9586ef572a2f2814" 44SRCREV = "3d36a7b8e53770c91db60cec9586ef572a2f2814"
42BRANCH = "master"
43
44S = "${WORKDIR}/git"
45 45
46DEPENDS = "qtbase qtdeclarative" 46DEPENDS = "qtbase qtdeclarative"
47RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard \ 47RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard \
diff --git a/recipes-qt/automotive/qmllive-target_git.bb b/recipes-qt/automotive/qmllive-target_git.bb
index efcac4d..7819941 100644
--- a/recipes-qt/automotive/qmllive-target_git.bb
+++ b/recipes-qt/automotive/qmllive-target_git.bb
@@ -1,19 +1,48 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
1DESCRIPTION = "QML Live target runtime" 30DESCRIPTION = "QML Live target runtime"
2 31
3LICENSE = "GPL-3.0" 32LICENSE = "GPL-3.0"
4LIC_FILES_CHKSUM = "file://../../LICENSE.GPL3;md5=75cd0dbc6f2d24e7eeb128ff59b74f4c" 33LIC_FILES_CHKSUM = "file://../../LICENSE.GPL3;md5=75cd0dbc6f2d24e7eeb128ff59b74f4c"
5 34
6inherit qmake5 sdk-sources 35inherit qmake5
36require recipes-qt/qt5/qt5-git.inc
7 37
8FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" 38QT_MODULE = "qt-apps-qmllive"
39QT_MODULE_BRANCH = "master"
9 40
10SRC_URI = " \ 41SRC_URI += " \
11 git://codereview.qt-project.org/qt-apps/qmllive.git;branch=${BRANCH};protocol=ssh;name=tools \
12 file://qmllive-target.patch \ 42 file://qmllive-target.patch \
13" 43 "
14 44
15BRANCH = "master" 45SRCREV = "d0d41c71c4691a5f3e2b72e22917f314b4190ffc"
16SRCREV_tools="d0d41c71c4691a5f3e2b72e22917f314b4190ffc"
17 46
18S = "${WORKDIR}/git/src/runtime" 47S = "${WORKDIR}/git/src/runtime"
19 48
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb
index fd128bd..028df78 100644
--- a/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ b/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -31,21 +31,15 @@ DESCRIPTION = "Qt component for application lifecycle management"
31LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1" 31LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=317fda864ac33d41406ff3938c3e78d1" 32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=317fda864ac33d41406ff3938c3e78d1"
33 33
34inherit qmake5 sdk-sources 34inherit qmake5
35 35require recipes-qt/qt5/qt5-git.inc
36SRC_URI = " \
37 git://codereview.qt-project.org/qt/qtapplicationmanager;branch=${BRANCH};protocol=ssh \
38 "
39 36
40SRCREV = "8a4b17fade4507860919fbbf9ea42f813a26be76" 37SRCREV = "8a4b17fade4507860919fbbf9ea42f813a26be76"
41BRANCH = "5.7"
42 38
43DEPENDS = "qtbase qtdeclarative libyaml libarchive \ 39DEPENDS = "qtbase qtdeclarative libyaml libarchive \
44 ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" 40 ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
45RDEPENDS_${PN} = "libcrypto" 41RDEPENDS_${PN} = "libcrypto"
46 42
47S = "${WORKDIR}/git"
48
49EXTRA_QMAKEVARS_PRE += "\ 43EXTRA_QMAKEVARS_PRE += "\
50 ${@base_contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \ 44 ${@base_contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \
51 -config enable-dummydata \ 45 -config enable-dummydata \
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb
index b50defc..0c50457 100644
--- a/recipes-qt/automotive/qtivi_git.bb
+++ b/recipes-qt/automotive/qtivi_git.bb
@@ -35,15 +35,9 @@ LIC_FILES_CHKSUM = "file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
35 file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \ 35 file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
36 file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02" 36 file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02"
37 37
38inherit qt5-module sdk-sources 38inherit qt5-module
39 39require recipes-qt/qt5/qt5-git.inc
40SRC_URI = " \
41 git://codereview.qt-project.org/qt/qtivi;branch=${BRANCH};protocol=ssh \
42 "
43 40
44SRCREV = "ccc1f3af652e4f2785d9ac60eeae521130740b1a" 41SRCREV = "ccc1f3af652e4f2785d9ac60eeae521130740b1a"
45BRANCH = "5.7"
46
47S = "${WORKDIR}/git"
48 42
49DEPENDS = "qtbase qtdeclarative" 43DEPENDS = "qtbase qtdeclarative"
diff --git a/recipes-qt/automotive/qtwebbrowser_git.bb b/recipes-qt/automotive/qtwebbrowser_git.bb
index 8031aac..b06446e 100644
--- a/recipes-qt/automotive/qtwebbrowser_git.bb
+++ b/recipes-qt/automotive/qtwebbrowser_git.bb
@@ -31,16 +31,13 @@ DESCRIPTION = "Qt Web Browser"
31LICENSE = "GPL-3.0" 31LICENSE = "GPL-3.0"
32LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=a40e2bb02b1ac431f461afd03ff9d1d6" 32LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=a40e2bb02b1ac431f461afd03ff9d1d6"
33 33
34inherit qmake5 sdk-sources 34inherit qmake5
35require recipes-qt/qt5/qt5-git.inc
35 36
36SRC_URI = " \ 37QT_MODULE = "qt-apps-qtwebbrowser"
37 git://codereview.qt-project.org/qt-apps/qtwebbrowser;branch=${BRANCH};protocol=http;sdk-uri=5.7/Src/qtwebbrowser \ 38QT_MODULE_BRANCH = "dev"
38 "
39 39
40SRCREV = "023733af5523a5ad84359926224fa106001215f4" 40SRCREV = "023733af5523a5ad84359926224fa106001215f4"
41BRANCH = "dev"
42
43S = "${WORKDIR}/git"
44 41
45DEPENDS = "qtbase qtdeclarative qtwebengine" 42DEPENDS = "qtbase qtdeclarative qtwebengine"
46 43