summaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-10-31 16:17:43 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2016-11-03 14:11:31 +0000
commitd1014d8b2e40f36cd85d75cfd3732f6b124dab2f (patch)
tree790a176c00adbc30dd310a93ee6c2b559885e105 /recipes-qt
parent464002ea626da5febafcae705773077eba7f7b8a (diff)
downloadmeta-boot2qt-d1014d8b2e40f36cd85d75cfd3732f6b124dab2f.tar.gz
sdk: do not explicitly define Qt dependency packages
Until now, the toolchain used by CI has been created without Qt, but with all (best guess) Qt dependencies. Now toolchain is created with Qt and we get all Qt dependencies correctly into the toolchain. As a consequence, CI will now need to build Qt, which has not been covered in CI before. The difference between embedded-sdk and embedded-qt5-sdk is that the former does not include files needed for debugging. Change-Id: Ie2be156c07e51119c0d4782494d6bcde6f34ed60 Reviewed-by: Risto Avila <risto.avila@qt.io>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/meta/meta-toolchain-b2qt-embedded-sdk.bb32
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb6
2 files changed, 35 insertions, 3 deletions
diff --git a/recipes-qt/meta/meta-toolchain-b2qt-embedded-sdk.bb b/recipes-qt/meta/meta-toolchain-b2qt-embedded-sdk.bb
new file mode 100644
index 0000000..777bffe
--- /dev/null
+++ b/recipes-qt/meta/meta-toolchain-b2qt-embedded-sdk.bb
@@ -0,0 +1,32 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30require recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb
31
32SDKIMAGE_FEATURES = "dev-pkgs"
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
index 6900190..6c1f022 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
@@ -35,11 +35,11 @@ inherit packagegroup qtquickcompiler
35 35
36PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1" 36PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
37 37
38MACHINE_EXTRA_INSTALL_QT_SDK ?= "" 38MACHINE_EXTRA_INSTALL_SDK ?= ""
39 39
40RDEPENDS_${PN} += " \ 40RDEPENDS_${PN} += " \
41 ${MACHINE_EXTRA_INSTALL_QT_SDK} \ 41 ${MACHINE_EXTRA_INSTALL_SDK} \
42 packagegroup-b2qt-embedded-toolchain-target \ 42 packagegroup-core-standalone-sdk-target \
43 \ 43 \
44 qt3d-dev \ 44 qt3d-dev \
45 qtbase-dev \ 45 qtbase-dev \