summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-08-18 15:54:29 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-08-22 11:08:35 +0000
commit0f967048d5bd99ffacfb9893b76818293aaaa8a0 (patch)
tree26fe07810d3a093e5183cb788c5e982fac20ecd1 /recipes-qt/qt5
parent39b77b9a9437f471d00269c3fbf2177d07045386 (diff)
downloadmeta-boot2qt-0f967048d5bd99ffacfb9893b76818293aaaa8a0.tar.gz
Update Qt5 submodules
Moved some of the addon recipes to be under qt5 folder, so that update-qt5-modules.sh script will work for those as well. Using latest revision from meta-qt5 and applied necessary changes to qt5 recipes. Change-Id: I802ca2e4ea67bde10c3b065365d25f1e543da181 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bbappend2
-rw-r--r--recipes-qt/qt5/qt3d_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtbase_git.bbappend4
-rw-r--r--recipes-qt/qt5/qtcanvas3d_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtcharts_git.bb31
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtdatavis3d_git.bb31
-rw-r--r--recipes-qt/qt5/qtdeclarative-render2d_git.bb31
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtquickcompiler_git.bb39
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb6
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtsensors_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb6
-rw-r--r--recipes-qt/qt5/qtserialport_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bbappend2
-rw-r--r--recipes-qt/qt5/qttools_git.bbappend2
-rw-r--r--recipes-qt/qt5/qttranslations_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb67
-rw-r--r--recipes-qt/qt5/qtwayland-native_5.7-wip.bb8
-rw-r--r--recipes-qt/qt5/qtwayland-native_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtwayland_5.7-wip.bb8
-rw-r--r--recipes-qt/qt5/qtwayland_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtwebchannel_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bbappend4
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bbappend2
32 files changed, 246 insertions, 31 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bbappend b/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
index 326bdec..ae8e6f4 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
@@ -19,7 +19,7 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22SRCREV = "540978288ea0f6ed0b166bb9207f427a4c825ab6" 22SRCREV = "17d68c4fc371c32bd58d0a94ac63f0170edaf29e"
23 23
24FILESEXTRAPATHS_prepend := "${THISDIR}/qtbase:" 24FILESEXTRAPATHS_prepend := "${THISDIR}/qtbase:"
25 25
diff --git a/recipes-qt/qt5/qt3d_git.bbappend b/recipes-qt/qt5/qt3d_git.bbappend
index f7ae884..349ef9a 100644
--- a/recipes-qt/qt5/qt3d_git.bbappend
+++ b/recipes-qt/qt5/qt3d_git.bbappend
@@ -25,4 +25,4 @@ SRC_URI_append_class-target = " \
25 file://0001-Remove-qgltf.patch \ 25 file://0001-Remove-qgltf.patch \
26 " 26 "
27 27
28SRCREV = "2270fae50f8d69858b2df2287342c02a4cd5357c" 28SRCREV = "d3889211dc245d44dab25dcc9fbbc4b57e92ac33"
diff --git a/recipes-qt/qt5/qtbase-native_git.bbappend b/recipes-qt/qt5/qtbase-native_git.bbappend
index 31cc314..8d86d39 100644
--- a/recipes-qt/qt5/qtbase-native_git.bbappend
+++ b/recipes-qt/qt5/qtbase-native_git.bbappend
@@ -19,7 +19,7 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22SRCREV = "540978288ea0f6ed0b166bb9207f427a4c825ab6" 22SRCREV = "17d68c4fc371c32bd58d0a94ac63f0170edaf29e"
23 23
24FILESEXTRAPATHS_prepend := "${THISDIR}/qtbase:" 24FILESEXTRAPATHS_prepend := "${THISDIR}/qtbase:"
25 25
diff --git a/recipes-qt/qt5/qtbase_git.bbappend b/recipes-qt/qt5/qtbase_git.bbappend
index e2c4191..19cd2d6 100644
--- a/recipes-qt/qt5/qtbase_git.bbappend
+++ b/recipes-qt/qt5/qtbase_git.bbappend
@@ -19,7 +19,7 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22PACKAGECONFIG_GL = "gles2" 22PACKAGECONFIG_GL = "gles2 eglfs"
23PACKAGECONFIG += " \ 23PACKAGECONFIG += " \
24 accessibility \ 24 accessibility \
25 alsa \ 25 alsa \
@@ -45,7 +45,7 @@ do_configure_prepend() {
45 install -m 0644 ${WORKDIR}/oe-device-extra.pri ${S}/mkspecs 45 install -m 0644 ${WORKDIR}/oe-device-extra.pri ${S}/mkspecs
46} 46}
47 47
48SRCREV = "540978288ea0f6ed0b166bb9207f427a4c825ab6" 48SRCREV = "17d68c4fc371c32bd58d0a94ac63f0170edaf29e"
49 49
50# Temporarily here, until merged upstream 50# Temporarily here, until merged upstream
51PACKAGECONFIG[kms] = "-kms,-no-kms,drm virtual/egl" 51PACKAGECONFIG[kms] = "-kms,-no-kms,drm virtual/egl"
diff --git a/recipes-qt/qt5/qtcanvas3d_git.bbappend b/recipes-qt/qt5/qtcanvas3d_git.bbappend
index 7a16176..95ef942 100644
--- a/recipes-qt/qt5/qtcanvas3d_git.bbappend
+++ b/recipes-qt/qt5/qtcanvas3d_git.bbappend
@@ -19,4 +19,4 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22SRCREV = "72312730a7507f77898df0876b9437c43587e1d1" 22SRCREV = "2778071f6c80b5397a183db37114aef881ade855"
diff --git a/recipes-qt/qt5/qtcharts_git.bb b/recipes-qt/qt5/qtcharts_git.bb
new file mode 100644
index 0000000..4b7a38a
--- /dev/null
+++ b/recipes-qt/qt5/qtcharts_git.bb
@@ -0,0 +1,31 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22DESCRIPTION = "Qt Charts"
23LICENSE = "QtEnterprise"
24LIC_FILES_CHKSUM = "file://src/charts/qchart.h;md5=a712f087e2146153f45db2e8eb1a3985;beginline=1;endline=17"
25
26inherit qt5-module qtquickcompiler
27require recipes-qt/qt5/qt5-git.inc
28
29SRCREV = "c6d72bb6ebd860a38aac2e557bca330b0d5b1926"
30
31DEPENDS = "qtbase qtdeclarative qtmultimedia"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bbappend b/recipes-qt/qt5/qtconnectivity_git.bbappend
index 018157e..934b40f 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bbappend
+++ b/recipes-qt/qt5/qtconnectivity_git.bbappend
@@ -19,4 +19,4 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22SRCREV = "7393531856058a8a0fe440d3a64728248958ac81" 22SRCREV = "f5fe6ce47841be34d4b851725d80133ff6d14fee"
diff --git a/recipes-qt/qt5/qtdatavis3d_git.bb b/recipes-qt/qt5/qtdatavis3d_git.bb
new file mode 100644
index 0000000..9b9f239
--- /dev/null
+++ b/recipes-qt/qt5/qtdatavis3d_git.bb
@@ -0,0 +1,31 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22DESCRIPTION = "Qt Data Visualization"
23LICENSE = "QtEnterprise"
24LIC_FILES_CHKSUM = "file://src/datavisualization/global/qdatavisualizationglobal.h;md5=80b80e41be7c22f5b90fc96163b7d1bf;beginline=1;endline=17"
25
26inherit qt5-module
27require recipes-qt/qt5/qt5-git.inc
28
29SRCREV = "4d4a9609fab58da304e4c13b9a37531116a4fadb"
30
31DEPENDS += "qtbase qtdeclarative qtmultimedia"
diff --git a/recipes-qt/qt5/qtdeclarative-render2d_git.bb b/recipes-qt/qt5/qtdeclarative-render2d_git.bb
new file mode 100644
index 0000000..1c45cb8
--- /dev/null
+++ b/recipes-qt/qt5/qtdeclarative-render2d_git.bb
@@ -0,0 +1,31 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22DESCRIPTION = "Qt Quick 2D Rendender"
23LICENSE = "QtEnterprise"
24LIC_FILES_CHKSUM = "file://src/plugins/scenegraph/softwarecontext/softwarelayer.cpp;md5=1f253bc897054feebffbaf70ecd49af4;beginline=1;endline=17"
25
26inherit qt5-module
27require recipes-qt/qt5/qt5-git.inc
28
29SRCREV = "334ca348b0badb284a1ade66b61bdc588da64e33"
30
31DEPENDS = "qtbase qtdeclarative"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bbappend b/recipes-qt/qt5/qtdeclarative_git.bbappend
index 76a1d42..8450938 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bbappend
+++ b/recipes-qt/qt5/qtdeclarative_git.bbappend
@@ -19,4 +19,4 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22SRCREV = "9b1231ca3d21ade574a8a7cf3f0805a8b520bcd5" 22SRCREV = "b1eeb7cdde17f70e8e9ad3c610d6492f3ca70717"
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bbappend b/recipes-qt/qt5/qtgraphicaleffects_git.bbappend
index f7b6d74..f164c73 100644
--- a/recipes-qt/qt5/qtgraphicaleffects_git.bbappend
+++ b/recipes-qt/qt5/qtgraphicaleffects_git.bbappend
@@ -19,4 +19,4 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22SRCREV = "d01a936b6454834e8ead7acc5838ee5c66541a55" 22SRCREV = "0b68e91d68902c4d05d0bb8aa045ae76c4e8c9b5"
diff --git a/recipes-qt/qt5/qtimageformats_git.bbappend b/recipes-qt/qt5/qtimageformats_git.bbappend
index 9a83783..afa85cb 100644
--- a/recipes-qt/qt5/qtimageformats_git.bbappend
+++ b/recipes-qt/qt5/qtimageformats_git.bbappend
@@ -19,4 +19,4 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22SRCREV = "cbf2d7e7696a4a08360c2004dfcbb8be7c1d2edb" 22SRCREV = "d7bdc138b89bf0c52ba9ddf22b34d2ccd06b3936"
diff --git a/recipes-qt/qt5/qtlocation_git.bbappend b/recipes-qt/qt5/qtlocation_git.bbappend
index 8397e50..3f93547 100644
--- a/recipes-qt/qt5/qtlocation_git.bbappend
+++ b/recipes-qt/qt5/qtlocation_git.bbappend
@@ -24,4 +24,4 @@ PACKAGECONFIG += "gypsy"
24EXTRA_QMAKEVARS_PRE_emulator += "CONFIG+=simulator" 24EXTRA_QMAKEVARS_PRE_emulator += "CONFIG+=simulator"
25DEPENDS_emulator += "qtsimulator" 25DEPENDS_emulator += "qtsimulator"
26 26
27SRCREV = "2bdeea286037e5ea0d8ba0d2ad59bdf1eaae1054" 27SRCREV = "fafc158427e9d54298ce5c3419c1d4b6ec3b946e"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bbappend b/recipes-qt/qt5/qtmultimedia_git.bbappend
index 818bc01..ecc7f15 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bbappend
+++ b/recipes-qt/qt5/qtmultimedia_git.bbappend
@@ -23,4 +23,4 @@ PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)
23 ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)} \ 23 ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)} \
24 ${@bb.utils.contains('DISTRO_FEATURES', 'gstreamer010', 'gstreamer010', 'gstreamer', d)}" 24 ${@bb.utils.contains('DISTRO_FEATURES', 'gstreamer010', 'gstreamer010', 'gstreamer', d)}"
25 25
26SRCREV = "711efc552d65f22b262e049c5a046198377519dc" 26SRCREV = "c9de25fa342ff8066d49541179c30d0ce45950b4"
diff --git a/recipes-qt/qt5/qtquickcompiler_git.bb b/recipes-qt/qt5/qtquickcompiler_git.bb
new file mode 100644
index 0000000..6018770
--- /dev/null
+++ b/recipes-qt/qt5/qtquickcompiler_git.bb
@@ -0,0 +1,39 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22DESCRIPTION = "Qt Quick Compiler"
23LICENSE = "QtEnterprise"
24LIC_FILES_CHKSUM = "file://compiler/qtquickcompiler.h;md5=02f6307ab0d6c4bd38a1540f16ea705d;beginline=1;endline=17"
25
26inherit qt5-module
27
28SRC_URI = " \
29 git://codereview.qt-project.org/qt/tqtc-qmlcompiler;branch=${BRANCH};protocol=ssh \
30 "
31
32SRCREV = "a2eac30f3be41447af1c9f2c3f3c841b68ca4d9c"
33BRANCH = "5.6"
34
35S = "${WORKDIR}/git"
36
37DEPENDS = "qtbase qtdeclarative"
38
39BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index 26aa40e..c6dec9f 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -24,14 +24,14 @@ require recipes-qt/qt5/qt5-git.inc
24 24
25LICENSE = "GFDL-1.3 & (LGPL-3.0 | GPL-3.0)" 25LICENSE = "GFDL-1.3 & (LGPL-3.0 | GPL-3.0)"
26LIC_FILES_CHKSUM = " \ 26LIC_FILES_CHKSUM = " \
27 file://LICENSE.LGPLv3;md5=8ba7f2099d17d636d5fcc8303bb17587 \ 27 file://LICENSE.LGPLv3;md5=a37e6cd7102174853307e03e6edc5f30 \
28 file://LICENSE.GPLv3;md5=40f9bf30e783ddc201497165dfb32afb \ 28 file://LICENSE.GPLv3;md5=88e2b9117e6be406b5ed6ee4ca99a705 \
29 file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ 29 file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
30" 30"
31 31
32DEPENDS += "qtbase qtxmlpatterns qtdeclarative qtgraphicaleffects" 32DEPENDS += "qtbase qtxmlpatterns qtdeclarative qtgraphicaleffects"
33 33
34SRCREV = "6ea6881ec8847dc99e05534769d6fe6198f56ead" 34SRCREV = "e93c73c0aa15cd973e008a04a70a7c69719ad244"
35 35
36FILES_${PN}-qmldesigner += " \ 36FILES_${PN}-qmldesigner += " \
37 ${OE_QMAKE_PATH_QML}/*/*/*/designer \ 37 ${OE_QMAKE_PATH_QML}/*/*/*/designer \
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bbappend b/recipes-qt/qt5/qtquickcontrols_git.bbappend
index a52513c..e0b892d 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bbappend
+++ b/recipes-qt/qt5/qtquickcontrols_git.bbappend
@@ -21,4 +21,4 @@
21 21
22FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 22FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
23 23
24SRCREV = "fcc9c0206433c5c940a0872447899743d1a9996a" 24SRCREV = "c0f58d5283ce981b8cfbc43f602a3b6553e26ce2"
diff --git a/recipes-qt/qt5/qtsensors_git.bbappend b/recipes-qt/qt5/qtsensors_git.bbappend
index dc59a6a..30e96b2 100644
--- a/recipes-qt/qt5/qtsensors_git.bbappend
+++ b/recipes-qt/qt5/qtsensors_git.bbappend
@@ -22,4 +22,4 @@
22EXTRA_QMAKEVARS_PRE_emulator += "SENSORS_PLUGINS=simulator" 22EXTRA_QMAKEVARS_PRE_emulator += "SENSORS_PLUGINS=simulator"
23DEPENDS_emulator += "qtsimulator" 23DEPENDS_emulator += "qtsimulator"
24 24
25SRCREV = "b08c3e69e3e82014b0f16b1ff94e5edd31d5c2c6" 25SRCREV = "8b79fc4ee1c0510c13dc6f1494f37727e3f8c0cf"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index cfb710c..491781c 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -24,11 +24,11 @@ require recipes-qt/qt5/qt5-git.inc
24 24
25LICENSE = "GFDL-1.3 & (LGPL-3.0 | GPL-2.0)" 25LICENSE = "GFDL-1.3 & (LGPL-3.0 | GPL-2.0)"
26LIC_FILES_CHKSUM = " \ 26LIC_FILES_CHKSUM = " \
27 file://LICENSE.LGPLv3;md5=b8c75190712063cde04e1f41b6fdad98 \ 27 file://LICENSE.LGPLv3;md5=e0459b45c5c4840b353141a8bbed91f0 \
28 file://LICENSE.GPLv2;md5=05832301944453ec79e40ba3c3cfceec \ 28 file://LICENSE.GPLv2;md5=c96076271561b0e3785dad260634eaa8 \
29 file://LICENSE.FDL;md5=f70ee9a6c44ae8917586fea34dff0ab5 \ 29 file://LICENSE.FDL;md5=f70ee9a6c44ae8917586fea34dff0ab5 \
30" 30"
31 31
32DEPENDS += "qtbase qtserialport" 32DEPENDS += "qtbase qtserialport"
33 33
34SRCREV = "ec7b4b226818fa39646ec9c619b9df995952ea9c" 34SRCREV = "0c63b3a441437a8bc42770d360a6696bbf11cd2d"
diff --git a/recipes-qt/qt5/qtserialport_git.bbappend b/recipes-qt/qt5/qtserialport_git.bbappend
index ef91dc4..7fbdf67 100644
--- a/recipes-qt/qt5/qtserialport_git.bbappend
+++ b/recipes-qt/qt5/qtserialport_git.bbappend
@@ -19,4 +19,4 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22SRCREV = "c1355ae41ee46437e9d6583dc4ea452a82b6b53b" 22SRCREV = "b0e3e7469cf5249bb395d044c5344bbe88884553"
diff --git a/recipes-qt/qt5/qtsvg_git.bbappend b/recipes-qt/qt5/qtsvg_git.bbappend
index c486a2d..755a49b 100644
--- a/recipes-qt/qt5/qtsvg_git.bbappend
+++ b/recipes-qt/qt5/qtsvg_git.bbappend
@@ -19,4 +19,4 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22SRCREV = "0e69a7c86f1908bc282362ec59f0ccf97d35d63a" 22SRCREV = "2d55b4996eaa26c973afdf15f6f703c0a1840a96"
diff --git a/recipes-qt/qt5/qttools_git.bbappend b/recipes-qt/qt5/qttools_git.bbappend
index 232f920..4234480 100644
--- a/recipes-qt/qt5/qttools_git.bbappend
+++ b/recipes-qt/qt5/qttools_git.bbappend
@@ -19,4 +19,4 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22SRCREV = "2d838dd06ebacc58c620614719067f6dac5e7418" 22SRCREV = "85197ddb8d6da0e5cf74b8d945c076d4db3986a8"
diff --git a/recipes-qt/qt5/qttranslations_git.bbappend b/recipes-qt/qt5/qttranslations_git.bbappend
index aeac682..f8021a5 100644
--- a/recipes-qt/qt5/qttranslations_git.bbappend
+++ b/recipes-qt/qt5/qttranslations_git.bbappend
@@ -19,4 +19,4 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22SRCREV = "efa6513bbf2515fbe6ab7b365e9597a8900ae279" 22SRCREV = "4925f90e9ceb0b4081649d1fc1eec10beb65f722"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
new file mode 100644
index 0000000..ef78418
--- /dev/null
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -0,0 +1,67 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22DESCRIPTION = "Qt Virtual Keyboard"
23LICENSE = "QtEnterprise"
24LIC_FILES_CHKSUM = "file://src/virtualkeyboard/plugin.cpp;md5=8913d0b71519756d2e83db02b9629bbd;beginline=1;endline=17"
25
26inherit qt5-module qtquickcompiler
27require recipes-qt/qt5/qt5-git.inc
28
29SRCREV = "68c30e00b0d9850643611d5ba9c29a247ccd44ec"
30
31DEPENDS = "qtbase qtdeclarative qtsvg hunspell"
32
33PACKAGECONFIG ?= "lipi-toolkit lang-all"
34PACKAGECONFIG[t9write] = "CONFIG+=t9write"
35PACKAGECONFIG[lipi-toolkit] = "CONFIG+=lipi-toolkit"
36PACKAGECONFIG[lang-all] = "CONFIG+=lang-all"
37PACKAGECONFIG[lang-ar_AR] = "CONFIG+=lang-ar_AR"
38PACKAGECONFIG[lang-da_DK] = "CONFIG+=lang-da_DK"
39PACKAGECONFIG[lang-de_DE] = "CONFIG+=lang-de_DE"
40PACKAGECONFIG[lang-en_GB] = "CONFIG+=lang-en_GB"
41PACKAGECONFIG[lang-es_ES] = "CONFIG+=lang-es_ES"
42PACKAGECONFIG[lang-fa_FA] = "CONFIG+=lang-fa_FA"
43PACKAGECONFIG[lang-fi_FI] = "CONFIG+=lang-fi_FI"
44PACKAGECONFIG[lang-fr_FR] = "CONFIG+=lang-fr_FR"
45PACKAGECONFIG[lang-hi_IN] = "CONFIG+=lang-hi_IN"
46PACKAGECONFIG[lang-it_IT] = "CONFIG+=lang-it_IT"
47PACKAGECONFIG[lang-ja_JP] = "CONFIG+=lang-ja_JP"
48PACKAGECONFIG[lang-ko_KR] = "CONFIG+=lang-ko_KR"
49PACKAGECONFIG[lang-nb_NO] = "CONFIG+=lang-nb_NO"
50PACKAGECONFIG[lang-pl_PL] = "CONFIG+=lang-pl_PL"
51PACKAGECONFIG[lang-pt_PT] = "CONFIG+=lang-pt_PT"
52PACKAGECONFIG[lang-ru_RU] = "CONFIG+=lang-ru_RU"
53PACKAGECONFIG[lang-sv_SE] = "CONFIG+=lang-sv_SE"
54PACKAGECONFIG[lang-zh_CN] = "CONFIG+=lang-zh_CN"
55PACKAGECONFIG[lang-zh_TW] = "CONFIG+=lang-zh_TW"
56
57EXTRA_QMAKEVARS_PRE += "${EXTRA_OECONF}"
58EXTRA_QMAKEVARS_PRE += "${@base_contains('DISTRO_FEATURES', 'x11', '', 'CONFIG+=disable-desktop', d)}"
59
60PACKAGES += "${PN}-dictionaries"
61RRECOMMENDS_${PN} += "${PN}-dictionaries"
62FILES_${PN}-dictionaries = "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/*/*.dat"
63
64FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
65FILES_${PN}-dbg += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit/lib/.debug"
66INSANE_SKIP_${PN} += "libdir"
67INSANE_SKIP_${PN}-dbg += "libdir"
diff --git a/recipes-qt/qt5/qtwayland-native_5.7-wip.bb b/recipes-qt/qt5/qtwayland-native_5.7-wip.bb
index 455726a..a83d6dc 100644
--- a/recipes-qt/qt5/qtwayland-native_5.7-wip.bb
+++ b/recipes-qt/qt5/qtwayland-native_5.7-wip.bb
@@ -23,6 +23,14 @@ require recipes-qt/qt5/qtwayland-native_git.bb
23 23
24FILESEXTRAPATHS_append := "${COREBASE}/../meta-qt5/recipes-qt/qt5/qtwayland:" 24FILESEXTRAPATHS_append := "${COREBASE}/../meta-qt5/recipes-qt/qt5/qtwayland:"
25 25
26LIC_FILES_CHKSUM = " \
27 file://LICENSE.LGPLv21;md5=58a180e1cf84c756c29f782b3a485c29 \
28 file://LICENSE.LGPLv3;md5=b8c75190712063cde04e1f41b6fdad98 \
29 file://LICENSE.GPLv3;md5=40f9bf30e783ddc201497165dfb32afb \
30 file://LGPL_EXCEPTION.txt;md5=9625233da42f9e0ce9d63651a9d97654 \
31 file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
32"
33
26SRCREV = "2adae188cb916d5a6ffbee65abf4ee8144de9ec2" 34SRCREV = "2adae188cb916d5a6ffbee65abf4ee8144de9ec2"
27PV = "5.7-wip+git${SRCPV}" 35PV = "5.7-wip+git${SRCPV}"
28QT_MODULE_BRANCH = "wip-compositor-api" 36QT_MODULE_BRANCH = "wip-compositor-api"
diff --git a/recipes-qt/qt5/qtwayland-native_git.bbappend b/recipes-qt/qt5/qtwayland-native_git.bbappend
index 8849fd8..793ed1b 100644
--- a/recipes-qt/qt5/qtwayland-native_git.bbappend
+++ b/recipes-qt/qt5/qtwayland-native_git.bbappend
@@ -19,4 +19,4 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22SRCREV = "920387296abcead6fea2d801fb2f57c185657c47" 22SRCREV = "1bc3b0fdc8d934c1ab69a902054681896b56d672"
diff --git a/recipes-qt/qt5/qtwayland_5.7-wip.bb b/recipes-qt/qt5/qtwayland_5.7-wip.bb
index 2de879b..fb59bba 100644
--- a/recipes-qt/qt5/qtwayland_5.7-wip.bb
+++ b/recipes-qt/qt5/qtwayland_5.7-wip.bb
@@ -21,6 +21,14 @@
21 21
22require recipes-qt/qt5/qtwayland_git.bb 22require recipes-qt/qt5/qtwayland_git.bb
23 23
24LIC_FILES_CHKSUM = " \
25 file://LICENSE.LGPLv21;md5=58a180e1cf84c756c29f782b3a485c29 \
26 file://LICENSE.LGPLv3;md5=b8c75190712063cde04e1f41b6fdad98 \
27 file://LICENSE.GPLv3;md5=40f9bf30e783ddc201497165dfb32afb \
28 file://LGPL_EXCEPTION.txt;md5=9625233da42f9e0ce9d63651a9d97654 \
29 file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
30"
31
24SRCREV = "0b9967d0f16652b0c77d454923bb7a1423792658" 32SRCREV = "0b9967d0f16652b0c77d454923bb7a1423792658"
25PV = "5.7-wip+git${SRCPV}" 33PV = "5.7-wip+git${SRCPV}"
26QT_MODULE_BRANCH = "wip-compositor-api" 34QT_MODULE_BRANCH = "wip-compositor-api"
diff --git a/recipes-qt/qt5/qtwayland_git.bbappend b/recipes-qt/qt5/qtwayland_git.bbappend
index 8849fd8..793ed1b 100644
--- a/recipes-qt/qt5/qtwayland_git.bbappend
+++ b/recipes-qt/qt5/qtwayland_git.bbappend
@@ -19,4 +19,4 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22SRCREV = "920387296abcead6fea2d801fb2f57c185657c47" 22SRCREV = "1bc3b0fdc8d934c1ab69a902054681896b56d672"
diff --git a/recipes-qt/qt5/qtwebchannel_git.bbappend b/recipes-qt/qt5/qtwebchannel_git.bbappend
index 672745e..7e87e21 100644
--- a/recipes-qt/qt5/qtwebchannel_git.bbappend
+++ b/recipes-qt/qt5/qtwebchannel_git.bbappend
@@ -19,4 +19,4 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22SRCREV = "b06c69533baeb2f80897f72ed787b51e122ffafc" 22SRCREV = "3b28a6956cb3cab087481312dc82a907b118e0de"
diff --git a/recipes-qt/qt5/qtwebengine_git.bbappend b/recipes-qt/qt5/qtwebengine_git.bbappend
index a7920fd..0a094f4 100644
--- a/recipes-qt/qt5/qtwebengine_git.bbappend
+++ b/recipes-qt/qt5/qtwebengine_git.bbappend
@@ -25,5 +25,5 @@ SRC_URI_append_mx6 = " \
25 file://0001-Fix-slow-video-with-webengine-on-nitrogen6x.patch \ 25 file://0001-Fix-slow-video-with-webengine-on-nitrogen6x.patch \
26 " 26 "
27 27
28SRCREV_qtwebengine = "69351428413edb7a76ce2ca11634b1797e45e296" 28SRCREV_qtwebengine = "b7fde78d7822ed7f2221acfd9db15b3ff579e29d"
29SRCREV_chromium = "dc08e3972d36a63dd477de0de005b3e81a5674d9" 29SRCREV_chromium = "696c084930b870a5b1fd7f176d4e7ccb3eff416c"
diff --git a/recipes-qt/qt5/qtwebsockets_git.bbappend b/recipes-qt/qt5/qtwebsockets_git.bbappend
index 8b8c9cd..274e4a4 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bbappend
+++ b/recipes-qt/qt5/qtwebsockets_git.bbappend
@@ -19,4 +19,4 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22SRCREV = "0637eb3f40440f90eb531561e26f3854463bdbb3" 22SRCREV = "ef7b03e3e5e20f89963bae799f7ecb753f332c34"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bbappend b/recipes-qt/qt5/qtxmlpatterns_git.bbappend
index 3150a1b..8594a95 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bbappend
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bbappend
@@ -19,4 +19,4 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22SRCREV = "23b764d34705d0f858e428e02c910637368b2694" 22SRCREV = "074571305e45d30066b199641eb5d0866e3b0a92"