summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtvirtualkeyboard_git.bbappend
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-06-01 13:48:48 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-06-06 05:49:35 +0000
commitd55a3a4ff2ea16b0663be0ec78dabde74ff4a206 (patch)
treec72442b71097f83ad7784f6c48463055b57d05bc /recipes-qt/qt5/qtvirtualkeyboard_git.bbappend
parentd92820c12827588507e111803638aaf819d57592 (diff)
downloadmeta-boot2qt-d55a3a4ff2ea16b0663be0ec78dabde74ff4a206.tar.gz
qt5: update submodules and meta-qt5
Disable SHA checking for Qt modules, so we can use sha1s from the release branch without breaking build after release. Change-Id: I1f016945caeed33b169945038418533f781a362a Reviewed-by: Dominik Holland <dominik.holland@pelagicore.com> Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'recipes-qt/qt5/qtvirtualkeyboard_git.bbappend')
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bbappend76
1 files changed, 76 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bbappend b/recipes-qt/qt5/qtvirtualkeyboard_git.bbappend
new file mode 100644
index 0000000..64321b9
--- /dev/null
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bbappend
@@ -0,0 +1,76 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30inherit qtquickcompiler
31
32SRCREV = "fd18b3e7b781680033b8dfed9476b0fc4a06dcc7"
33
34# To enabled Nuance T9 Write support, you need to provide the licensed components
35# and enable "t9write" in PACKAGECONFIG. This can be done in a separate .bbappend file.
36# for example:
37#T9WRITEPACKAGE = "${HOME}/Downloads/zzEval_QT_T9Write_Alpha_v750_20150916.zip"
38#SRC_URI += "file://${T9WRITEPACKAGE};subdir=git/src/virtualkeyboard/3rdparty/t9write"
39#PACKAGECONFIG = "t9write lang-all"
40
41PACKAGECONFIG ?= "lipi-toolkit lang-all hunspell"
42PACKAGECONFIG[hunspell] = ",CONFIG+=disable-hunspell,hunspell"
43PACKAGECONFIG[t9write] = "CONFIG+=t9write"
44PACKAGECONFIG[lipi-toolkit] = "CONFIG+=lipi-toolkit"
45PACKAGECONFIG[lang-all] = "CONFIG+=lang-all"
46PACKAGECONFIG[lang-ar_AR] = "CONFIG+=lang-ar_AR"
47PACKAGECONFIG[lang-da_DK] = "CONFIG+=lang-da_DK"
48PACKAGECONFIG[lang-de_DE] = "CONFIG+=lang-de_DE"
49PACKAGECONFIG[lang-en_GB] = "CONFIG+=lang-en_GB"
50PACKAGECONFIG[lang-es_ES] = "CONFIG+=lang-es_ES"
51PACKAGECONFIG[lang-fa_FA] = "CONFIG+=lang-fa_FA"
52PACKAGECONFIG[lang-fi_FI] = "CONFIG+=lang-fi_FI"
53PACKAGECONFIG[lang-fr_FR] = "CONFIG+=lang-fr_FR"
54PACKAGECONFIG[lang-hi_IN] = "CONFIG+=lang-hi_IN"
55PACKAGECONFIG[lang-it_IT] = "CONFIG+=lang-it_IT"
56PACKAGECONFIG[lang-ja_JP] = "CONFIG+=lang-ja_JP"
57PACKAGECONFIG[lang-ko_KR] = "CONFIG+=lang-ko_KR"
58PACKAGECONFIG[lang-nb_NO] = "CONFIG+=lang-nb_NO"
59PACKAGECONFIG[lang-pl_PL] = "CONFIG+=lang-pl_PL"
60PACKAGECONFIG[lang-pt_PT] = "CONFIG+=lang-pt_PT"
61PACKAGECONFIG[lang-ru_RU] = "CONFIG+=lang-ru_RU"
62PACKAGECONFIG[lang-sv_SE] = "CONFIG+=lang-sv_SE"
63PACKAGECONFIG[lang-zh_CN] = "CONFIG+=lang-zh_CN"
64PACKAGECONFIG[lang-zh_TW] = "CONFIG+=lang-zh_TW"
65
66EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
67EXTRA_QMAKEVARS_PRE += "${@base_contains('DISTRO_FEATURES', 'x11', '', 'CONFIG+=disable-desktop', d)}"
68
69PACKAGES += "${PN}-dictionaries"
70RRECOMMENDS_${PN} += "${PN}-dictionaries"
71FILES_${PN}-dictionaries = "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/*/*.dat"
72
73FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
74FILES_${PN}-dbg += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit/lib/.debug"
75INSANE_SKIP_${PN} += "libdir"
76INSANE_SKIP_${PN}-dbg += "libdir"