summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtquickcompiler_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-08-22 15:59:05 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-08-22 15:59:05 +0300
commit83b656eb3219ee37d95d6453d692562406fe7be0 (patch)
tree47b52b59932c23c4e9cfeb8bfc0a3e75c23117de /recipes-qt/qt5/qtquickcompiler_git.bb
parent1778a81a6d214b27f20cb5242b28d5c41fbbf5b6 (diff)
parent797b8c96bd53cd15b6540a989353f89d285c8de9 (diff)
downloadmeta-boot2qt-83b656eb3219ee37d95d6453d692562406fe7be0.tar.gz
Merge remote-tracking branch 'origin/fido' into jethro
* origin/fido: Correctly update qtquickcompiler SHA1 Reuse qt5-git.inc to define git repo location Remove automotive recipes Update Qt5 submodules Handle qtquickcompiler in update-qt5-modules.sh script Correctly use QtQuickCompiler when available Change git protocol from ssh to http Update qtdeclarative module Update boot2qt-demos version Conflicts: conf/distro/b2qt-auto.conf recipes-qt/automotive/gammaray_git.bb recipes-qt/automotive/neptune-ui/neptune.service recipes-qt/automotive/neptune-ui_git.bb recipes-qt/automotive/qtapplicationmanager_git.bb recipes-qt/automotive/qtivi_git.bb recipes-qt/automotive/qtwebbrowser_git.bb recipes-qt/b2qt-addons/b2qt-demos.bb recipes-qt/b2qt-addons/b2qt-launcher.bb recipes-qt/b2qt-addons/democompositor_git.bb recipes-qt/images/b2qt-automotive-qt5-image.bb recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb recipes-qt/qt5-addons/qtvirtualkeyboard_git.bb recipes-qt/qt5/nativesdk-qtbase_git.bbappend recipes-qt/qt5/qt3d_git.bbappend recipes-qt/qt5/qtbase-native_git.bbappend recipes-qt/qt5/qtbase_git.bbappend recipes-qt/qt5/qtcanvas3d_git.bbappend recipes-qt/qt5/qtcharts_git.bb recipes-qt/qt5/qtconnectivity_git.bbappend recipes-qt/qt5/qtdatavis3d_git.bb recipes-qt/qt5/qtdeclarative-render2d_git.bb recipes-qt/qt5/qtdeclarative_git.bbappend recipes-qt/qt5/qtgraphicaleffects_git.bbappend recipes-qt/qt5/qtimageformats_git.bbappend recipes-qt/qt5/qtlocation_git.bbappend recipes-qt/qt5/qtmultimedia_git.bbappend recipes-qt/qt5/qtquickcompiler_git.bb recipes-qt/qt5/qtquickcontrols2_git.bb recipes-qt/qt5/qtquickcontrols_git.bbappend recipes-qt/qt5/qtsensors_git.bbappend recipes-qt/qt5/qtserialbus_git.bb recipes-qt/qt5/qtserialport_git.bbappend recipes-qt/qt5/qtsvg_git.bbappend recipes-qt/qt5/qttools_git.bbappend recipes-qt/qt5/qttranslations_git.bbappend recipes-qt/qt5/qtvirtualkeyboard_git.bb recipes-qt/qt5/qtvirtualkeyboard_git.bbappend recipes-qt/qt5/qtwayland-native_5.7-wip.bb recipes-qt/qt5/qtwayland-native_git.bbappend recipes-qt/qt5/qtwayland_5.7-wip.bb recipes-qt/qt5/qtwayland_git.bbappend recipes-qt/qt5/qtwebchannel_git.bbappend recipes-qt/qt5/qtwebengine_git.bbappend recipes-qt/qt5/qtwebsockets_git.bbappend recipes-qt/qt5/qtxmlpatterns_git.bbappend scripts/manifest.xml Change-Id: Ibf7f89a35c9e19bd8cf81c49cb44f6fd454838b4
Diffstat (limited to 'recipes-qt/qt5/qtquickcompiler_git.bb')
-rw-r--r--recipes-qt/qt5/qtquickcompiler_git.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtquickcompiler_git.bb b/recipes-qt/qt5/qtquickcompiler_git.bb
new file mode 100644
index 0000000..564fc3d
--- /dev/null
+++ b/recipes-qt/qt5/qtquickcompiler_git.bb
@@ -0,0 +1,46 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Qt Quick Compiler"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://compiler/qtquickcompiler.h;md5=02f6307ab0d6c4bd38a1540f16ea705d;beginline=1;endline=17"
33
34inherit qt5-module
35
36SRC_URI = " \
37 git://codereview.qt-project.org/qt/tqtc-qmlcompiler;nobranch=1;protocol=ssh \
38 "
39
40SRCREV = "973a3d4c78c4435c34f1967a737e8b358c88f16f"
41
42S = "${WORKDIR}/git"
43
44DEPENDS = "qtbase qtdeclarative"
45
46BBCLASSEXTEND = "native nativesdk"