summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5-addons
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-06-01 17:58:41 +0300
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-06-03 11:19:23 +0300
commit623fe39f70996687f07888d6cea1f706c300986a (patch)
tree66da3e82041cb1b22390f14dd92c0ba4ba45b2f6 /recipes-qt/qt5-addons
parent4f2523addd2a4decbe82bb5dd66e5ba55d77626c (diff)
downloadmeta-boot2qt-623fe39f70996687f07888d6cea1f706c300986a.tar.gz
Add QtSimulator support
QtSimulator is added as dependency to Qt modules that support it, and some helper components are installed to emulator target. Change-Id: I878ffcfc6a8d9a579cb4a5a4e823fa7f0fa5a3cd Reviewed-by: Rainer Keller <rainer.keller@theqtcompany.com>
Diffstat (limited to 'recipes-qt/qt5-addons')
-rw-r--r--recipes-qt/qt5-addons/qtsimulator_1.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-qt/qt5-addons/qtsimulator_1.0.bb b/recipes-qt/qt5-addons/qtsimulator_1.0.bb
new file mode 100644
index 0000000..5f0c761
--- /dev/null
+++ b/recipes-qt/qt5-addons/qtsimulator_1.0.bb
@@ -0,0 +1,39 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "QtSimulator"
24LICENSE = "QtEnterprise"
25LIC_FILES_CHKSUM = "file://src/simulator/version.h;md5=ba04e32af7257890758a149b0c14d11a;beginline=1;endline=17"
26
27inherit qt5-module
28
29SRC_URI = " \
30 git://qt-gerrit.ci.local/QtRD-15810/b2qt-qtsimulator.git;branch=${BRANCH};protocol=ssh \
31 "
32
33# v1.0.8
34SRCREV = "faf8ea5cee8a4105b97c3f2ba4a4c828f03a70ab"
35BRANCH = "master"
36
37S = "${WORKDIR}/git"
38
39DEPENDS = "qtbase"