summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5-addons
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-02-05 15:50:21 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-02-12 10:11:38 +0000
commitcabaf4ef690ab5dcde901822edfd4fe5067497ac (patch)
treece006f10ef4ee9e36142c9f0a322b72ac3315f8f /recipes-qt/qt5-addons
parente91280bbcb99d7f4e3f79c2efe9c1fbc40b144fc (diff)
downloadmeta-boot2qt-cabaf4ef690ab5dcde901822edfd4fe5067497ac.tar.gz
qt5: Upgrade to Qt 5.11.0
QtQuickCompiler is now part of qtdeclarative, separate recipe is no longer needed. Keeping qtquickcompiler.bbclass still for backwards compatibility. Change-Id: I8e6a66b176fc17c4bb161ae4638125238518e22a Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'recipes-qt/qt5-addons')
-rw-r--r--recipes-qt/qt5-addons/qtquickcompiler-sdk.bb79
1 files changed, 0 insertions, 79 deletions
diff --git a/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb b/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb
deleted file mode 100644
index 1fad9f3..0000000
--- a/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb
+++ /dev/null
@@ -1,79 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Qt Quick Compiler using prebuilt binaries from Qt SDK"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
33
34inherit allarch qmake5_paths
35
36do_unpack[depends] += "p7zip-native:do_populate_sysroot"
37
38SRC_URI = "http://download.qt.io/development_releases/prebuilt/mingw_32/i686-4.9.2-release-posix-dwarf-rt_v3-rev1-runtime.7z"
39
40SRC_URI[md5sum] = "a7d673c4ad8bcef9e464ea5386492cb3"
41SRC_URI[sha256sum] = "f7e58b0fb1f5aa4c23eefdc60abb88cb642eaa272fb741dca23068c70ca86542"
42
43S = "${WORKDIR}"
44
45NATIVESDK_BINARY = "qtquickcompiler"
46NATIVESDK_BINARY_mingw32 = "qtquickcompiler.exe"
47
48do_install() {
49 install -d ${D}${OE_QMAKE_PATH_ARCHDATA}/mkspecs/features
50 install -m 0755 ${THISDIR}/qtquickcompiler-sdk/mkspecs/features/qtquickcompiler.prf ${D}${OE_QMAKE_PATH_ARCHDATA}/mkspecs/features
51 install -d ${D}${OE_QMAKE_PATH_ARCHDATA}/cmake/Qt5QuickCompiler
52 install -m 0644 ${THISDIR}/qtquickcompiler-sdk/lib/cmake/Qt5QuickCompiler/Qt5QuickCompilerConfig.cmake ${D}${OE_QMAKE_PATH_ARCHDATA}/cmake/Qt5QuickCompiler
53
54 if [ "${PN}" = "qtquickcompiler-sdk-native" ]; then
55 install -d ${D}${OE_QMAKE_PATH_BINS}
56 install -m 0755 ${THISDIR}/qtquickcompiler-sdk/bin/qtquickcompiler ${D}${OE_QMAKE_PATH_BINS}
57 elif [ "${PN}" = "nativesdk-qtquickcompiler-sdk" ]; then
58 install -d ${D}${OE_QMAKE_PATH_BINS}
59 install -m 0755 ${THISDIR}/qtquickcompiler-sdk/bin/${NATIVESDK_BINARY} ${D}${OE_QMAKE_PATH_BINS}
60 fi
61
62 # Use the EffectivePath instead of installation path
63 sed -i -e 's|QT_HOST_BINS|QT_HOST_BINS/get|' ${D}${OE_QMAKE_PATH_ARCHDATA}/mkspecs/features/qtquickcompiler.prf
64}
65
66do_install_append_mingw32() {
67 if [ "${PN}" = "nativesdk-qtquickcompiler-sdk" ]; then
68 install -m 0644 ${WORKDIR}/libgcc_s_dw2-1.dll ${D}${OE_QMAKE_PATH_BINS}
69 fi
70}
71
72INHIBIT_PACKAGE_STRIP = "1"
73ALLOW_EMPTY_${PN} = "1"
74PACKAGES =+ "${PN}-tools"
75FILES_${PN}-tools = "${OE_QMAKE_PATH_BINS}"
76FILES_${PN}-dev = "${OE_QMAKE_PATH_ARCHDATA}"
77INSANE_SKIP_${PN} += "already-stripped"
78
79BBCLASSEXTEND = "native nativesdk"