summaryrefslogtreecommitdiffstats
path: root/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-03-31 11:01:04 +0300
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-05-12 14:47:11 +0300
commitae4b6421c0bb4771e2cedfcdadd44c04dc8e93f5 (patch)
treeacaecd3b089b341f87dd27384bb800c9b497148d /recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5.bb
parent5fcb893d078d718318ca94bf7f284ef35355c152 (diff)
downloadmeta-boot2qt-ae4b6421c0bb4771e2cedfcdadd44c04dc8e93f5.tar.gz
Build Qt5 and all addons
Use meta-qt5 layer to build Qt5, commercial addons and b2qt addons. Create new image and toolchain recipes with Qt5 content, so that the existing image and toolchain remain as-is without Qt5. Currently support only for imx6 targets. Change-Id: I398750dd1a62c6ff8ea216cfe364da273d8e9a77 Reviewed-by: Andy Nichols <andy.nichols@theqtcompany.com>
Diffstat (limited to 'recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5.bb')
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5.bb b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5.bb
new file mode 100644
index 0000000..970da82
--- /dev/null
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5.bb
@@ -0,0 +1,47 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Qt5 modules"
24LICENSE = "QtEnterprise"
25
26inherit packagegroup
27
28PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
29
30RDEPENDS_${PN} += " \
31 qtbase \
32 qtbase-fonts \
33 qtconnectivity \
34 qtdeclarative \
35 qtdeclarative-tools \
36 qtgraphicaleffects \
37 qtimageformats \
38 qtlocation \
39 qtmultimedia \
40 qtsensors \
41 qtserialport \
42 qtsvg \
43 qtwebsockets \
44 qtxmlpatterns \
45 qtquickcontrols \
46 qtwebengine \
47 "