summaryrefslogtreecommitdiffstats
path: root/recipes-qt/meta
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-03-31 11:01:04 +0300
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-05-12 14:47:11 +0300
commitae4b6421c0bb4771e2cedfcdadd44c04dc8e93f5 (patch)
treeacaecd3b089b341f87dd27384bb800c9b497148d /recipes-qt/meta
parent5fcb893d078d718318ca94bf7f284ef35355c152 (diff)
downloadmeta-boot2qt-ae4b6421c0bb4771e2cedfcdadd44c04dc8e93f5.tar.gz
Build Qt5 and all addons
Use meta-qt5 layer to build Qt5, commercial addons and b2qt addons. Create new image and toolchain recipes with Qt5 content, so that the existing image and toolchain remain as-is without Qt5. Currently support only for imx6 targets. Change-Id: I398750dd1a62c6ff8ea216cfe364da273d8e9a77 Reviewed-by: Andy Nichols <andy.nichols@theqtcompany.com>
Diffstat (limited to 'recipes-qt/meta')
-rw-r--r--recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb b/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb
new file mode 100644
index 0000000..1199da9
--- /dev/null
+++ b/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt5-sdk.bb
@@ -0,0 +1,31 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "B2Qt embedded Qt5 SDK toolchain"
24PR = "r0"
25LICENSE = "QtEnterprise"
26LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9"
27
28inherit populate_sdk populate_sdk_qt5
29
30TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host"
31TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target"