summaryrefslogtreecommitdiffstats
path: root/recipes-qt/images
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-11-19 16:30:05 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-11-25 08:46:35 +0000
commitde715c72f99850dc959ecf9282fc356deebd67af (patch)
tree664aee1ae8112577bd1e57fb5f6b239f8f90bbf5 /recipes-qt/images
parent86d8d137d9765a2333dda4f2ccef8422eab1b125 (diff)
downloadmeta-boot2qt-de715c72f99850dc959ecf9282fc356deebd67af.tar.gz
automotive: create new automotive specific image
Reuse most parts from b2qt image, only difference is the demo addons which will be different for the automotive image. For now, add no demo app, so image boots to empty screen. Change-Id: I67bbe8724422c9ea86dae6e4d5f8f38d3d567ba1 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'recipes-qt/images')
-rw-r--r--recipes-qt/images/b2qt-automotive-qt5-image.bb49
-rw-r--r--recipes-qt/images/b2qt-embedded-qt5-image.bb4
2 files changed, 51 insertions, 2 deletions
diff --git a/recipes-qt/images/b2qt-automotive-qt5-image.bb b/recipes-qt/images/b2qt-automotive-qt5-image.bb
new file mode 100644
index 0000000..6aafc77
--- /dev/null
+++ b/recipes-qt/images/b2qt-automotive-qt5-image.bb
@@ -0,0 +1,49 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "B2Qt Automotive Qt5 image"
24LICENSE = "QtEnterprise"
25LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9"
26PR = "r0"
27
28IMAGE_FEATURES += "\
29 package-management \
30 ssh-server-dropbear \
31 tools-debug \
32 debug-tweaks \
33 hwcodecs \
34 "
35
36inherit core-image
37inherit bootfs-image
38
39MACHINE_EXTRA_INSTALL_QT ?= ""
40
41IMAGE_INSTALL += "\
42 ${MACHINE_EXTRA_INSTALL_QT} \
43 packagegroup-b2qt-embedded-base \
44 packagegroup-b2qt-embedded-tools \
45 ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \
46 ${@base_contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \
47 packagegroup-b2qt-qt5-modules \
48 packagegroup-b2qt-automotive-addons \
49 "
diff --git a/recipes-qt/images/b2qt-embedded-qt5-image.bb b/recipes-qt/images/b2qt-embedded-qt5-image.bb
index 924ba61..8c986ac 100644
--- a/recipes-qt/images/b2qt-embedded-qt5-image.bb
+++ b/recipes-qt/images/b2qt-embedded-qt5-image.bb
@@ -44,6 +44,6 @@ IMAGE_INSTALL += "\
44 packagegroup-b2qt-embedded-tools \ 44 packagegroup-b2qt-embedded-tools \
45 ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \ 45 ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \
46 ${@base_contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \ 46 ${@base_contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \
47 packagegroup-b2qt-embedded-qt5 \ 47 packagegroup-b2qt-qt5-modules \
48 packagegroup-b2qt-embedded-qt5-addons \ 48 packagegroup-b2qt-embedded-addons \
49 " 49 "