summaryrefslogtreecommitdiffstats
path: root/recipes-qt/images
diff options
context:
space:
mode:
authorGatis Paeglis <gatis.paeglis@theqtcompany.com>2016-03-14 15:28:03 +0100
committerGatis Paeglis <gatis.paeglis@theqtcompany.com>2016-03-16 13:05:33 +0000
commit69074fbee24ecfcaf304cfcb07cadf78b3ec2cda (patch)
treea582713ce3696ac7ff3d891ade9d78c22f857bb7 /recipes-qt/images
parent482d631b27aae54477c80d44660ddd23769cacf5 (diff)
downloadmeta-boot2qt-69074fbee24ecfcaf304cfcb07cadf78b3ec2cda.tar.gz
Use consistent mtime timestamps
This patch adds consistent_timestamps.bbclass which is a hackish way of resembling reproducible build - byte-for-byte identical binary packages from a given source. Naturally this is not a complete solution, but it fixes the issue described below. Real solution for this should be done by the Yocto project itself. In OSTree each new update is checked out with all files and directories having mtime=0, this breaks fontconfig cache validity check (mtime embedded in the cache should match the containing directories mtime). Yocto generates this cache file in poky/meta/lib/oe/rootfs.py::create by calling self._run_intercepts() after all packages have been installed. These timestamps are nondeterministic as they depend on current system time. By using ROOTFS_POSTINSTALL_COMMAND hook we can ensure that these embedded time stamps have a known time, which is a basic property of reproducible build system. Change-Id: Ib2f130248f2e65db391d2b2f19ab5dac30a2cfb0 Task-number: QTEE-1081 Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
Diffstat (limited to 'recipes-qt/images')
-rw-r--r--recipes-qt/images/b2qt-automotive-qt5-image.bb1
-rw-r--r--recipes-qt/images/b2qt-embedded-qt5-image.bb1
2 files changed, 2 insertions, 0 deletions
diff --git a/recipes-qt/images/b2qt-automotive-qt5-image.bb b/recipes-qt/images/b2qt-automotive-qt5-image.bb
index 004c2e8..bbcb82d 100644
--- a/recipes-qt/images/b2qt-automotive-qt5-image.bb
+++ b/recipes-qt/images/b2qt-automotive-qt5-image.bb
@@ -36,6 +36,7 @@ IMAGE_FEATURES += "\
36 36
37inherit core-image 37inherit core-image
38inherit bootfs-image 38inherit bootfs-image
39inherit consistent_timestamps
39 40
40MACHINE_EXTRA_INSTALL_QT ?= "" 41MACHINE_EXTRA_INSTALL_QT ?= ""
41 42
diff --git a/recipes-qt/images/b2qt-embedded-qt5-image.bb b/recipes-qt/images/b2qt-embedded-qt5-image.bb
index 2909e38..6f82a8b 100644
--- a/recipes-qt/images/b2qt-embedded-qt5-image.bb
+++ b/recipes-qt/images/b2qt-embedded-qt5-image.bb
@@ -36,6 +36,7 @@ IMAGE_FEATURES += "\
36 36
37inherit core-image 37inherit core-image
38inherit bootfs-image 38inherit bootfs-image
39inherit consistent_timestamps
39 40
40MACHINE_EXTRA_INSTALL_QT ?= "" 41MACHINE_EXTRA_INSTALL_QT ?= ""
41 42