summaryrefslogtreecommitdiffstats
path: root/recipes-qt/images
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-11-01 10:13:58 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2016-11-03 14:11:34 +0000
commit57f2d6e8c7a518b50981674849014c1640022563 (patch)
treedbc82561185727d9d961cd79622b2dc9c0a45a8f /recipes-qt/images
parentd1014d8b2e40f36cd85d75cfd3732f6b124dab2f (diff)
downloadmeta-boot2qt-57f2d6e8c7a518b50981674849014c1640022563.tar.gz
images: do not explicitly define Qt dependency packages
Remove all Qt dependency packages from machine include files and base packagegroups, instead let packagemanager pull in all the needed dependent packages. Do not create tar image or bootfs, since they are not used anymore. The old base image is now renamed for CI usage and contains all the Qt dependent packages but without any Qt modules. This is achieved by first installing all the Qt modules (which pulls in all the dependencies) and then removing only Qt modules. Change-Id: I36d996d4531af42e955f19a487c22d0b90c5ada9 Reviewed-by: Risto Avila <risto.avila@qt.io>
Diffstat (limited to 'recipes-qt/images')
-rw-r--r--recipes-qt/images/b2qt-automotive-qt5-image.bb4
-rw-r--r--recipes-qt/images/b2qt-embedded-ci-image.bb74
-rw-r--r--recipes-qt/images/b2qt-embedded-qt5-image.bb4
3 files changed, 74 insertions, 8 deletions
diff --git a/recipes-qt/images/b2qt-automotive-qt5-image.bb b/recipes-qt/images/b2qt-automotive-qt5-image.bb
index b60d9a0..d0e13d5 100644
--- a/recipes-qt/images/b2qt-automotive-qt5-image.bb
+++ b/recipes-qt/images/b2qt-automotive-qt5-image.bb
@@ -43,13 +43,9 @@ IMAGE_FEATURES += "\
43 " 43 "
44 44
45inherit core-image 45inherit core-image
46inherit bootfs-image
47inherit consistent_timestamps 46inherit consistent_timestamps
48 47
49MACHINE_EXTRA_INSTALL_QT ?= ""
50
51IMAGE_INSTALL += "\ 48IMAGE_INSTALL += "\
52 ${MACHINE_EXTRA_INSTALL_QT} \
53 packagegroup-b2qt-embedded-base \ 49 packagegroup-b2qt-embedded-base \
54 packagegroup-b2qt-embedded-tools \ 50 packagegroup-b2qt-embedded-tools \
55 ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \ 51 ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \
diff --git a/recipes-qt/images/b2qt-embedded-ci-image.bb b/recipes-qt/images/b2qt-embedded-ci-image.bb
new file mode 100644
index 0000000..09dbcf8
--- /dev/null
+++ b/recipes-qt/images/b2qt-embedded-ci-image.bb
@@ -0,0 +1,74 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "B2Qt on embedded Linux SDK image"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32PR = "r0"
33
34IMAGE_FEATURES += "\
35 package-management \
36 ssh-server-dropbear \
37 tools-debug \
38 debug-tweaks \
39 hwcodecs \
40 "
41
42inherit core-image
43
44IMAGE_INSTALL += "\
45 packagegroup-b2qt-embedded-base \
46 packagegroup-b2qt-embedded-tools \
47 ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \
48 ${@base_contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \
49 packagegroup-b2qt-qt5-modules \
50 "
51
52ROOTFS_POSTINSTALL_COMMAND += "remove_qt_from_rootfs;"
53
54python remove_qt_from_rootfs() {
55 import subprocess
56
57 # remove qtbase and all dependent packages
58 image_rootfs = d.getVar('IMAGE_ROOTFS', True)
59 opkg_conf = d.getVar("IPKGCONF_TARGET", True)
60 opkg_cmd = bb.utils.which(os.getenv('PATH'), "opkg")
61 opkg_args = "--volatile-cache -f %s -o %s " % (opkg_conf, image_rootfs)
62 opkg_args += d.getVar("OPKG_ARGS", True)
63
64 cmd = "%s %s --force-remove --force-removal-of-dependent-packages remove %s" % \
65 (opkg_cmd, opkg_args, 'qtbase')
66
67 try:
68 bb.note(cmd)
69 output = subprocess.check_output(cmd.split(), stderr=subprocess.STDOUT)
70 bb.note(output)
71 except subprocess.CalledProcessError as e:
72 bb.fatal("Unable to remove packages. Command '%s' "
73 "returned %d:\n%s" % (e.cmd, e.returncode, e.output))
74}
diff --git a/recipes-qt/images/b2qt-embedded-qt5-image.bb b/recipes-qt/images/b2qt-embedded-qt5-image.bb
index 88b5d33..970d30f 100644
--- a/recipes-qt/images/b2qt-embedded-qt5-image.bb
+++ b/recipes-qt/images/b2qt-embedded-qt5-image.bb
@@ -43,13 +43,9 @@ IMAGE_FEATURES += "\
43 " 43 "
44 44
45inherit core-image 45inherit core-image
46inherit bootfs-image
47inherit consistent_timestamps 46inherit consistent_timestamps
48 47
49MACHINE_EXTRA_INSTALL_QT ?= ""
50
51IMAGE_INSTALL += "\ 48IMAGE_INSTALL += "\
52 ${MACHINE_EXTRA_INSTALL_QT} \
53 packagegroup-b2qt-embedded-base \ 49 packagegroup-b2qt-embedded-base \
54 packagegroup-b2qt-embedded-tools \ 50 packagegroup-b2qt-embedded-tools \
55 ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \ 51 ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \