summaryrefslogtreecommitdiffstats
path: root/recipes-qt/images
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-11-10 10:06:11 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2016-11-21 08:39:46 +0000
commit1a9ad4899efb2f3054ec0d676e41a85e01d8f806 (patch)
tree0db9018d6d7e3c6caa71fe4710e94e25021e041d /recipes-qt/images
parent3ee5d97e4de4356d416dad28239324ab757ec27a (diff)
downloadmeta-boot2qt-1a9ad4899efb2f3054ec0d676e41a85e01d8f806.tar.gz
Add support for creating QBSP package
QBSP is a Qt specific Board Support Package that can be installed with the Qt SDK or MaintenanceTool and contains a system image and a toolchain. The toolchain is automatically registered to the QtCreator. The recipes used for creating the system image and the toolchain can be configured with QBSP_IMAGE_TASK and QBSP_SDK_TASK. The files wanted for the system image can be further configured with QBSP_IMAGE_CONTENT, with a list of files located in DEPLOY_DIR_IMAGE folder. By default, .img and .conf files are used from the selected image recipe. QBSP_INSTALLER_COMPONENT defines the location in the Qt installer tree where the QBSP is shown and QBSP_VERSION defines the version for the components. The QBSP is installed to path defined by QBSP_INSTALL_PATH. The regular SDK creation can now reuse the same image package .7z, so update upload script to use it instead of creating new package. Task-number: QTBUG-57018 Change-Id: Id1e7cc4ab3998a7d450f23ed603b8e676b314d63 Reviewed-by: Iikka Eklund <iikka.eklund@qt.io> Reviewed-by: Teemu Holappa <teemu.holappa@qt.io>
Diffstat (limited to 'recipes-qt/images')
-rw-r--r--recipes-qt/images/b2qt-automotive-qt5-image.bb2
-rw-r--r--recipes-qt/images/b2qt-embedded-qt5-image.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-qt/images/b2qt-automotive-qt5-image.bb b/recipes-qt/images/b2qt-automotive-qt5-image.bb
index d0e13d5..179831a 100644
--- a/recipes-qt/images/b2qt-automotive-qt5-image.bb
+++ b/recipes-qt/images/b2qt-automotive-qt5-image.bb
@@ -42,7 +42,7 @@ IMAGE_FEATURES += "\
42 hwcodecs \ 42 hwcodecs \
43 " 43 "
44 44
45inherit core-image 45inherit core-image qbsp-image
46inherit consistent_timestamps 46inherit consistent_timestamps
47 47
48IMAGE_INSTALL += "\ 48IMAGE_INSTALL += "\
diff --git a/recipes-qt/images/b2qt-embedded-qt5-image.bb b/recipes-qt/images/b2qt-embedded-qt5-image.bb
index 970d30f..4d0bfa4 100644
--- a/recipes-qt/images/b2qt-embedded-qt5-image.bb
+++ b/recipes-qt/images/b2qt-embedded-qt5-image.bb
@@ -42,7 +42,7 @@ IMAGE_FEATURES += "\
42 hwcodecs \ 42 hwcodecs \
43 " 43 "
44 44
45inherit core-image 45inherit core-image qbsp-image
46inherit consistent_timestamps 46inherit consistent_timestamps
47 47
48IMAGE_INSTALL += "\ 48IMAGE_INSTALL += "\