diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2016-04-19 10:07:08 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2016-04-21 05:34:16 +0000 |
commit | 95a7d3e9bcd4b250c28c46ce95ac215066e0264a (patch) | |
tree | 53528ab8ff4dd414f1e404496955eb050fa7dccb /recipes-qt/automotive | |
parent | f043ae36aa4cd0895110bed92bbf68370f559f5b (diff) | |
download | meta-boot2qt-95a7d3e9bcd4b250c28c46ce95ac215066e0264a.tar.gz |
automotive: update revisions
Update neptune-ui and qtapplication manager, which need latest
qtwayland. Add needed environment variable for wayland.
Change-Id: I2e9eddd109546dca49451bff6bcf5623e16eb0bc
Reviewed-by: Robert Griebl <robert.griebl@pelagicore.com>
Diffstat (limited to 'recipes-qt/automotive')
-rw-r--r-- | recipes-qt/automotive/neptune-ui_git.bb | 10 | ||||
-rw-r--r-- | recipes-qt/automotive/qtapplicationmanager_git.bb | 10 |
2 files changed, 10 insertions, 10 deletions
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb index a71cce6..702ca90 100644 --- a/recipes-qt/automotive/neptune-ui_git.bb +++ b/recipes-qt/automotive/neptune-ui_git.bb | |||
@@ -20,17 +20,17 @@ | |||
20 | ############################################################################## | 20 | ############################################################################## |
21 | 21 | ||
22 | DESCRIPTION = "Neptune IVI UI" | 22 | DESCRIPTION = "Neptune IVI UI" |
23 | LICENSE = "GPLv3" | 23 | LICENSE = "GPL-3.0" |
24 | LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=024d61f4545fb889faa57982553ce094" | 24 | LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=bc0cb4bfd3f72b3fe47b2b2d0d89762c" |
25 | 25 | ||
26 | inherit qt5-module sdk-sources systemd | 26 | inherit qt5-module sdk-sources systemd |
27 | 27 | ||
28 | SRC_URI = " \ | 28 | SRC_URI = " \ |
29 | git://codereview.qt-project.org/qt-apps/neptune-ui;branch=${BRANCH};protocol=ssh;sdk-uri=5.6/Src/neptune-ui \ | 29 | git://codereview.qt-project.org/qt-apps/neptune-ui;branch=${BRANCH};protocol=ssh;sdk-uri=5.7/Src/neptune-ui \ |
30 | file://neptune.service \ | 30 | file://neptune.service \ |
31 | " | 31 | " |
32 | 32 | ||
33 | SRCREV = "9b05221285ce2369e1e87e88c86970b943797294" | 33 | SRCREV = "c405b322d773068521855e048f215c6ec59e965f" |
34 | BRANCH = "master" | 34 | BRANCH = "master" |
35 | 35 | ||
36 | S = "${WORKDIR}/git" | 36 | S = "${WORKDIR}/git" |
@@ -48,7 +48,7 @@ do_install_append() { | |||
48 | install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/ | 48 | install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/ |
49 | 49 | ||
50 | install -m 0644 ${S}/Main*.qml ${D}/opt/neptune | 50 | install -m 0644 ${S}/Main*.qml ${D}/opt/neptune |
51 | install -m 0644 ${S}/ClusterAndHUD.qml ${D}/opt/neptune | 51 | install -m 0644 ${S}/MainWithCluster.qml ${D}/opt/neptune |
52 | install -m 0644 ${S}/am-config.yaml ${D}/opt/neptune | 52 | install -m 0644 ${S}/am-config.yaml ${D}/opt/neptune |
53 | } | 53 | } |
54 | 54 | ||
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb index 2c21d1b..240fedc 100644 --- a/recipes-qt/automotive/qtapplicationmanager_git.bb +++ b/recipes-qt/automotive/qtapplicationmanager_git.bb | |||
@@ -20,17 +20,17 @@ | |||
20 | ############################################################################## | 20 | ############################################################################## |
21 | 21 | ||
22 | DESCRIPTION = "Qt component for application lifecycle management" | 22 | DESCRIPTION = "Qt component for application lifecycle management" |
23 | LICENSE = "GPLv3" | 23 | LICENSE = "GPL-3.0" |
24 | LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=311507adb75495acc0b61d69109485ce" | 24 | LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=317fda864ac33d41406ff3938c3e78d1" |
25 | 25 | ||
26 | inherit qmake5 sdk-sources | 26 | inherit qmake5 sdk-sources |
27 | 27 | ||
28 | SRC_URI = " \ | 28 | SRC_URI = " \ |
29 | git://codereview.qt-project.org/qt/qtapplicationmanager;branch=${BRANCH};protocol=ssh;sdk-uri=5.6/Src/qtapplicationmanager \ | 29 | git://codereview.qt-project.org/qt/qtapplicationmanager;branch=${BRANCH};protocol=ssh;sdk-uri=5.7/Src/qtapplicationmanager \ |
30 | " | 30 | " |
31 | 31 | ||
32 | SRCREV = "b7578378b578788c2ae9c60708a2908d3b090c16" | 32 | SRCREV = "97530155847257102fe0a159c681857fb9eb1194" |
33 | BRANCH = "master" | 33 | BRANCH = "5.7" |
34 | 34 | ||
35 | DEPENDS = "qtbase qtdeclarative libyaml libarchive \ | 35 | DEPENDS = "qtbase qtdeclarative libyaml libarchive \ |
36 | ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" | 36 | ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" |