summaryrefslogtreecommitdiffstats
path: root/recipes-qt/automotive/qtivi_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-12-18 15:59:51 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-12-19 10:04:35 +0000
commitd42593edfb649b07f426db6c82972eb1a5615058 (patch)
tree1d14e86ac651c32aeffb97cc6c5f4382b3d71cb0 /recipes-qt/automotive/qtivi_git.bb
parent9fd509397d955ab32fa37d85cd42d8ac3d007ad7 (diff)
downloadmeta-boot2qt-d42593edfb649b07f426db6c82972eb1a5615058.tar.gz
qtivi: enable ivigenerator for toolchain
Fix yocto build issues with nativesdk-qtivi and include the ivigenerator to the toolchain. ivigenerator is disabled for mingw build since it is using the prebuild python binaries and doesn't work with virtualenv. Task-number: AUTOSUITE-176 Change-Id: I4765652919649f4aafeb723127b0e75194325f92 Reviewed-by: Dominik Holland <dominik.holland@pelagicore.com>
Diffstat (limited to 'recipes-qt/automotive/qtivi_git.bb')
-rw-r--r--recipes-qt/automotive/qtivi_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb
index de12d54..f422b15 100644
--- a/recipes-qt/automotive/qtivi_git.bb
+++ b/recipes-qt/automotive/qtivi_git.bb
@@ -68,6 +68,9 @@ PACKAGECONFIG[simulator-native] = "QMAKE_EXTRA_ARGS+=-feature-simulator QMAKE_EX
68 68
69PACKAGECONFIG_class-native ??= "host-tools-only ivigenerator-native" 69PACKAGECONFIG_class-native ??= "host-tools-only ivigenerator-native"
70PACKAGECONFIG_class-nativesdk ??= "${PACKAGECONFIG_class-native}" 70PACKAGECONFIG_class-nativesdk ??= "${PACKAGECONFIG_class-native}"
71PACKAGECONFIG_class-nativesdk_mingw32 ??= "host-tools-only"
72
73ALLOW_EMPTY_${PN}-tools = "1"
71 74
72EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS} ${@bb.utils.contains_any('PACKAGECONFIG', 'ivigenerator ivigenerator-native', '', 'QMAKE_EXTRA_ARGS+=-no-ivigenerator', d)}" 75EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS} ${@bb.utils.contains_any('PACKAGECONFIG', 'ivigenerator ivigenerator-native', '', 'QMAKE_EXTRA_ARGS+=-no-ivigenerator', d)}"
73 76
@@ -90,3 +93,5 @@ do_install_prepend() {
90BBCLASSEXTEND += "native nativesdk" 93BBCLASSEXTEND += "native nativesdk"
91 94
92INSANE_SKIP_${PN}_class-native = "already-stripped" 95INSANE_SKIP_${PN}_class-native = "already-stripped"
96INSANE_SKIP_${PN}_class-nativesdk = "already-stripped"
97INSANE_SKIP_${PN}-tools_class-nativesdk = "staticdev"