summaryrefslogtreecommitdiffstats
path: root/recipes-qt/automotive/qtapplicationmanager_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-08-22 16:17:30 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-08-24 10:54:52 +0000
commite245c1dc8fe450fe9aeb5e505c90ba6dadf365d1 (patch)
tree8a0c7296e7f6655e620427d7f05e6a7adad3c258 /recipes-qt/automotive/qtapplicationmanager_git.bb
parentaf902739757f9581473009ad8668fc64cc92e279 (diff)
downloadmeta-boot2qt-e245c1dc8fe450fe9aeb5e505c90ba6dadf365d1.tar.gz
Reuse qt5-git.inc in automotive recipes
Instead of using codereview.qt-project.org directly, reuse qt5-git.inc from meta-qt5 that defines git url to be used which simplyfies the recipes. Also cleanup unnecessary use of sdk-sources for opened repos. Change-Id: I80e02c9aba600eb41e2618f377e878fd8ecead11 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'recipes-qt/automotive/qtapplicationmanager_git.bb')
-rw-r--r--recipes-qt/automotive/qtapplicationmanager_git.bb10
1 files changed, 2 insertions, 8 deletions
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb
index fd128bd..028df78 100644
--- a/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ b/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -31,21 +31,15 @@ DESCRIPTION = "Qt component for application lifecycle management"
31LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1" 31LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=317fda864ac33d41406ff3938c3e78d1" 32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=317fda864ac33d41406ff3938c3e78d1"
33 33
34inherit qmake5 sdk-sources 34inherit qmake5
35 35require recipes-qt/qt5/qt5-git.inc
36SRC_URI = " \
37 git://codereview.qt-project.org/qt/qtapplicationmanager;branch=${BRANCH};protocol=ssh \
38 "
39 36
40SRCREV = "8a4b17fade4507860919fbbf9ea42f813a26be76" 37SRCREV = "8a4b17fade4507860919fbbf9ea42f813a26be76"
41BRANCH = "5.7"
42 38
43DEPENDS = "qtbase qtdeclarative libyaml libarchive \ 39DEPENDS = "qtbase qtdeclarative libyaml libarchive \
44 ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" 40 ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
45RDEPENDS_${PN} = "libcrypto" 41RDEPENDS_${PN} = "libcrypto"
46 42
47S = "${WORKDIR}/git"
48
49EXTRA_QMAKEVARS_PRE += "\ 43EXTRA_QMAKEVARS_PRE += "\
50 ${@base_contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \ 44 ${@base_contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \
51 -config enable-dummydata \ 45 -config enable-dummydata \