summaryrefslogtreecommitdiffstats
path: root/recipes-qt/automotive/qtapplicationmanager_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-12-03 16:10:11 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-12-09 08:34:57 +0000
commit80ad88fd866526b191754104a6d78a3d33e712b3 (patch)
tree3d42da476a215592e248ffeb6c24b714679dea0b /recipes-qt/automotive/qtapplicationmanager_git.bb
parent9fd94853105aaf0670f0f94386d9a30a6876f115 (diff)
downloadmeta-boot2qt-80ad88fd866526b191754104a6d78a3d33e712b3.tar.gz
Add recipes for qtapplicationmanager and neptune-ui
Include both in the automotive image and set neptune-ui to start at boot up. Change-Id: I41197deb6a15540b7d27a5235fc1658582667b4a Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'recipes-qt/automotive/qtapplicationmanager_git.bb')
-rw-r--r--recipes-qt/automotive/qtapplicationmanager_git.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb
new file mode 100644
index 0000000..3e43b15
--- /dev/null
+++ b/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -0,0 +1,58 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Qt component for application lifecycle management"
24LICENSE = "GPLv3"
25LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=311507adb75495acc0b61d69109485ce"
26
27inherit qt5-module sdk-sources
28
29SRC_URI = " \
30 git://codereview.qt-project.org/qt/qtapplicationmanager;branch=${BRANCH};protocol=ssh;sdk-uri=5.6/Src/qtapplicationmanager \
31 "
32
33SRCREV = "5e40d9fa1ea0d6f8eaaed97e614775078916ee86"
34BRANCH = "master"
35
36DEPENDS = "qtbase qtdeclarative libyaml libarchive \
37 ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
38
39S = "${WORKDIR}/git"
40
41EXTRA_QMAKEVARS_PRE += "\
42 -config force-singleprocess \
43 -config enable-dummydata \
44 -config enable-ivi-logging \
45 -config install-prefix=/usr \
46 -config systemd-workaround \
47 "
48
49do_install_append() {
50 install -m 0755 -d ${D}/opt/am/
51 install -m 0644 ${S}/template-opt/am/config.yaml ${D}/opt/am/
52}
53
54FILES_${PN} += "\
55 /opt/am \
56 ${libdir}/appman \
57 ${datadir}/dbus-1"
58FILES_${PN}-dbg += "${libdir}/appman/.debug"