summaryrefslogtreecommitdiffstats
path: root/recipes-qt/automotive/neptune-ui_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-12-03 16:10:11 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-12-09 08:34:57 +0000
commit80ad88fd866526b191754104a6d78a3d33e712b3 (patch)
tree3d42da476a215592e248ffeb6c24b714679dea0b /recipes-qt/automotive/neptune-ui_git.bb
parent9fd94853105aaf0670f0f94386d9a30a6876f115 (diff)
downloadmeta-boot2qt-80ad88fd866526b191754104a6d78a3d33e712b3.tar.gz
Add recipes for qtapplicationmanager and neptune-ui
Include both in the automotive image and set neptune-ui to start at boot up. Change-Id: I41197deb6a15540b7d27a5235fc1658582667b4a Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'recipes-qt/automotive/neptune-ui_git.bb')
-rw-r--r--recipes-qt/automotive/neptune-ui_git.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb
new file mode 100644
index 0000000..78cd30c
--- /dev/null
+++ b/recipes-qt/automotive/neptune-ui_git.bb
@@ -0,0 +1,62 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Neptune IVI UI"
24LICENSE = "GPLv3"
25LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=024d61f4545fb889faa57982553ce094"
26
27inherit qt5-module sdk-sources systemd
28
29SRC_URI = " \
30 git://codereview.qt-project.org/qt-apps/neptune-ui;branch=${BRANCH};protocol=ssh;sdk-uri=5.6/Src/neptune-ui \
31 file://neptune.service \
32 "
33
34SRCREV = "9ca0b519a13cf98528b66fe737c86139872c1649"
35BRANCH = "master"
36
37S = "${WORKDIR}/git"
38
39DEPENDS = "qtbase qtdeclarative"
40RDEPENDS_${PN} = "qtapplicationmanager qtivi ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}"
41
42do_configure_prepend() {
43 echo "qml.path = /opt/neptune" >> ${S}/neptuneui.pro
44}
45
46do_install_append() {
47 install -m 0755 -d ${D}${systemd_unitdir}/system
48 install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/
49
50 install -m 0644 ${S}/Main*.qml ${D}/opt/neptune
51 install -m 0644 ${S}/am-config.yaml ${D}/opt/neptune
52}
53
54PACKAGES =+ "${PN}-apps"
55RRECOMMENDS_${PN} += "${PN}-apps"
56
57FILES_${PN}-apps += "/opt/neptune/apps"
58FILES_${PN} += "\
59 /opt/neptune \
60 "
61
62SYSTEMD_SERVICE_${PN} = "neptune.service"