summaryrefslogtreecommitdiffstats
path: root/recipes-qt/automotive/neptune-ui_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-02-28 11:10:51 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-02-28 10:30:37 +0000
commit09f8c75cfeb0ea6d6b77dbd25cfbf779aa395b45 (patch)
tree2aa293ff56c2e9d303b2d5fc277b0a963f5ad130 /recipes-qt/automotive/neptune-ui_git.bb
parent0605ccb7bab4c787c68a623717e0eef7ebd7d26d (diff)
downloadmeta-boot2qt-09f8c75cfeb0ea6d6b77dbd25cfbf779aa395b45.tar.gz
Update automotive components
Use latest version of QtWayland from 5.8 branch, which is needed for qtapplicationmanager to work correctly. Change Drive CX to use basic rendering loop. Change-Id: If74255e982a676f1c556f2ef25975b675a484e05 Reviewed-by: Dominik Holland <dominik.holland@pelagicore.com>
Diffstat (limited to 'recipes-qt/automotive/neptune-ui_git.bb')
-rw-r--r--recipes-qt/automotive/neptune-ui_git.bb7
1 files changed, 1 insertions, 6 deletions
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb
index 7397c11..11b81db 100644
--- a/recipes-qt/automotive/neptune-ui_git.bb
+++ b/recipes-qt/automotive/neptune-ui_git.bb
@@ -36,23 +36,18 @@ require recipes-qt/qt5/qt5-git.inc
36 36
37QT_GIT = "git://github.com/qtproject" 37QT_GIT = "git://github.com/qtproject"
38QT_MODULE = "qt-apps-neptune-ui" 38QT_MODULE = "qt-apps-neptune-ui"
39QT_MODULE_BRANCH = "master"
40 39
41SRC_URI += " \ 40SRC_URI += " \
42 file://neptune.service \ 41 file://neptune.service \
43 " 42 "
44 43
45SRCREV = "fd18dcbb9f53eb3948da890704530007327c476f" 44SRCREV = "7d865406d6ccc538f9fd658a0d2b557e115d6919"
46 45
47DEPENDS = "qtbase qtdeclarative" 46DEPENDS = "qtbase qtdeclarative"
48RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard \ 47RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard \
49 qtquickcontrols-qmlplugins qtgraphicaleffects-qmlplugins \ 48 qtquickcontrols-qmlplugins qtgraphicaleffects-qmlplugins \
50 ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}" 49 ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}"
51 50
52do_configure_prepend() {
53 echo "qml.path = /opt/neptune" >> ${S}/neptuneui.pro
54}
55
56do_install_append() { 51do_install_append() {
57 install -m 0755 -d ${D}${systemd_unitdir}/system 52 install -m 0755 -d ${D}${systemd_unitdir}/system
58 install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/ 53 install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/