diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2017-01-31 08:24:30 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2017-02-15 08:32:05 +0000 |
commit | 505d8414e11d4da9d8fc485931f2af6fdfd5912f (patch) | |
tree | 743f22f93422748f243c125908c1eaf90af6e8f6 /meta-vib4-extras | |
parent | cbfd8dd6a9ff034ec1e2839c1e72ee0973163195 (diff) | |
download | meta-boot2qt-505d8414e11d4da9d8fc485931f2af6fdfd5912f.tar.gz |
Rename nvidia extra layers
Reserve meta-tegra-extras for the open source meta-tegra layer
used for Jetson TX1 and TK1.
Change-Id: I78b168105f306ee342671b612205d68b56016c14
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-vib4-extras')
8 files changed, 0 insertions, 336 deletions
diff --git a/meta-vib4-extras/conf/layer.conf b/meta-vib4-extras/conf/layer.conf deleted file mode 100644 index 525c018..0000000 --- a/meta-vib4-extras/conf/layer.conf +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | # We have a conf and classes directory, append to BBPATH | ||
31 | BBPATH .= ":${LAYERDIR}" | ||
32 | |||
33 | # We have a recipes directory, add to BBFILES | ||
34 | BBFILES += "${LAYERDIR}/recipes*/*/*.bb \ | ||
35 | ${LAYERDIR}/recipes*/*/*.bbappend \ | ||
36 | " | ||
37 | |||
38 | BBFILE_COLLECTIONS += "b2qt_vib4" | ||
39 | BBFILE_PATTERN_b2qt_vib4 := "^${LAYERDIR}/" | ||
40 | BBFILE_PRIORITY_b2qt_vib4 = "20" | ||
diff --git a/meta-vib4-extras/recipes/linux-libc-headers/linux-libc-headers_4.%.bbappend b/meta-vib4-extras/recipes/linux-libc-headers/linux-libc-headers_4.%.bbappend deleted file mode 100644 index f2bdba1..0000000 --- a/meta-vib4-extras/recipes/linux-libc-headers/linux-libc-headers_4.%.bbappend +++ /dev/null | |||
@@ -1,7 +0,0 @@ | |||
1 | # Use our kernel instead of yocto which defaults to mainline 3.18 | ||
2 | SRC_URI = "file://${KERN_DIR}/linux.tar.bz2" | ||
3 | PV = "3.18" | ||
4 | |||
5 | # Extracting linux.tar.bz2 creates directories | ||
6 | # <top>/vibrante-oss-src/kernel | ||
7 | S = "${WORKDIR}/vibrante-oss-src/kernel" | ||
diff --git a/meta-vib4-extras/recipes/linux/linux-nvidia.bbappend b/meta-vib4-extras/recipes/linux/linux-nvidia.bbappend deleted file mode 100644 index 70ee515..0000000 --- a/meta-vib4-extras/recipes/linux/linux-nvidia.bbappend +++ /dev/null | |||
@@ -1,69 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | do_unpack_append() { | ||
31 | rm -rf ${STAGING_KERNEL_DIR} | ||
32 | ln -s ${S} ${STAGING_KERNEL_DIR} | ||
33 | } | ||
34 | |||
35 | do_kernel_defconfig_prepend () { | ||
36 | } | ||
37 | |||
38 | do_compile_prepend () { | ||
39 | # cross_compile_exports | ||
40 | export ARCH=${KERNEL_ARCH} | ||
41 | export CROSS_COMPILE=${CROSS_COMPILE} | ||
42 | |||
43 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${B}/.config | ||
44 | echo "CONFIG_USB_ACM=m" >> ${B}/.config | ||
45 | |||
46 | make olddefconfig | ||
47 | } | ||
48 | |||
49 | do_install () { | ||
50 | kernel_do_install | ||
51 | |||
52 | s=$(readlink -m "${S}") | ||
53 | kernsrc="${STAGING_KERNEL_DIR}" | ||
54 | |||
55 | if [ "${s}" != "${kernsrc}" ]; then | ||
56 | mkdir -p "${kernsrc}" | ||
57 | rm -rf "${kernsrc}" | ||
58 | mv "${S}" "${STAGING_KERNEL_DIR}" | ||
59 | ln -sf "${kernsrc}" "${s}" | ||
60 | fi | ||
61 | } | ||
62 | |||
63 | do_deploy() { | ||
64 | kernel_do_deploy | ||
65 | } | ||
66 | |||
67 | do_compile () { | ||
68 | kernel_do_compile | ||
69 | } | ||
diff --git a/meta-vib4-extras/recipes/systemd/systemd_%.bbappend b/meta-vib4-extras/recipes/systemd/systemd_%.bbappend deleted file mode 100644 index 53ea1e4..0000000 --- a/meta-vib4-extras/recipes/systemd/systemd_%.bbappend +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | SRC_URI_remove = "file://0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch" | ||
diff --git a/meta-vib4-extras/recipes/wayland/wayland/always-build-scanner.patch b/meta-vib4-extras/recipes/wayland/wayland/always-build-scanner.patch deleted file mode 100644 index 5e0e6bf..0000000 --- a/meta-vib4-extras/recipes/wayland/wayland/always-build-scanner.patch +++ /dev/null | |||
@@ -1,105 +0,0 @@ | |||
1 | build: always build wayland-scanner | ||
2 | |||
3 | The previous idiom for building a cross-compiled Wayland is to build once for | ||
4 | the build host (with --enable-scanner --disable-libraries) to get a | ||
5 | wayland-scanner binary that can then be used in a cross-compile (with | ||
6 | --disable-scanner). The problem with this is that the cross wayland is missing | ||
7 | a wayland-scanner binary, which means you then can't do any Wayland development | ||
8 | on the target. | ||
9 | |||
10 | Instead, always build wayland-scanner for the target and change | ||
11 | --enable/disable-scanner to --with/without-host-scanner. Normal builds use the | ||
12 | default of --without-host-scanner and run the wayland-scanner it just built, and | ||
13 | cross-compiled builds pass --with-host-scanner to use a previously built host | ||
14 | scanner but still get a wayland-scanner to install. | ||
15 | |||
16 | (a theoretically neater solution would be to build two scanners if required (one | ||
17 | to run and one to install), but automake makes this overly complicated) | ||
18 | |||
19 | Signed-off-by: Ross Burton <ross.burton@intel.com> | ||
20 | Upstream-Status: Submitted | ||
21 | |||
22 | diff --git a/Makefile.am b/Makefile.am | ||
23 | index c19494f..c2d929b 100644 | ||
24 | --- a/Makefile.am | ||
25 | +++ b/Makefile.am | ||
26 | @@ -64,16 +64,17 @@ nodist_libwayland_client_la_SOURCES = \ | ||
27 | |||
28 | pkgconfig_DATA += src/wayland-client.pc src/wayland-server.pc | ||
29 | |||
30 | -if ENABLE_SCANNER | ||
31 | -wayland_scanner = $(top_builddir)/wayland-scanner | ||
32 | bin_PROGRAMS = wayland-scanner | ||
33 | wayland_scanner_SOURCES = src/scanner.c | ||
34 | wayland_scanner_CFLAGS = $(EXPAT_CFLAGS) $(AM_CFLAGS) | ||
35 | wayland_scanner_LDADD = $(EXPAT_LIBS) libwayland-util.la | ||
36 | -$(BUILT_SOURCES) : wayland-scanner | ||
37 | pkgconfig_DATA += src/wayland-scanner.pc | ||
38 | -else | ||
39 | + | ||
40 | +if HOST_SCANNER | ||
41 | wayland_scanner = wayland-scanner | ||
42 | +else | ||
43 | +$(BUILT_SOURCES) : wayland-scanner | ||
44 | +wayland_scanner = $(top_builddir)/wayland-scanner | ||
45 | endif | ||
46 | |||
47 | protocol/%-protocol.c : $(top_srcdir)/protocol/%.xml | ||
48 | diff --git a/configure.ac b/configure.ac | ||
49 | index c2a804e..de0b02f 100644 | ||
50 | --- a/configure.ac | ||
51 | +++ b/configure.ac | ||
52 | @@ -65,11 +65,11 @@ AC_CHECK_DECL(CLOCK_MONOTONIC,[], | ||
53 | [[#include <time.h>]]) | ||
54 | AC_CHECK_HEADERS([execinfo.h]) | ||
55 | |||
56 | -AC_ARG_ENABLE([scanner], | ||
57 | - [AC_HELP_STRING([--disable-scanner], | ||
58 | - [Disable compilation of wayland-scanner])], | ||
59 | - [], | ||
60 | - [enable_scanner=yes]) | ||
61 | +AC_ARG_WITH([host-scanner], | ||
62 | + [AC_HELP_STRING([--with-host-scanner], | ||
63 | + [Use a host wayland-scanner])], | ||
64 | + [], | ||
65 | + [with_host_scanner=no]) | ||
66 | |||
67 | AC_ARG_ENABLE([documentation], | ||
68 | [AC_HELP_STRING([--disable-documentation], | ||
69 | @@ -77,25 +77,23 @@ AC_ARG_ENABLE([documentation], | ||
70 | [], | ||
71 | [enable_documentation=yes]) | ||
72 | |||
73 | -AM_CONDITIONAL(ENABLE_SCANNER, test "x$enable_scanner" = xyes) | ||
74 | +AM_CONDITIONAL(HOST_SCANNER, test "x$with_host_scanner" = xyes) | ||
75 | |||
76 | AC_ARG_WITH(icondir, [ --with-icondir=<dir> Look for cursor icons here], | ||
77 | [ ICONDIR=$withval], | ||
78 | [ ICONDIR=${datadir}/icons]) | ||
79 | AC_SUBST([ICONDIR]) | ||
80 | |||
81 | -if test "x$enable_scanner" = "xyes"; then | ||
82 | - PKG_CHECK_MODULES(EXPAT, [expat], [], | ||
83 | - [AC_CHECK_HEADERS(expat.h, [], | ||
84 | - [AC_MSG_ERROR([Can't find expat.h. Please install expat.])]) | ||
85 | - SAVE_LIBS="$LIBS" | ||
86 | - AC_SEARCH_LIBS(XML_ParserCreate, expat, [], | ||
87 | - [AC_MSG_ERROR([Can't find expat library. Please install expat.])]) | ||
88 | - EXPAT_LIBS="$LIBS" | ||
89 | - LIBS="$SAVE_LIBS" | ||
90 | - AC_SUBST(EXPAT_LIBS) | ||
91 | - ]) | ||
92 | -fi | ||
93 | +PKG_CHECK_MODULES(EXPAT, [expat], [], | ||
94 | + [AC_CHECK_HEADERS(expat.h, [], | ||
95 | + [AC_MSG_ERROR([Can't find expat.h. Please install expat.])]) | ||
96 | + SAVE_LIBS="$LIBS" | ||
97 | + AC_SEARCH_LIBS(XML_ParserCreate, expat, [], | ||
98 | + [AC_MSG_ERROR([Can't find expat library. Please install expat.])]) | ||
99 | + EXPAT_LIBS="$LIBS" | ||
100 | + LIBS="$SAVE_LIBS" | ||
101 | + AC_SUBST(EXPAT_LIBS) | ||
102 | + ]) | ||
103 | |||
104 | AC_PATH_PROG(XSLTPROC, xsltproc) | ||
105 | AM_CONDITIONAL([HAVE_XSLTPROC], [test "x$XSLTPROC" != "x"]) | ||
diff --git a/meta-vib4-extras/recipes/wayland/wayland_%.bbappend b/meta-vib4-extras/recipes/wayland/wayland_%.bbappend deleted file mode 100644 index 463d5a1..0000000 --- a/meta-vib4-extras/recipes/wayland/wayland_%.bbappend +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | FILESEXTRAPATHS_append := ":${NVLAYER_DIR}/packages:${LNX_TOPDIR}/${PN}:${THISDIR}/${PN}" | ||
31 | |||
32 | SRC_URI_remove = "file://${NVLAYER_DIR}/packages/wayland-1.8.1-src.tar.gz" | ||
33 | SRC_URI = "\ | ||
34 | file://wayland-1.8.1-src.tar.gz \ | ||
35 | file://always-build-scanner.patch \ | ||
36 | " | ||
diff --git a/meta-vib4-extras/recipes/weston/weston/disable-wayland-scanner-pkg-check.patch b/meta-vib4-extras/recipes/weston/weston/disable-wayland-scanner-pkg-check.patch deleted file mode 100644 index 062da5c..0000000 --- a/meta-vib4-extras/recipes/weston/weston/disable-wayland-scanner-pkg-check.patch +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | Index: weston-1.5.0/configure.ac | ||
2 | =================================================================== | ||
3 | --- weston-1.5.0.orig/configure.ac | ||
4 | +++ weston-1.5.0/configure.ac | ||
5 | @@ -503,7 +503,7 @@ if test x$wayland_scanner = x; then | ||
6 | AC_MSG_ERROR([wayland-scanner is needed to compile weston]) | ||
7 | fi | ||
8 | |||
9 | -PKG_CHECK_MODULES(WAYLAND_SCANNER, wayland-scanner) | ||
10 | +#PKG_CHECK_MODULES(WAYLAND_SCANNER, wayland-scanner) | ||
11 | |||
12 | AC_CONFIG_FILES([Makefile src/version.h src/weston.pc]) | ||
13 | |||
diff --git a/meta-vib4-extras/recipes/weston/weston_%.bbappend b/meta-vib4-extras/recipes/weston/weston_%.bbappend deleted file mode 100644 index cfc286f..0000000 --- a/meta-vib4-extras/recipes/weston/weston_%.bbappend +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | FILESEXTRAPATHS_append := ":${THISDIR}/${PN}" | ||
31 | S = "${WORKDIR}/${LNX_TOPDIR}/samples/wayland/weston" | ||
32 | |||
33 | do_install_prepend() { | ||
34 | mkdir -p ${WORKDIR}/${LNX_TOPDIR}/samples/weston/tools | ||
35 | cp ${WORKDIR}/${LNX_TOPDIR}/samples/wayland/weston/tools/weston.ini ${WORKDIR}/${LNX_TOPDIR}/samples/weston/tools/weston.ini | ||
36 | } | ||