summaryrefslogtreecommitdiffstats
path: root/meta-toradex-extras
diff options
context:
space:
mode:
authorTeemu Holappa <teemu.holappa@theqtcompany.com>2016-08-17 11:20:46 +0300
committerTeemu Holappa <teemu.holappa@theqtcompany.com>2016-08-17 12:20:18 +0000
commitffdd18178f9016c5e556f6b70ab70ba66956807e (patch)
tree07c70366eaec2c5237f50cdfdab46978a453455d /meta-toradex-extras
parent10c9d074e0b3a00ef45d0764c7283fe2cdade101 (diff)
downloadmeta-boot2qt-ffdd18178f9016c5e556f6b70ab70ba66956807e.tar.gz
Fix adb to toradex-imx6 imagev5.7.0
Enabled functionfs module in toradex-imx6 configuration. Change-Id: I2ff2de89bfa25cd6f40da700f96360e2cc13f1e7 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-toradex-extras')
-rw-r--r--meta-toradex-extras/recipes/linux/linux-toradex_3.14.%.bbappend37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex_3.14.%.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex_3.14.%.bbappend
new file mode 100644
index 0000000..b696b19
--- /dev/null
+++ b/meta-toradex-extras/recipes/linux/linux-toradex_3.14.%.bbappend
@@ -0,0 +1,37 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30# kernel image files are not needed in the image
31RDEPENDS_kernel-base = ""
32
33do_configure_prepend () {
34 # FunctionFS for adb
35 echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
36 echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig
37}