summaryrefslogtreecommitdiffstats
path: root/meta-toradex-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-10-06 16:32:46 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2017-10-12 13:16:26 +0000
commitc23e67cc73e4fe0d7c07dd79bd2380367d2047d6 (patch)
treedafbdaa5eb0ad95ed1bddf3744e27463caf52458 /meta-toradex-extras
parent7c988467d12fe6507e6ca2275c65d90b247a3e12 (diff)
downloadmeta-boot2qt-c23e67cc73e4fe0d7c07dd79bd2380367d2047d6.tar.gz
apalis-imx6: add support for the new capasitive touch display
The atmel_mxt_ts controller needs to be enabled in the dtb, done here for the ixora v1.1 dtb. Said dtb is also changed to be the default dtb in the u-boot config. Existing u-boot patch is updated to include console=tty1 removal for all toradex boards. Task-number: QTBUG-63344 Change-Id: Idaba988c2a0a5916c8fe6b6f11cc75981a9a28e2 Reviewed-by: Sami Nurmenniemi <sami.nurmenniemi@qt.io>
Diffstat (limited to 'meta-toradex-extras')
-rw-r--r--meta-toradex-extras/conf/layer.conf40
-rw-r--r--meta-toradex-extras/recipes/linux/linux-toradex/0001-Enable-atmel-mxt-multitouch-controller.patch31
-rw-r--r--meta-toradex-extras/recipes/linux/linux-toradex_4.1-2.0.x.bbappend32
3 files changed, 103 insertions, 0 deletions
diff --git a/meta-toradex-extras/conf/layer.conf b/meta-toradex-extras/conf/layer.conf
new file mode 100644
index 0000000..e39649f
--- /dev/null
+++ b/meta-toradex-extras/conf/layer.conf
@@ -0,0 +1,40 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30# We have a conf and classes directory, append to BBPATH
31BBPATH .= ":${LAYERDIR}"
32
33# We have a recipes directory, add to BBFILES
34BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
35 ${LAYERDIR}/recipes*/*/*.bbappend \
36 "
37
38BBFILE_COLLECTIONS += "b2qt_toradex"
39BBFILE_PATTERN_b2qt_toradex := "^${LAYERDIR}/"
40BBFILE_PRIORITY_b2qt_toradex = "20"
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex/0001-Enable-atmel-mxt-multitouch-controller.patch b/meta-toradex-extras/recipes/linux/linux-toradex/0001-Enable-atmel-mxt-multitouch-controller.patch
new file mode 100644
index 0000000..1535234
--- /dev/null
+++ b/meta-toradex-extras/recipes/linux/linux-toradex/0001-Enable-atmel-mxt-multitouch-controller.patch
@@ -0,0 +1,31 @@
1From 37a2e407172b37a880d04c5a7721aeff498854ad Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Fri, 6 Oct 2017 15:54:35 +0300
4Subject: [PATCH] Enable atmel mxt multitouch controller for ixora v1.1 dtb
5
6Need to disable fusion touch to get the new atmel mxt multitouch
7controller to work.
8---
9 arch/arm/boot/dts/imx6qdl-apalis-ixora-v1.1.dtsi | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/arch/arm/boot/dts/imx6qdl-apalis-ixora-v1.1.dtsi b/arch/arm/boot/dts/imx6qdl-apalis-ixora-v1.1.dtsi
13index 354bf80d..1181502 100644
14--- a/arch/arm/boot/dts/imx6qdl-apalis-ixora-v1.1.dtsi
15+++ b/arch/arm/boot/dts/imx6qdl-apalis-ixora-v1.1.dtsi
16@@ -166,7 +166,6 @@
17 reg = <0x4a>;
18 interrupt-parent = <&gpio6>;
19 interrupts = <10 IRQ_TYPE_EDGE_FALLING>;
20- status = "disabled";
21 };
22
23 pcap@10 {
24@@ -176,6 +175,7 @@
25 gpios = <&gpio6 10 0 /* MXM3 11, Pen down interrupt */
26 &gpio6 9 0 /* MXM3 13, Reset */
27 >;
28+ status = "disabled";
29 };
30
31 /* M41T0M6 real time clock on carrier board */
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex_4.1-2.0.x.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex_4.1-2.0.x.bbappend
new file mode 100644
index 0000000..eadfa15
--- /dev/null
+++ b/meta-toradex-extras/recipes/linux/linux-toradex_4.1-2.0.x.bbappend
@@ -0,0 +1,32 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
31
32SRC_URI += "file://0001-Enable-atmel-mxt-multitouch-controller.patch"