summaryrefslogtreecommitdiffstats
path: root/meta-toradex-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-24 14:26:30 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-25 08:17:18 +0000
commita38939e7a86f835f101efacf4db7967bb4b489be (patch)
tree7864355dc45ce234c5cf481f92a281627ae4e0fc /meta-toradex-extras
parent9836c267a651a037e6e1d8991b9c71332ee33d7d (diff)
downloadmeta-boot2qt-a38939e7a86f835f101efacf4db7967bb4b489be.tar.gz
toradex: enable u-boot update
Add all necessary files to enable u-boot update on all toradex devices. Update patch to the new u-boot that colibri vf is using and enable sd boot for colibri imx6. Task-number: QTEE-1070 Task-number: QTEE-978 Change-Id: I6ff362028cfb80cd34bbe5362bb6976d0084e008 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-toradex-extras')
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb4
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr2
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-imx6-enable-sdboot-by-default.patch36
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-vf-enable-sdboot-by-default.patch35
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend6
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-vf-remove-console-from-tty1.patch25
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend25
7 files changed, 92 insertions, 41 deletions
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
index 3d63f6b..337d57d 100644
--- a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
@@ -29,6 +29,8 @@ SRC_URI = " \
29 file://flash_blk.scr \ 29 file://flash_blk.scr \
30 " 30 "
31 31
32S = "${WORKDIR}"
33
32inherit deploy 34inherit deploy
33 35
34do_mkimage () { 36do_mkimage () {
@@ -62,4 +64,4 @@ do_install[noexec] = "1"
62do_populate_sysroot[noexec] = "1" 64do_populate_sysroot[noexec] = "1"
63 65
64PACKAGE_ARCH = "${MACHINE_ARCH}" 66PACKAGE_ARCH = "${MACHINE_ARCH}"
65COMPATIBLE_MACHINE = "(apalis-imx6|colibri-vf)" 67COMPATIBLE_MACHINE = "(apalis-imx6|colibri-vf|colibri-imx6)"
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr
index 5e31380..be8ec8d 100644
--- a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr
@@ -1,2 +1,2 @@
1setenv update_uboot 'fatload ${interface} 0:1 ${loadaddr} u-boot-nand.imx && nand erase.part u-boot && nand erase.part u-boot-env && nand write ${loadaddr} u-boot' 1setenv update_uboot 'fatload ${interface} 0:1 ${loadaddr} u-boot.imx && nand erase.part u-boot && nand erase.part u-boot-env && nand write ${loadaddr} u-boot'
2echo 'enter "run update_uboot" to update the uboot' 2echo 'enter "run update_uboot" to update the uboot'
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-imx6-enable-sdboot-by-default.patch b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-imx6-enable-sdboot-by-default.patch
new file mode 100644
index 0000000..0743128
--- /dev/null
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-imx6-enable-sdboot-by-default.patch
@@ -0,0 +1,36 @@
1From 10ebeba59e6fd25352aa44ecd85913126ec45afe Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@theqtcompany.com>
3Date: Wed, 24 Feb 2016 15:39:52 +0200
4Subject: [PATCH] colibri imx6: enable sdboot by default
5
6remove console from tty1
7---
8 include/configs/colibri_imx6.h | 5 +++--
9 1 file changed, 3 insertions(+), 2 deletions(-)
10
11diff --git a/include/configs/colibri_imx6.h b/include/configs/colibri_imx6.h
12index c545334..eb0dfa9 100644
13--- a/include/configs/colibri_imx6.h
14+++ b/include/configs/colibri_imx6.h
15@@ -242,7 +242,8 @@
16
17 #define FDT_FILE "imx6dl-colibri-eval-v3.dtb"
18 #define CONFIG_EXTRA_ENV_SETTINGS \
19- "bootcmd=run emmcboot ; echo ; echo emmcboot failed ; " \
20+ "bootcmd=run sdboot ; echo ; echo sdboot failed ; " \
21+ "run emmcboot ; echo ; echo emmcboot failed ; " \
22 "run nfsboot ; echo ; echo nfsboot failed ; " \
23 "usb start ;" \
24 "setenv stdout serial,vga ; setenv stdin serial,usbkbd\0" \
25@@ -261,7 +262,7 @@
26 "setsdupdate=setenv interface mmc; setenv drive 1; mmc rescan; " \
27 "load ${interface} ${drive}:1 ${kernel_addr_r} flash_blk.img\0" \
28 "setup=setenv setupargs fec_mac=${ethaddr} " \
29- "consoleblank=0 no_console_suspend=1 console=tty1 " \
30+ "consoleblank=0 no_console_suspend=1 " \
31 "console=${console},${baudrate}n8\0 " \
32 "setupdate=run setsdupdate || run setusbupdate || run setethupdate;" \
33 " source ${kernel_addr_r}\0" \
34--
351.9.1
36
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-vf-enable-sdboot-by-default.patch b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-vf-enable-sdboot-by-default.patch
deleted file mode 100644
index bae71d5..0000000
--- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-vf-enable-sdboot-by-default.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From 878f506e43f40c2667e9e5ae82741d32fc653cac Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@theqtcompany.com>
3Date: Thu, 28 May 2015 09:06:54 +0300
4Subject: [PATCH] colibri vf: enable sdboot by default
5
6Run sdboot first and remove console message from tty1
7---
8 include/configs/colibri_vf.h | 4 ++--
9 1 file changed, 2 insertions(+), 2 deletions(-)
10
11diff --git a/include/configs/colibri_vf.h b/include/configs/colibri_vf.h
12index 06caabd..fb9fe41 100644
13--- a/include/configs/colibri_vf.h
14+++ b/include/configs/colibri_vf.h
15@@ -174,7 +174,7 @@
16 "ubifsload ${fdt_addr_r} /boot/${soc}-colibri-${fdt_board}.dtb && " \
17 "bootz ${kernel_addr_r} - ${fdt_addr_r}\0" \
18
19-#define CONFIG_BOOTCOMMAND "run ubiboot; run sdboot; run nfsboot"
20+#define CONFIG_BOOTCOMMAND "run sdboot; run ubiboot; run nfsboot"
21
22 #define DFU_ALT_NAND_INFO "vf-bcb part 0,1;u-boot part 0,2;ubi part 0,4"
23
24@@ -187,7 +187,7 @@
25 "defargs=\0" \
26 "console=ttyLP0\0" \
27 "setup=setenv setupargs " \
28- "console=tty1 console=${console}" \
29+ "console=${console}" \
30 ",${baudrate}n8 ${memargs} consoleblank=0\0" \
31 "setsdupdate=mmc rescan && setenv interface mmc && " \
32 "fatload ${interface} 0:1 ${loadaddr} flash_blk.img && " \
33--
341.9.1
35
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend
index 905619a..1165713 100644
--- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend
@@ -20,9 +20,7 @@
20############################################################################## 20##############################################################################
21 21
22FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 22FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
23SRC_URI_append_apalis-imx6 = " \ 23SRC_URI += " \
24 file://0001-Update-default-args-for-apalis-imx6.patch \ 24 file://0001-Update-default-args-for-apalis-imx6.patch \
25 " 25 file://0001-colibri-imx6-enable-sdboot-by-default.patch \
26SRC_URI_append_colibri-vf = " \
27 file://0001-colibri-vf-enable-sdboot-by-default.patch \
28 " 26 "
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-vf-remove-console-from-tty1.patch b/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-vf-remove-console-from-tty1.patch
new file mode 100644
index 0000000..b54a4ae
--- /dev/null
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-vf-remove-console-from-tty1.patch
@@ -0,0 +1,25 @@
1From f480a948551b0e5592d93cb7a5dc1653de900909 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@theqtcompany.com>
3Date: Wed, 24 Feb 2016 16:01:33 +0200
4Subject: [PATCH] colibri vf: remove console from tty1
5
6---
7 include/configs/colibri_vf.h | 2 +-
8 1 file changed, 1 insertion(+), 1 deletion(-)
9
10diff --git a/include/configs/colibri_vf.h b/include/configs/colibri_vf.h
11index b870812..0726fc5 100644
12--- a/include/configs/colibri_vf.h
13+++ b/include/configs/colibri_vf.h
14@@ -202,7 +202,7 @@
15 "fatload ${interface} 0:1 ${loadaddr} flash_blk.img && " \
16 "source ${loadaddr}\0" \
17 "setup=setenv setupargs " \
18- "console=tty1 console=${console}" \
19+ "console=${console}" \
20 ",${baudrate}n8 ${memargs} consoleblank=0\0" \
21 "setupdate=run setsdupdate || run setusbupdate || run setethupdate\0" \
22 "setusbupdate=usb start && setenv interface usb && " \
23--
241.9.1
25
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend b/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend
new file mode 100644
index 0000000..4e0c623
--- /dev/null
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend
@@ -0,0 +1,25 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
23SRC_URI += " \
24 file://0001-colibri-vf-remove-console-from-tty1.patch \
25 "