summaryrefslogtreecommitdiffstats
path: root/meta-toradex-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-09-23 15:17:53 +0300
committerSamuli Piippo <samuli.piippo@digia.com>2014-09-25 15:22:40 +0300
commit8962af850b3317680b88f0d8fa10df5787747e27 (patch)
tree2a2d54bc0ae7ec46581e1fb0d4f4f2afbb428374 /meta-toradex-extras
parent2395137acb37e56a85c1b78bad86a58d9c04e54d (diff)
downloadmeta-boot2qt-8962af850b3317680b88f0d8fa10df5787747e27.tar.gz
Move meta-toradex specific files to separate layer
Create new layer for recipes and files that required only when meta-toradex layer is used. For now, the bblayers.conf template still includes the new layer as well. Change-Id: Ib2c81a444786845f2e7c2fbf78dd0676459996c0 Reviewed-by: Eirik Aavitsland <eirik.aavitsland@digia.com>
Diffstat (limited to 'meta-toradex-extras')
-rw-r--r--meta-toradex-extras/conf/layer.conf33
-rw-r--r--meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend29
2 files changed, 62 insertions, 0 deletions
diff --git a/meta-toradex-extras/conf/layer.conf b/meta-toradex-extras/conf/layer.conf
new file mode 100644
index 0000000..aba9374
--- /dev/null
+++ b/meta-toradex-extras/conf/layer.conf
@@ -0,0 +1,33 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# We have a conf and classes directory, append to BBPATH
24BBPATH .= ":${LAYERDIR}"
25
26# We have a recipes directory, add to BBFILES
27BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
28 ${LAYERDIR}/recipes*/*/*.bbappend \
29 "
30
31BBFILE_COLLECTIONS += "b2qt_toradex"
32BBFILE_PATTERN_b2qt_toradex := "^${LAYERDIR}/"
33BBFILE_PRIORITY_b2qt_toradex = "20"
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend
new file mode 100644
index 0000000..0bcbad7
--- /dev/null
+++ b/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend
@@ -0,0 +1,29 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# kernel image files are not needed in the image
24RDEPENDS_kernel-base = ""
25
26config_script () {
27 # FunctionFS for adb
28 echo "CONFIG_USB_FUNCTIONFS=m" >> ${S}/.config
29}