summaryrefslogtreecommitdiffstats
path: root/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-09-14 16:53:57 +0300
committerFrederik Gladhorn <frederik.gladhorn@qt.io>2016-09-19 14:46:40 +0000
commit5e19fd01a8021b2aef3488666c555edd63eb4582 (patch)
treea35161921fbfcdf0fa2d2b73c3bbd0ea79160709 /meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend
parent97e5acb0a9a1b8c772cbf0018d46f26f61605bd1 (diff)
downloadmeta-boot2qt-5e19fd01a8021b2aef3488666c555edd63eb4582.tar.gz
toradex: use latest u-boot and flashing scripts
The script sources are from meta-toradex-demos layer, but they are patched to update only u-boot part. The u-boot from V2.6 release is the latest that toradex uses in their boards and uses the changed u-boot location. Change-Id: I86345f692961ed906af4d9f251de28eb551d9cbf Reviewed-by: Risto Avila <risto.avila@qt.io> Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend')
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend13
1 files changed, 12 insertions, 1 deletions
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend b/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend
index 4e0c623..d7be9e2 100644
--- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend
@@ -19,7 +19,18 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22PV = "v2015.04-v2.6b2.1+git${SRCPV}"
23SRCREV_b2qt = "90a974d34aaa85d5ce69f83067928592c5389990"
24SRCBRANCH = "2015.04-toradex"
25COMPATIBLE_MACHINE = "(mx6|mx7|vf)"
26
27do_deploy_append_apalis-imx6() {
28 cd ${DEPLOYDIR}
29 ln -sf u-boot-${type}-${PV}-${PR}.${UBOOT_SUFFIX} ${UBOOT_SYMLINK}-${type}
30 ln -sf u-boot-${type}-${PV}-${PR}.${UBOOT_SUFFIX} ${UBOOT_BINARY}-${type}
31}
32
22FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 33FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
23SRC_URI += " \ 34SRC_URI += " \
24 file://0001-colibri-vf-remove-console-from-tty1.patch \ 35 file://0001-Make-sdboot-default-on-all-boards.patch \
25 " 36 "