summaryrefslogtreecommitdiffstats
path: root/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/colibri-imx7/0001-Update-only-u-boot.patch
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-09-21 11:57:54 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-09-21 11:57:54 +0300
commit460ef0a31e5e5684e785cdde115244e69f74b01b (patch)
tree6f42855f3e92e16e730fd1bfcbf7fb07369d42f7 /meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/colibri-imx7/0001-Update-only-u-boot.patch
parent4ae75513231a69dc176fdb37c20bcb8c87c2f8c8 (diff)
parent2b115238356e2cfa963f004cb8469533d4d21305 (diff)
downloadmeta-boot2qt-460ef0a31e5e5684e785cdde115244e69f74b01b.tar.gz
Merge remote-tracking branch 'origin/fido' into jethro
* origin/fido: qt5: update submodules toradex: use latest u-boot and flashing scripts kontron: update to SMARC-sAMX6i BSP release v2.0, RC2 Use code.qt.io with git protocol instead of codereview Use new repo url for utils and appcontroller qt5: update submodules qtquickcompiler: update revision qtquickcompiler: update revision Fix typo in RPi overlay config Update meta layers Conflicts: conf/distro/include/colibri-imx6.conf conf/distro/include/raspberrypi2.conf conf/distro/include/toradex.inc meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-Update-default-args-for-apalis-imx6.patch meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-imx6-enable-sdboot-by-default.patch meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend meta-toradex-extras/recipes/u-boot/u-boot-toradex_git.bbappend recipes-qt/b2qt-addons/b2qt-appcontroller.bb recipes-qt/b2qt-addons/b2qt-utils.bb recipes-qt/qt5/nativesdk-qtbase_git.bbappend recipes-qt/qt5/qtbase-native_git.bbappend recipes-qt/qt5/qtbase_git.bbappend recipes-qt/qt5/qtcanvas3d_git.bbappend recipes-qt/qt5/qtcharts_git.bb recipes-qt/qt5/qtconnectivity_git.bbappend recipes-qt/qt5/qtdeclarative-render2d_git.bb recipes-qt/qt5/qtdeclarative_git.bbappend recipes-qt/qt5/qtlocation_git.bbappend recipes-qt/qt5/qtmultimedia_git.bbappend recipes-qt/qt5/qtquickcompiler_git.bb recipes-qt/qt5/qtquickcontrols_git.bbappend recipes-qt/qt5/qtsensors_git.bbappend recipes-qt/qt5/qtserialbus_git.bb recipes-qt/qt5/qtserialport_git.bbappend recipes-qt/qt5/qttools_git.bbappend recipes-qt/qt5/qttranslations_git.bbappend recipes-qt/qt5/qtvirtualkeyboard_git.bbappend recipes-qt/qt5/qtwayland-native_git.bbappend recipes-qt/qt5/qtwayland_git.bbappend recipes-qt/qt5/qtwebengine_git.bbappend scripts/manifest.xml Change-Id: I621a82a6deeeb2b74c8179c2f46b4fa42968b636
Diffstat (limited to 'meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/colibri-imx7/0001-Update-only-u-boot.patch')
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/colibri-imx7/0001-Update-only-u-boot.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/colibri-imx7/0001-Update-only-u-boot.patch b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/colibri-imx7/0001-Update-only-u-boot.patch
new file mode 100644
index 0000000..08ddd88
--- /dev/null
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/colibri-imx7/0001-Update-only-u-boot.patch
@@ -0,0 +1,36 @@
1From c02da9f92f6ffaee65f428e1978bd3ff379a2612 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Wed, 14 Sep 2016 10:19:28 +0300
4Subject: [PATCH] Update only u-boot
5
6---
7 flash_blk.scr | 4 ++--
8 flash_eth.scr | 4 ++--
9 2 files changed, 4 insertions(+), 4 deletions(-)
10
11diff --git a/flash_blk.scr b/flash_blk.scr
12index cc4cf38..b63366a 100644
13--- a/flash_blk.scr
14+++ b/flash_blk.scr
15@@ -14,6 +14,6 @@ setenv update_rootfs 'fatload ${interface} 0:1 ${loadaddr} ${board_name}/ubifs.i
16
17 setenv upgrade_alpha1_msg 'Updated U-Boot, please reset the board and use "run setupdate && run update" again.'
18 setenv prepare_alpha1_uboot 'if test "${soc}" = "mx7"; then run update_uboot && echo ${upgrade_alpha1_msg} && reset; fi'
19-setenv update 'mtdparts default && run prepare_alpha1_uboot; run update_uboot && run prepare_ubi && run update_kernel && run update_fdt && run update_rootfs && reset'
20+setenv update 'mtdparts default && run update_uboot && reset'
21
22-echo 'enter "run update" to update the entire module'
23+echo 'enter "run update" to update the uboot'
24diff --git a/flash_eth.scr b/flash_eth.scr
25index 01be124..13025de 100644
26--- a/flash_eth.scr
27+++ b/flash_eth.scr
28@@ -14,6 +14,6 @@ setenv update_rootfs 'tftpboot ${loadaddr} ${board_name}/ubifs.img && ubi write
29
30 setenv upgrade_alpha1_msg 'Updated U-Boot, please reset the board and use "run setupdate && run update" again.'
31 setenv prepare_alpha1_uboot 'if test "${soc}" = "mx7"; then run update_uboot && echo ${upgrade_alpha1_msg} && reset; fi'
32-setenv update 'mtdparts default && run prepare_alpha1_uboot; run update_uboot && run prepare_ubi && run update_kernel && run update_fdt && run update_rootfs && reset'
33+setenv update 'mtdparts default && run update_uboot && reset'
34
35-echo 'enter "run update" to update the entire module'
36+echo 'enter "run update" to update the uboot'