summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-05-12 12:29:17 +0300
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-05-12 14:45:38 +0300
commit4f943fd455a37ff4663e25730c353247f2d9e49f (patch)
tree6c11d57c497f579ae5fa3c44bca06b3fa70b8ed0 /meta-ti-extras
parent58b688071999ee2f9a5a72d217351cfd97f45123 (diff)
downloadmeta-boot2qt-4f943fd455a37ff4663e25730c353247f2d9e49f.tar.gz
Remove old kernel recipes for am335x-evm and beagleboard
Upstream meta-ti has removed these kernel version, so the bbappend files need to go as well. Both am335x-evm and beagleboard are not officially supported devices, so the kernel config changes needed to the new kernel will be done only if requested. Change-Id: Ic3d8e1cc7fcdf30875c3ed3667a09e96817e0e45 Reviewed-by: Andy Nichols <andy.nichols@theqtcompany.com>
Diffstat (limited to 'meta-ti-extras')
-rw-r--r--meta-ti-extras/recipes/linux/linux-am335x-psp_3.2.bbappend40
-rw-r--r--meta-ti-extras/recipes/linux/linux-mainline_3.2.bbappend42
2 files changed, 0 insertions, 82 deletions
diff --git a/meta-ti-extras/recipes/linux/linux-am335x-psp_3.2.bbappend b/meta-ti-extras/recipes/linux/linux-am335x-psp_3.2.bbappend
deleted file mode 100644
index 0b4beff..0000000
--- a/meta-ti-extras/recipes/linux/linux-am335x-psp_3.2.bbappend
+++ /dev/null
@@ -1,40 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23do_configure_append() {
24 # FunctionFS for adb
25 echo "CONFIG_USB_LIBCOMPOSITE=y" >> ${S}/.config
26 echo "CONFIG_USB_FUNCTIONFS=m" >> ${S}/.config
27 echo "CONFIG_USB_FUNCTIONFS_ETH=n" >> ${S}/.config
28 echo "CONFIG_USB_FUNCTIONFS_RNDIS=n" >> ${S}/.config
29 echo "CONFIG_USB_FUNCTIONFS_GENERIC=y" >> ${S}/.config
30
31 echo "CONFIG_DEVTMPFS=y" >> ${S}/.config
32
33 # Enable USB serial support
34 echo "CONFIG_USB_SERIAL=m" >> ${S}/.config
35 echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${S}/.config
36 echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${S}/.config
37 echo "CONFIG_USB_SERIAL_PL2303=m" >> ${S}/.config
38
39 yes '' | oe_runmake oldconfig
40}
diff --git a/meta-ti-extras/recipes/linux/linux-mainline_3.2.bbappend b/meta-ti-extras/recipes/linux/linux-mainline_3.2.bbappend
deleted file mode 100644
index 502edf1..0000000
--- a/meta-ti-extras/recipes/linux/linux-mainline_3.2.bbappend
+++ /dev/null
@@ -1,42 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23do_configure_prepend() {
24 # Builtin network driver, so networking is initialized correctly during boot
25 echo "CONFIG_USB_NET_SMSC95XX=y" >> ${WORKDIR}/defconfig
26
27 # FunctionFS for adb
28 echo "CONFIG_USB_FUNCTIONFS_ETH=n" >> ${WORKDIR}/defconfig
29 echo "CONFIG_USB_FUNCTIONFS_RNDIS=n" >> ${WORKDIR}/defconfig
30 echo "CONFIG_USB_FUNCTIONFS_GENERIC=y" >> ${WORKDIR}/defconfig
31
32 # Enable USB serial support
33 echo "CONFIG_USB_SERIAL=m" >> ${WORKDIR}/defconfig
34 echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${WORKDIR}/defconfig
35 echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig
36 echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig
37
38 # Remove beagleboard logo
39 if [ -e ${WORKDIR}/${LOGO_SIZE}/logo_linux_clut224.ppm ]; then
40 rm ${WORKDIR}/${LOGO_SIZE}/logo_linux_clut224.ppm
41 fi
42}