summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-02-02 09:26:40 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-02-19 11:23:06 +0200
commit4a8019ef9314bba9a8ecaa01a899b9602fab744b (patch)
treee86d1eac7f8e9a6d76348b2f777932e057c4c118 /meta-ti-extras
parent4a13a522a080f5c3c66948f081aecaa94fd6fc9b (diff)
downloadmeta-boot2qt-4a8019ef9314bba9a8ecaa01a899b9602fab744b.tar.gz
BBB: fix libgles-omap3 build
4.x version of libgles-omap4 did not build correctly any more, since correct compiler flags were not used. Need to use the CC instead of PLAT_CC which is modified by the makefiles. Change-Id: I23f4f757db392a65a6322be857bd47c06047f38b Reviewed-by: Andy Nichols <andy.nichols@theqtcompany.com>
Diffstat (limited to 'meta-ti-extras')
-rw-r--r--meta-ti-extras/recipes/libgles/libgles-omap3_4.10.00.01.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta-ti-extras/recipes/libgles/libgles-omap3_4.10.00.01.bb b/meta-ti-extras/recipes/libgles/libgles-omap3_4.10.00.01.bb
index 1c9824c..9265ffe 100644
--- a/meta-ti-extras/recipes/libgles/libgles-omap3_4.10.00.01.bb
+++ b/meta-ti-extras/recipes/libgles/libgles-omap3_4.10.00.01.bb
@@ -1,6 +1,6 @@
1require recipes-graphics/libgles/libgles-omap3-no-x.inc 1require recipes-graphics/libgles/libgles-omap3-no-x.inc
2 2
3FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:${COREBASE}/../meta-ti/recipes-graphics/libgles/${PN}" 3FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:${COREBASE}/../meta-ti/recipes-graphics/libgles/${PN}:"
4 4
5LICENSE = "TI-TSPA" 5LICENSE = "TI-TSPA"
6 6
@@ -46,3 +46,10 @@ SRC_URI[sha256sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard',
46S = "${WORKDIR}/Graphics_SDK_${SGXPV}" 46S = "${WORKDIR}/Graphics_SDK_${SGXPV}"
47 47
48LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FRONTWSEGL.so.1" 48LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FRONTWSEGL.so.1"
49
50do_configure_append() {
51 # PLAT_CC might not have needed arguments, so use CC instead.
52 for mak in $(find ${S} -name "*.mak" -o -name Makefile) ; do
53 sed -i -e s:\$\(PLAT_CC\):\$\(CC\):g $mak
54 done
55}