summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-09-23 12:34:23 +0300
committerSamuli Piippo <samuli.piippo@digia.com>2014-09-25 15:22:18 +0300
commit0dded51636b689237af7fdcda1719790c7fb3aa7 (patch)
treee3eb3b08771005311ca9157882ff2dad6cb733f8 /meta-ti-extras
parent841eaa73863184bba6c805fc622e242f367609f7 (diff)
downloadmeta-boot2qt-0dded51636b689237af7fdcda1719790c7fb3aa7.tar.gz
Move meta-ti specific files to separate layer
Create new layer for recipes and files that required only when meta-ti layer is used. For now, the bblayers.conf template still includes the new layer as well. Change-Id: Iab8f6b3a61578e7a9579066ae7facca5a9a1f33b Reviewed-by: Eirik Aavitsland <eirik.aavitsland@digia.com>
Diffstat (limited to 'meta-ti-extras')
-rw-r--r--meta-ti-extras/conf/layer.conf33
-rwxr-xr-xmeta-ti-extras/recipes/libgles/libgles-omap3/rc.pvr117
-rw-r--r--meta-ti-extras/recipes/libgles/libgles-omap3_4.09.00.01.bbappend43
-rw-r--r--meta-ti-extras/recipes/libgles/libgles-omap3_4.10.00.01.bb48
-rw-r--r--meta-ti-extras/recipes/libgles/libgles-omap3_5.01.01.01.bbappend42
-rw-r--r--meta-ti-extras/recipes/linux/linux-am335x-psp_3.2.bbappend40
-rw-r--r--meta-ti-extras/recipes/linux/linux-mainline_3.2.bbappend42
-rw-r--r--meta-ti-extras/recipes/linux/linux-ti-staging/usb-serial.cfg4
-rw-r--r--meta-ti-extras/recipes/linux/linux-ti-staging_3.12.bbappend28
-rw-r--r--meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/0001-Graphics-SDK-04.10.00.01-AM335x-sgx-irq-change.patch32
-rw-r--r--meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/Change-for-interfacing-with-SGX-DT-node.patch51
-rw-r--r--meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/linux-3.8.patch63
-rw-r--r--meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules_4.10.00.01.bb66
-rw-r--r--meta-ti-extras/recipes/u-boot/u-boot-am33x/0001-am335x-evm-disable-console-cursor-blinking.patch25
-rw-r--r--meta-ti-extras/recipes/u-boot/u-boot-am33x_2013.01.01.bbappend26
-rw-r--r--meta-ti-extras/recipes/u-boot/u-boot-ti-staging/0001-BBB-disable-console-cursor-blinking.patch25
-rw-r--r--meta-ti-extras/recipes/u-boot/u-boot-ti-staging_2013.10.bbappend26
17 files changed, 711 insertions, 0 deletions
diff --git a/meta-ti-extras/conf/layer.conf b/meta-ti-extras/conf/layer.conf
new file mode 100644
index 0000000..120b507
--- /dev/null
+++ b/meta-ti-extras/conf/layer.conf
@@ -0,0 +1,33 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# We have a conf and classes directory, append to BBPATH
24BBPATH .= ":${LAYERDIR}"
25
26# We have a recipes directory, add to BBFILES
27BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
28 ${LAYERDIR}/recipes*/*/*.bbappend \
29 "
30
31BBFILE_COLLECTIONS += "b2qt_ti"
32BBFILE_PATTERN_b2qt_ti := "^${LAYERDIR}/"
33BBFILE_PRIORITY_b2qt_ti = "20"
diff --git a/meta-ti-extras/recipes/libgles/libgles-omap3/rc.pvr b/meta-ti-extras/recipes/libgles/libgles-omap3/rc.pvr
new file mode 100755
index 0000000..d6f6c82
--- /dev/null
+++ b/meta-ti-extras/recipes/libgles/libgles-omap3/rc.pvr
@@ -0,0 +1,117 @@
1#!/bin/sh
2PATH=$PATH:/usr/sbin
3
4# Check if an fb device is available. If not then just go ahead and
5# exit because we have no display.
6fbset > /dev/null 2>&1
7if [ "$?" == "1" ]
8then
9 # looks like there is no display, so let's exit
10 exit 0
11fi
12
13BITSPERPIXEL="$(fbset | grep geom | awk '{print $6}')"
14YRES="$(fbset | grep geom | awk '{print $3}')"
15
16CPUTYPE="$(cputype)"
17
18if [ "$1" = "" ]; then
19 echo PVR-INIT: Please use start, stop, or restart.
20 exit 1
21fi
22
23if [ "$1" = "stop" -o "$1" = "restart" ]; then
24 echo Stopping PVR
25 rmmod bufferclass_ti
26 rmmod omaplfb 2>/dev/null
27 rmmod pvrsrvkm 2>/dev/null
28fi
29
30if [ "$1" = "stop" ]; then
31 exit 0
32fi
33
34# Set RGBA ordering to something the drivers like
35if [ "$BITSPERPIXEL" = "32" ] ; then
36 fbset -rgba 8/16,8/8,8/0,8/24
37fi
38
39# Try to enable triple buffering when there's enough VRAM
40fbset -vyres $(expr $YRES \* 3)
41
42sgxprepare () {
43 echo Starting PVR
44
45 modprobe omaplfb
46 modprobe bufferclass_ti
47
48 pvr_maj=`grep "pvrsrvkm$" /proc/devices | cut -b1,2,3`
49 bc_maj=`grep "bc" /proc/devices | cut -b1,2,3`
50
51 if [ -e /dev/pvrsrvkm ] ; then
52 rm -f /dev/pvrsrvkm
53 fi
54
55 mknod /dev/pvrsrvkm c $pvr_maj 0
56 chmod 666 /dev/pvrsrvkm
57
58 touch /etc/powervr-esrev
59
60 SAVED_ESREVISION="$(cat /etc/powervr-esrev)"
61}
62
63sgxfinish () {
64 # Fix up a bug in opkg
65 if [ $(readlink /usr/lib/libsrv_um.so) != $(readlink /usr/lib/libsrv_um.so.1) ] ; then
66 cd /usr/lib
67 ln -sf $(readlink /usr/lib/libsrv_um.so.1) libsrv_um.so
68 fi
69
70 if [ "${ES_REVISION}" != "${SAVED_ESREVISION}" ] ; then
71 echo -n "Starting SGX fixup for"
72 echo " ES${ES_REVISION}.x"
73 cp -a /usr/lib/ES${ES_REVISION}.0/* /usr/lib
74 cp -a /usr/bin/ES${ES_REVISION}.0/* /usr/bin
75 echo "${ES_REVISION}" > /etc/powervr-esrev
76 fi
77
78 /usr/bin/pvrsrvctl --start --no-module
79}
80
81case $CPUTYPE in
82"OMAP3530")
83 sgxprepare
84
85 devmem2 0x48004B48 w 0x2 > /dev/null
86 devmem2 0x48004B10 w 0x1 > /dev/null
87 devmem2 0x48004B00 w 0x2 > /dev/null
88
89 ES_REVISION="$(devmem2 0x50000014 | sed -e s:0x00010205:5: -e s:0x00010201:3: -e s:0x00010003:2: | tail -n1 | awk -F': ' '{print $2}')"
90
91 sgxfinish
92 ;;
93"TI33XX")
94 sgxprepare
95
96 devmem2 0x44e01104 w 0x0 > /dev/null
97 devmem2 0x44e00904 w 0x2 > /dev/null
98
99 ES_REVISION="$(devmem2 0x56000014 | sed -e s:0x00010205:8: | tail -n1 | awk -F': ' '{print $2}')"
100
101 sgxfinish
102 ;;
103"TI816x")
104 sgxprepare
105
106 devmem2 0x48180F04 w 0x0 > /dev/null
107 devmem2 0x48180900 w 0x2 > /dev/null
108 devmem2 0x48180920 w 0x2 > /dev/null
109
110 ES_REVISION="$(devmem2 0x56000014 | sed -e s:0x00010205:6: -e s:0x00010201:3: -e s:0x00010003:2: | tail -n1 | awk -F': ' '{print $2}')"
111
112 sgxfinish
113 ;;
114*)
115 echo No SGX hardware, not starting PVR
116 ;;
117esac
diff --git a/meta-ti-extras/recipes/libgles/libgles-omap3_4.09.00.01.bbappend b/meta-ti-extras/recipes/libgles/libgles-omap3_4.09.00.01.bbappend
new file mode 100644
index 0000000..0646e73
--- /dev/null
+++ b/meta-ti-extras/recipes/libgles/libgles-omap3_4.09.00.01.bbappend
@@ -0,0 +1,43 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23BINLOCATION_omap3 = "${S}/gfx_rel_es5.x"
24
25LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FLIPWSEGL.so.1"
26
27do_install_append() {
28 echo "ParamBufferSize=33554432" >> ${D}${sysconfdir}/powervr.ini
29}
30
31# Inhibit warnings about files being stripped.
32INHIBIT_PACKAGE_STRIP = "1"
33
34pkg_postinst_${PN}_append() {
35ESREV=$(echo ${BINLOCATION} | grep -Po '(\d+)(?!.*\d)' )
36echo ${ESREV} > $D${sysconfdir}/powervr-esrev
37}
38
39RRECOMMENDS_${PN} = "omap3-sgx-modules"
40RRECOMMENDS_${PN}-blitwsegl = ""
41RRECOMMENDS_${PN}-flipwsegl = ""
42RRECOMMENDS_${PN}-frontwsegl = ""
43RRECOMMENDS_${PN}-linuxfbwsegl = ""
diff --git a/meta-ti-extras/recipes/libgles/libgles-omap3_4.10.00.01.bb b/meta-ti-extras/recipes/libgles/libgles-omap3_4.10.00.01.bb
new file mode 100644
index 0000000..6a8c1ba
--- /dev/null
+++ b/meta-ti-extras/recipes/libgles/libgles-omap3_4.10.00.01.bb
@@ -0,0 +1,48 @@
1require recipes-graphics/libgles/libgles-omap3-no-x.inc
2
3FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:${COREBASE}/meta-ti/recipes-graphics/libgles/${PN}"
4
5LICENSE = "TI-TSPA"
6
7PR = "${INC_PR}.3"
8
9BINLOCATION_omap3 = "${S}/gfx_rel_es3.x"
10BINLOCATION_ti816x = "${S}/gfx_rel_es6.x"
11BINLOCATION_ti814x = "${S}/gfx_rel_es6.x"
12BINLOCATION_ti33x = "${S}/gfx_rel_es8.x"
13
14PLATFORM = "LinuxARMV7"
15PVR_INIT = "pvrsrvctl"
16
17# download required binary distribution from:
18# http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
19# see libgles-omap3.inc for detailed installation instructions
20
21SGXPV = "4_10_00_01"
22IMGPV = "1.9.2188537"
23
24TI_BIN_UNPK_WDEXT := "/Graphics_SDK_${SGXPV}"
25
26# Select the corresponding hardfp/softfp filename and checksums based on tune flags
27BINFILE_SOFTFP = "Graphics_SDK_setuplinux_${SGXPV}_minimal_demos.bin"
28MD5SUM_SOFTFP = "bd35e9d8843aff3a2aca9d41e7db1c7d"
29SHA256SUM_SOFTFP = "eb37f75ddde4640b09e760fa86e689beb394330ecdf68786188c34f249247647"
30
31BINFILE_HARDFP = "Graphics_SDK_setuplinux_${SGXPV}_hardfp_minimal_demos.bin"
32MD5SUM_HARDFP = "15a3ccb66e98580e474fc112565f66b6"
33SHA256SUM_HARDFP = "4d94d5a1869b228ce12027783fc5425c92e9b66685c501247889f1f167e66c9d"
34
35BINFILE = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${BINFILE_HARDFP}', '${BINFILE_SOFTFP}', d)}"
36
37SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \
38 file://cputype \
39 file://rc.pvr \
40 file://99-bufferclass.rules \
41"
42
43SRC_URI[md5sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${MD5SUM_HARDFP}', '${MD5SUM_SOFTFP}', d)}"
44SRC_URI[sha256sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${SHA256SUM_HARDFP}', '${SHA256SUM_SOFTFP}', d)}"
45
46S = "${WORKDIR}/Graphics_SDK_${SGXPV}"
47
48LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FRONTWSEGL.so.1"
diff --git a/meta-ti-extras/recipes/libgles/libgles-omap3_5.01.01.01.bbappend b/meta-ti-extras/recipes/libgles/libgles-omap3_5.01.01.01.bbappend
new file mode 100644
index 0000000..9a90577
--- /dev/null
+++ b/meta-ti-extras/recipes/libgles/libgles-omap3_5.01.01.01.bbappend
@@ -0,0 +1,42 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
24
25BINLOCATION_omap3 = "${S}/gfx_rel_es5.x"
26BINLOCATION_beaglebone = "${S}/gfx_rel_es8.x"
27
28LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FLIPWSEGL.so.1"
29
30# Inhibit warnings about files being stripped.
31INHIBIT_PACKAGE_STRIP = "1"
32
33pkg_postinst_${PN}_append() {
34ESREV=$(echo ${BINLOCATION} | grep -Po '(\d+)(?!.*\d)' )
35echo ${ESREV} > $D${sysconfdir}/powervr-esrev
36}
37
38RRECOMMENDS_${PN} = "omap3-sgx-modules"
39RRECOMMENDS_${PN}-blitwsegl = ""
40RRECOMMENDS_${PN}-flipwsegl = ""
41RRECOMMENDS_${PN}-frontwsegl = ""
42RRECOMMENDS_${PN}-linuxfbwsegl = ""
diff --git a/meta-ti-extras/recipes/linux/linux-am335x-psp_3.2.bbappend b/meta-ti-extras/recipes/linux/linux-am335x-psp_3.2.bbappend
new file mode 100644
index 0000000..fd7dd31
--- /dev/null
+++ b/meta-ti-extras/recipes/linux/linux-am335x-psp_3.2.bbappend
@@ -0,0 +1,40 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23do_configure_append() {
24 # FunctionFS for adb
25 echo "CONFIG_USB_LIBCOMPOSITE=y" >> ${S}/.config
26 echo "CONFIG_USB_FUNCTIONFS=m" >> ${S}/.config
27 echo "CONFIG_USB_FUNCTIONFS_ETH=n" >> ${S}/.config
28 echo "CONFIG_USB_FUNCTIONFS_RNDIS=n" >> ${S}/.config
29 echo "CONFIG_USB_FUNCTIONFS_GENERIC=y" >> ${S}/.config
30
31 echo "CONFIG_DEVTMPFS=y" >> ${S}/.config
32
33 # Enable USB serial support
34 echo "CONFIG_USB_SERIAL=m" >> ${S}/.config
35 echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${S}/.config
36 echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${S}/.config
37 echo "CONFIG_USB_SERIAL_PL2303=m" >> ${S}/.config
38
39 yes '' | oe_runmake oldconfig
40}
diff --git a/meta-ti-extras/recipes/linux/linux-mainline_3.2.bbappend b/meta-ti-extras/recipes/linux/linux-mainline_3.2.bbappend
new file mode 100644
index 0000000..9e195dc
--- /dev/null
+++ b/meta-ti-extras/recipes/linux/linux-mainline_3.2.bbappend
@@ -0,0 +1,42 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23do_configure_prepend() {
24 # Builtin network driver, so networking is initialized correctly during boot
25 echo "CONFIG_USB_NET_SMSC95XX=y" >> ${WORKDIR}/defconfig
26
27 # FunctionFS for adb
28 echo "CONFIG_USB_FUNCTIONFS_ETH=n" >> ${WORKDIR}/defconfig
29 echo "CONFIG_USB_FUNCTIONFS_RNDIS=n" >> ${WORKDIR}/defconfig
30 echo "CONFIG_USB_FUNCTIONFS_GENERIC=y" >> ${WORKDIR}/defconfig
31
32 # Enable USB serial support
33 echo "CONFIG_USB_SERIAL=m" >> ${WORKDIR}/defconfig
34 echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${WORKDIR}/defconfig
35 echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig
36 echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig
37
38 # Remove beagleboard logo
39 if [ -e ${WORKDIR}/${LOGO_SIZE}/logo_linux_clut224.ppm ]; then
40 rm ${WORKDIR}/${LOGO_SIZE}/logo_linux_clut224.ppm
41 fi
42}
diff --git a/meta-ti-extras/recipes/linux/linux-ti-staging/usb-serial.cfg b/meta-ti-extras/recipes/linux/linux-ti-staging/usb-serial.cfg
new file mode 100644
index 0000000..8f0688e
--- /dev/null
+++ b/meta-ti-extras/recipes/linux/linux-ti-staging/usb-serial.cfg
@@ -0,0 +1,4 @@
1CONFIG_USB_SERIAL=m
2CONFIG_USB_SERIAL_GENERIC=y
3CONFIG_USB_SERIAL_FTDI_SIO=m
4CONFIG_USB_SERIAL_PL2303=m
diff --git a/meta-ti-extras/recipes/linux/linux-ti-staging_3.12.bbappend b/meta-ti-extras/recipes/linux/linux-ti-staging_3.12.bbappend
new file mode 100644
index 0000000..b2d6104
--- /dev/null
+++ b/meta-ti-extras/recipes/linux/linux-ti-staging_3.12.bbappend
@@ -0,0 +1,28 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
24SRC_URI += "\
25 file://usb-serial.cfg \
26 "
27KERNEL_CONFIG_FRAGMENTS += "${WORKDIR}/usb-serial.cfg"
28KERNEL_DEVICETREE_b2qt = "am335x-evm.dtb am335x-evmsk.dtb am335x-bone.dtb am335x-boneblack.dtb"
diff --git a/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/0001-Graphics-SDK-04.10.00.01-AM335x-sgx-irq-change.patch b/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/0001-Graphics-SDK-04.10.00.01-AM335x-sgx-irq-change.patch
new file mode 100644
index 0000000..ce50479
--- /dev/null
+++ b/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/0001-Graphics-SDK-04.10.00.01-AM335x-sgx-irq-change.patch
@@ -0,0 +1,32 @@
1From e55f63a07e5266095da89b7f94122fcba9bdef04 Mon Sep 17 00:00:00 2001
2From: Prathap M S <msprathap@ti.com>
3Date: Tue, 19 Nov 2013 16:33:24 +0530
4Subject: [PATCH 1/1] Graphics SDK 04.10.00.01 : AM335x sgx irq change
5
6This patch enables PVR_LINUX_DYNAMIC_SGX_RESOURCE_INFO for AM335x.
7This is required with 3.8 kernel onwards which uses DT.
8This will enable the path of getting sgx irq number dynamically.
9
10Signed-off-by: Prathap M S <msprathap@ti.com>
11---
12 services4/system/ti335x/syslocal.h | 4 ++--
13 1 file changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/services4/system/ti335x/syslocal.h b/services4/system/ti335x/syslocal.h
16index 090b38d..222d52d 100644
17--- a/services4/system/ti335x/syslocal.h
18+++ b/services4/system/ti335x/syslocal.h
19@@ -69,8 +69,8 @@ CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
20 #if !defined(LDM_PLATFORM)
21 #error "LDM_PLATFORM must be set"
22 #endif
23-//#define PVR_LINUX_DYNAMIC_SGX_RESOURCE_INFO
24-//#include <linux/platform_device.h>
25+#define PVR_LINUX_DYNAMIC_SGX_RESOURCE_INFO
26+#include <linux/platform_device.h>
27 #endif
28
29 #if ((defined(DEBUG) || defined(TIMING)) && \
30--
311.7.9.5
32
diff --git a/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/Change-for-interfacing-with-SGX-DT-node.patch b/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/Change-for-interfacing-with-SGX-DT-node.patch
new file mode 100644
index 0000000..c553354
--- /dev/null
+++ b/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/Change-for-interfacing-with-SGX-DT-node.patch
@@ -0,0 +1,51 @@
1diff --git a/services4/srvkm/env/linux/module.c b/services4/srvkm/env/linux/module.c
2index 668dc2d..2247aad 100644
3--- a/services4/srvkm/env/linux/module.c
4+++ b/services4/srvkm/env/linux/module.c
5@@ -84,6 +84,9 @@ CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
6 #include <linux/module.h>
7 #include <linux/fs.h>
8 #include <linux/proc_fs.h>
9+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(3,8,0))
10+#include <linux/of.h>
11+#endif
12
13 #if defined(SUPPORT_DRI_DRM)
14 #include <drm/drmP.h>
15@@ -296,10 +299,24 @@ static struct platform_device_id powervr_id_table[] __devinitdata = {
16 };
17 #endif
18
19+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(3,8,0))
20+static const struct of_device_id omap_sgx_of_match[] = {
21+ {
22+ .compatible = "ti,sgx",
23+ },
24+ {},
25+};
26+MODULE_DEVICE_TABLE(of, omap_sgx_of_match);
27+#endif
28+
29+
30 static LDM_DRV powervr_driver = {
31 #if defined(PVR_LDM_PLATFORM_MODULE)
32 .driver = {
33 .name = DRVNAME,
34+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(3,8,0))
35+ .of_match_table = of_match_ptr(omap_sgx_of_match),
36+#endif
37 },
38 #endif
39 #if defined(PVR_LDM_PCI_MODULE)
40@@ -362,7 +379,7 @@ static int __devinit PVRSRVDriverProbe(LDM_DEV *pDevice, const struct pci_device
41 #endif
42 {
43 SYS_DATA *psSysData;
44-
45+
46 PVR_TRACE(("PVRSRVDriverProbe(pDevice=%p)", pDevice));
47
48 #if 0 /* INTEGRATION_POINT */
49--
501.7.9.5
51
diff --git a/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/linux-3.8.patch b/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/linux-3.8.patch
new file mode 100644
index 0000000..acef54b
--- /dev/null
+++ b/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/linux-3.8.patch
@@ -0,0 +1,63 @@
1diff --git a/services4/3rdparty/linux_drm/Kbuild b/services4/3rdparty/linux_drm/Kbuild
2index d01ef39..ccca3cd 100755
3--- a/services4/3rdparty/linux_drm/Kbuild
4+++ b/services4/3rdparty/linux_drm/Kbuild
5@@ -26,38 +26,38 @@ endif
6 endif
7
8 obj-m := drm.o
9-ifeq ($(TI_PLATFORM),omap4)
10-drm-y := pvr_drm_stubs.o drm_auth.o drm_bufs.o drm_cache.o drm_context.o drm_dma.o drm_drawable.o drm_drv.o drm_fops.o drm_gem.o drm_ioctl.o drm_irq.o \
11- drm_lock.o drm_memory.o drm_proc.o drm_stub.o drm_vm.o \
12- drm_agpsupport.o drm_scatter.o ati_pcigart.o drm_pci.o \
13- drm_sysfs.o drm_hashtab.o drm_sman.o drm_mm.o \
14- drm_crtc.o drm_modes.o drm_edid.o \
15- drm_info.o drm_debugfs.o drm_encoder_slave.o
16-else
17+#ifeq ($(TI_PLATFORM),omap4)
18+#drm-y := pvr_drm_stubs.o drm_auth.o drm_bufs.o drm_cache.o drm_context.o drm_dma.o drm_drawable.o drm_drv.o drm_fops.o drm_gem.o drm_ioctl.o drm_irq.o \
19+# drm_lock.o drm_memory.o drm_proc.o drm_stub.o drm_vm.o \
20+# drm_agpsupport.o drm_scatter.o ati_pcigart.o drm_pci.o \
21+# drm_sysfs.o drm_hashtab.o drm_sman.o drm_mm.o \
22+# drm_crtc.o drm_modes.o drm_edid.o \
23+# drm_info.o drm_debugfs.o drm_encoder_slave.o
24+#else
25 # Works for 2.6.37 till 3.2 kernel
26-drm-y := pvr_drm_stubs.o drm_auth.o drm_bufs.o drm_cache.o drm_context.o drm_dma.o drm_drv.o drm_fops.o drm_gem.o drm_ioctl.o drm_irq.o \
27- drm_lock.o drm_memory.o drm_proc.o drm_stub.o drm_vm.o \
28- drm_agpsupport.o drm_scatter.o ati_pcigart.o drm_pci.o \
29- drm_sysfs.o drm_hashtab.o drm_sman.o drm_mm.o \
30- drm_crtc.o drm_modes.o drm_edid.o \
31- drm_info.o drm_debugfs.o drm_encoder_slave.o drm_global.o drm_platform.o drm_trace_points.o
32-endif
33-
34-# For 3.3 kernel only
35 #drm-y := pvr_drm_stubs.o drm_auth.o drm_bufs.o drm_cache.o drm_context.o drm_dma.o drm_drv.o drm_fops.o drm_gem.o drm_ioctl.o drm_irq.o \
36 # drm_lock.o drm_memory.o drm_proc.o drm_stub.o drm_vm.o \
37 # drm_agpsupport.o drm_scatter.o ati_pcigart.o drm_pci.o \
38-# drm_sysfs.o drm_hashtab.o drm_mm.o \
39+# drm_sysfs.o drm_hashtab.o drm_sman.o drm_mm.o \
40 # drm_crtc.o drm_modes.o drm_edid.o \
41 # drm_info.o drm_debugfs.o drm_encoder_slave.o drm_global.o drm_platform.o drm_trace_points.o
42+#endif
43
44-# For greater than/equal to 3.4 till 3.8 kernel
45+# For 3.3 kernel only
46 #drm-y := pvr_drm_stubs.o drm_auth.o drm_bufs.o drm_cache.o drm_context.o drm_dma.o drm_drv.o drm_fops.o drm_gem.o drm_ioctl.o drm_irq.o \
47 # drm_lock.o drm_memory.o drm_proc.o drm_stub.o drm_vm.o \
48 # drm_agpsupport.o drm_scatter.o ati_pcigart.o drm_pci.o \
49 # drm_sysfs.o drm_hashtab.o drm_mm.o \
50 # drm_crtc.o drm_modes.o drm_edid.o \
51-# drm_info.o drm_debugfs.o drm_encoder_slave.o drm_global.o drm_platform.o drm_trace_points.o drm_prime.o
52+# drm_info.o drm_debugfs.o drm_encoder_slave.o drm_global.o drm_platform.o drm_trace_points.o
53+
54+# For greater than/equal to 3.4 till 3.8 kernel
55+drm-y := pvr_drm_stubs.o drm_auth.o drm_bufs.o drm_cache.o drm_context.o drm_dma.o drm_drv.o drm_fops.o drm_gem.o drm_ioctl.o drm_irq.o \
56+ drm_lock.o drm_memory.o drm_proc.o drm_stub.o drm_vm.o \
57+ drm_agpsupport.o drm_scatter.o ati_pcigart.o drm_pci.o \
58+ drm_sysfs.o drm_hashtab.o drm_mm.o \
59+ drm_crtc.o drm_modes.o drm_edid.o \
60+ drm_info.o drm_debugfs.o drm_encoder_slave.o drm_global.o drm_platform.o drm_trace_points.o drm_prime.o
61
62 # less than 2.6.32 kernel
63
diff --git a/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules_4.10.00.01.bb b/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules_4.10.00.01.bb
new file mode 100644
index 0000000..b83e1ee
--- /dev/null
+++ b/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules_4.10.00.01.bb
@@ -0,0 +1,66 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=ea5743acf520dd81ca172e69f818a3d4"
4
5TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
6require recipes-ti/includes/ti-eula-unpack.inc
7
8SGXPV = "4_10_00_01"
9IMGPV = "1.9.2188537"
10
11inherit module
12
13MACHINE_KERNEL_PR_append = "c"
14PR = "${MACHINE_KERNEL_PR}"
15
16DEFAULT_PREFERENCE = "-1"
17
18# Select the corresponding hardfp/softfp filename and checksums based on tune flags
19BINFILE_SOFTFP = "Graphics_SDK_setuplinux_${SGXPV}_minimal_demos.bin"
20MD5SUM_SOFTFP = "bd35e9d8843aff3a2aca9d41e7db1c7d"
21SHA256SUM_SOFTFP = "eb37f75ddde4640b09e760fa86e689beb394330ecdf68786188c34f249247647"
22
23BINFILE_HARDFP = "Graphics_SDK_setuplinux_${SGXPV}_hardfp_minimal_demos.bin"
24MD5SUM_HARDFP = "15a3ccb66e98580e474fc112565f66b6"
25SHA256SUM_HARDFP = "4d94d5a1869b228ce12027783fc5425c92e9b66685c501247889f1f167e66c9d"
26
27BINFILE = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${BINFILE_HARDFP}', '${BINFILE_SOFTFP}', d)}"
28
29SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \
30 file://Change-for-interfacing-with-SGX-DT-node.patch \
31 file://linux-3.8.patch \
32 file://0001-Graphics-SDK-04.10.00.01-AM335x-sgx-irq-change.patch \
33 "
34
35SRC_URI[md5sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${MD5SUM_HARDFP}', '${MD5SUM_SOFTFP}', d)}"
36SRC_URI[sha256sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${SHA256SUM_HARDFP}', '${SHA256SUM_SOFTFP}', d)}"
37
38TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}"
39S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM"
40
41PVRBUILD = "release"
42export KERNELDIR = "${STAGING_KERNEL_DIR}"
43
44INHIBIT_PACKAGE_STRIP = "1"
45
46TI_PLATFORM_omap3 = "omap3630"
47TI_PLATFORM_ti814x = "ti81xx"
48TI_PLATFORM_ti816x = "ti81xx"
49TI_PLATFORM_ti33x = "ti335x"
50
51MODULESLOCATION_omap3 = "dc_omapfb3_linux"
52MODULESLOCATION_ti814x = "dc_ti81xx_linux"
53MODULESLOCATION_ti816x = "dc_ti81xx_linux"
54MODULESLOCATION_ti33x = "dc_ti335x_linux"
55
56MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=0"
57
58MAKE_TARGETS_append_ti33x = " PM_RUNTIME=1"
59
60do_install() {
61 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
62 cp ${S}/pvrsrvkm.ko \
63 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
64 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
65 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
66}
diff --git a/meta-ti-extras/recipes/u-boot/u-boot-am33x/0001-am335x-evm-disable-console-cursor-blinking.patch b/meta-ti-extras/recipes/u-boot/u-boot-am33x/0001-am335x-evm-disable-console-cursor-blinking.patch
new file mode 100644
index 0000000..8c3ee2d
--- /dev/null
+++ b/meta-ti-extras/recipes/u-boot/u-boot-am33x/0001-am335x-evm-disable-console-cursor-blinking.patch
@@ -0,0 +1,25 @@
1From c7edbae8c34f73abb1974c0e8722f6f3c7b49f45 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@digia.com>
3Date: Tue, 17 Sep 2013 08:16:51 +0300
4Subject: [PATCH] am335x-evm: disable console cursor blinking
5
6---
7 include/configs/am335x_evm.h | 2 +
8 1 file changed, 2 insertion(++)
9
10diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
11index 90e35ee..f28e842 100644
12--- a/include/configs/am335x_evm.h
13+++ b/include/configs/am335x_evm.h
14@@ -86,6 +86,8 @@
15 "ip_method=none\0" \
16 "bootargs_defaults=setenv bootargs " \
17 "console=${console} " \
18+ "consoleblank=0 " \
19+ "vt.global_cursor_default=0 " \
20 "${optargs}\0" \
21 "mmcargs=run bootargs_defaults;" \
22 "setenv bootargs ${bootargs} " \
23--
241.7.10.4
25
diff --git a/meta-ti-extras/recipes/u-boot/u-boot-am33x_2013.01.01.bbappend b/meta-ti-extras/recipes/u-boot/u-boot-am33x_2013.01.01.bbappend
new file mode 100644
index 0000000..2b1c656
--- /dev/null
+++ b/meta-ti-extras/recipes/u-boot/u-boot-am33x_2013.01.01.bbappend
@@ -0,0 +1,26 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
24SRC_URI += " \
25 file://0001-am335x-evm-disable-console-cursor-blinking.patch \
26 "
diff --git a/meta-ti-extras/recipes/u-boot/u-boot-ti-staging/0001-BBB-disable-console-cursor-blinking.patch b/meta-ti-extras/recipes/u-boot/u-boot-ti-staging/0001-BBB-disable-console-cursor-blinking.patch
new file mode 100644
index 0000000..25dd9e4
--- /dev/null
+++ b/meta-ti-extras/recipes/u-boot/u-boot-ti-staging/0001-BBB-disable-console-cursor-blinking.patch
@@ -0,0 +1,25 @@
1From bde714b9bfeafe46abc1078c09f6efac0e7b6478 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@digia.com>
3Date: Wed, 22 Jan 2014 11:30:59 +0200
4Subject: [PATCH] BBB: disable console cursor blinking
5
6---
7 include/configs/am335x_evm.h | 2 ++
8 1 file changed, 2 insertions(+)
9
10diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
11index d53f17d..1b3d2a4 100644
12--- a/include/configs/am335x_evm.h
13+++ b/include/configs/am335x_evm.h
14@@ -59,6 +59,8 @@
15 "ramrootfstype=ext2\0" \
16 "mmcargs=setenv bootargs console=${console} " \
17 "${optargs} " \
18+ "consoleblank=0 " \
19+ "vt.global_cursor_default=0 " \
20 "root=${mmcroot} " \
21 "rootfstype=${mmcrootfstype}\0" \
22 "spiroot=/dev/mtdblock4 rw\0" \
23--
241.8.3.2
25
diff --git a/meta-ti-extras/recipes/u-boot/u-boot-ti-staging_2013.10.bbappend b/meta-ti-extras/recipes/u-boot/u-boot-ti-staging_2013.10.bbappend
new file mode 100644
index 0000000..bad928b
--- /dev/null
+++ b/meta-ti-extras/recipes/u-boot/u-boot-ti-staging_2013.10.bbappend
@@ -0,0 +1,26 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
24SRC_URI += " \
25 file://0001-BBB-disable-console-cursor-blinking.patch \
26 "