summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras/recipes/powervr-drivers
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-09-02 11:58:28 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-09-12 12:34:57 +0000
commitc23246d7bfeec65dc69eb381adc38916df486ad2 (patch)
tree4d945e4274eae3089b57b2e0cf5f0fc5c8b374d0 /meta-ti-extras/recipes/powervr-drivers
parent0ae680c6463b82dfcd4a7692eb35dc4a9456b2f7 (diff)
downloadmeta-boot2qt-c23246d7bfeec65dc69eb381adc38916df486ad2.tar.gz
TI: Use latest versions of u-boot and kernel
Remove use of meta-beagleboard and use recipes provided in meta-ti instead. Beaglebone will not work fully with the linux-ti-staging, follow up commit will fix that. U-boot changes need to be ported to newer version if still required. Change-Id: I3e06b6e310c0d40b9b4b33276802e4817cee0295 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-ti-extras/recipes/powervr-drivers')
-rw-r--r--meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/0001-Graphics-SDK-04.10.00.01-AM335x-sgx-irq-change.patch32
-rw-r--r--meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/Change-for-interfacing-with-SGX-DT-node.patch51
-rw-r--r--meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/linux-3.8.patch63
-rw-r--r--meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules_4.10.00.01.bb66
4 files changed, 0 insertions, 212 deletions
diff --git a/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/0001-Graphics-SDK-04.10.00.01-AM335x-sgx-irq-change.patch b/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/0001-Graphics-SDK-04.10.00.01-AM335x-sgx-irq-change.patch
deleted file mode 100644
index ce50479..0000000
--- a/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/0001-Graphics-SDK-04.10.00.01-AM335x-sgx-irq-change.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From e55f63a07e5266095da89b7f94122fcba9bdef04 Mon Sep 17 00:00:00 2001
2From: Prathap M S <msprathap@ti.com>
3Date: Tue, 19 Nov 2013 16:33:24 +0530
4Subject: [PATCH 1/1] Graphics SDK 04.10.00.01 : AM335x sgx irq change
5
6This patch enables PVR_LINUX_DYNAMIC_SGX_RESOURCE_INFO for AM335x.
7This is required with 3.8 kernel onwards which uses DT.
8This will enable the path of getting sgx irq number dynamically.
9
10Signed-off-by: Prathap M S <msprathap@ti.com>
11---
12 services4/system/ti335x/syslocal.h | 4 ++--
13 1 file changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/services4/system/ti335x/syslocal.h b/services4/system/ti335x/syslocal.h
16index 090b38d..222d52d 100644
17--- a/services4/system/ti335x/syslocal.h
18+++ b/services4/system/ti335x/syslocal.h
19@@ -69,8 +69,8 @@ CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
20 #if !defined(LDM_PLATFORM)
21 #error "LDM_PLATFORM must be set"
22 #endif
23-//#define PVR_LINUX_DYNAMIC_SGX_RESOURCE_INFO
24-//#include <linux/platform_device.h>
25+#define PVR_LINUX_DYNAMIC_SGX_RESOURCE_INFO
26+#include <linux/platform_device.h>
27 #endif
28
29 #if ((defined(DEBUG) || defined(TIMING)) && \
30--
311.7.9.5
32
diff --git a/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/Change-for-interfacing-with-SGX-DT-node.patch b/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/Change-for-interfacing-with-SGX-DT-node.patch
deleted file mode 100644
index c553354..0000000
--- a/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/Change-for-interfacing-with-SGX-DT-node.patch
+++ /dev/null
@@ -1,51 +0,0 @@
1diff --git a/services4/srvkm/env/linux/module.c b/services4/srvkm/env/linux/module.c
2index 668dc2d..2247aad 100644
3--- a/services4/srvkm/env/linux/module.c
4+++ b/services4/srvkm/env/linux/module.c
5@@ -84,6 +84,9 @@ CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
6 #include <linux/module.h>
7 #include <linux/fs.h>
8 #include <linux/proc_fs.h>
9+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(3,8,0))
10+#include <linux/of.h>
11+#endif
12
13 #if defined(SUPPORT_DRI_DRM)
14 #include <drm/drmP.h>
15@@ -296,10 +299,24 @@ static struct platform_device_id powervr_id_table[] __devinitdata = {
16 };
17 #endif
18
19+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(3,8,0))
20+static const struct of_device_id omap_sgx_of_match[] = {
21+ {
22+ .compatible = "ti,sgx",
23+ },
24+ {},
25+};
26+MODULE_DEVICE_TABLE(of, omap_sgx_of_match);
27+#endif
28+
29+
30 static LDM_DRV powervr_driver = {
31 #if defined(PVR_LDM_PLATFORM_MODULE)
32 .driver = {
33 .name = DRVNAME,
34+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(3,8,0))
35+ .of_match_table = of_match_ptr(omap_sgx_of_match),
36+#endif
37 },
38 #endif
39 #if defined(PVR_LDM_PCI_MODULE)
40@@ -362,7 +379,7 @@ static int __devinit PVRSRVDriverProbe(LDM_DEV *pDevice, const struct pci_device
41 #endif
42 {
43 SYS_DATA *psSysData;
44-
45+
46 PVR_TRACE(("PVRSRVDriverProbe(pDevice=%p)", pDevice));
47
48 #if 0 /* INTEGRATION_POINT */
49--
501.7.9.5
51
diff --git a/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/linux-3.8.patch b/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/linux-3.8.patch
deleted file mode 100644
index acef54b..0000000
--- a/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/linux-3.8.patch
+++ /dev/null
@@ -1,63 +0,0 @@
1diff --git a/services4/3rdparty/linux_drm/Kbuild b/services4/3rdparty/linux_drm/Kbuild
2index d01ef39..ccca3cd 100755
3--- a/services4/3rdparty/linux_drm/Kbuild
4+++ b/services4/3rdparty/linux_drm/Kbuild
5@@ -26,38 +26,38 @@ endif
6 endif
7
8 obj-m := drm.o
9-ifeq ($(TI_PLATFORM),omap4)
10-drm-y := pvr_drm_stubs.o drm_auth.o drm_bufs.o drm_cache.o drm_context.o drm_dma.o drm_drawable.o drm_drv.o drm_fops.o drm_gem.o drm_ioctl.o drm_irq.o \
11- drm_lock.o drm_memory.o drm_proc.o drm_stub.o drm_vm.o \
12- drm_agpsupport.o drm_scatter.o ati_pcigart.o drm_pci.o \
13- drm_sysfs.o drm_hashtab.o drm_sman.o drm_mm.o \
14- drm_crtc.o drm_modes.o drm_edid.o \
15- drm_info.o drm_debugfs.o drm_encoder_slave.o
16-else
17+#ifeq ($(TI_PLATFORM),omap4)
18+#drm-y := pvr_drm_stubs.o drm_auth.o drm_bufs.o drm_cache.o drm_context.o drm_dma.o drm_drawable.o drm_drv.o drm_fops.o drm_gem.o drm_ioctl.o drm_irq.o \
19+# drm_lock.o drm_memory.o drm_proc.o drm_stub.o drm_vm.o \
20+# drm_agpsupport.o drm_scatter.o ati_pcigart.o drm_pci.o \
21+# drm_sysfs.o drm_hashtab.o drm_sman.o drm_mm.o \
22+# drm_crtc.o drm_modes.o drm_edid.o \
23+# drm_info.o drm_debugfs.o drm_encoder_slave.o
24+#else
25 # Works for 2.6.37 till 3.2 kernel
26-drm-y := pvr_drm_stubs.o drm_auth.o drm_bufs.o drm_cache.o drm_context.o drm_dma.o drm_drv.o drm_fops.o drm_gem.o drm_ioctl.o drm_irq.o \
27- drm_lock.o drm_memory.o drm_proc.o drm_stub.o drm_vm.o \
28- drm_agpsupport.o drm_scatter.o ati_pcigart.o drm_pci.o \
29- drm_sysfs.o drm_hashtab.o drm_sman.o drm_mm.o \
30- drm_crtc.o drm_modes.o drm_edid.o \
31- drm_info.o drm_debugfs.o drm_encoder_slave.o drm_global.o drm_platform.o drm_trace_points.o
32-endif
33-
34-# For 3.3 kernel only
35 #drm-y := pvr_drm_stubs.o drm_auth.o drm_bufs.o drm_cache.o drm_context.o drm_dma.o drm_drv.o drm_fops.o drm_gem.o drm_ioctl.o drm_irq.o \
36 # drm_lock.o drm_memory.o drm_proc.o drm_stub.o drm_vm.o \
37 # drm_agpsupport.o drm_scatter.o ati_pcigart.o drm_pci.o \
38-# drm_sysfs.o drm_hashtab.o drm_mm.o \
39+# drm_sysfs.o drm_hashtab.o drm_sman.o drm_mm.o \
40 # drm_crtc.o drm_modes.o drm_edid.o \
41 # drm_info.o drm_debugfs.o drm_encoder_slave.o drm_global.o drm_platform.o drm_trace_points.o
42+#endif
43
44-# For greater than/equal to 3.4 till 3.8 kernel
45+# For 3.3 kernel only
46 #drm-y := pvr_drm_stubs.o drm_auth.o drm_bufs.o drm_cache.o drm_context.o drm_dma.o drm_drv.o drm_fops.o drm_gem.o drm_ioctl.o drm_irq.o \
47 # drm_lock.o drm_memory.o drm_proc.o drm_stub.o drm_vm.o \
48 # drm_agpsupport.o drm_scatter.o ati_pcigart.o drm_pci.o \
49 # drm_sysfs.o drm_hashtab.o drm_mm.o \
50 # drm_crtc.o drm_modes.o drm_edid.o \
51-# drm_info.o drm_debugfs.o drm_encoder_slave.o drm_global.o drm_platform.o drm_trace_points.o drm_prime.o
52+# drm_info.o drm_debugfs.o drm_encoder_slave.o drm_global.o drm_platform.o drm_trace_points.o
53+
54+# For greater than/equal to 3.4 till 3.8 kernel
55+drm-y := pvr_drm_stubs.o drm_auth.o drm_bufs.o drm_cache.o drm_context.o drm_dma.o drm_drv.o drm_fops.o drm_gem.o drm_ioctl.o drm_irq.o \
56+ drm_lock.o drm_memory.o drm_proc.o drm_stub.o drm_vm.o \
57+ drm_agpsupport.o drm_scatter.o ati_pcigart.o drm_pci.o \
58+ drm_sysfs.o drm_hashtab.o drm_mm.o \
59+ drm_crtc.o drm_modes.o drm_edid.o \
60+ drm_info.o drm_debugfs.o drm_encoder_slave.o drm_global.o drm_platform.o drm_trace_points.o drm_prime.o
61
62 # less than 2.6.32 kernel
63
diff --git a/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules_4.10.00.01.bb b/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules_4.10.00.01.bb
deleted file mode 100644
index b83e1ee..0000000
--- a/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules_4.10.00.01.bb
+++ /dev/null
@@ -1,66 +0,0 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=ea5743acf520dd81ca172e69f818a3d4"
4
5TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
6require recipes-ti/includes/ti-eula-unpack.inc
7
8SGXPV = "4_10_00_01"
9IMGPV = "1.9.2188537"
10
11inherit module
12
13MACHINE_KERNEL_PR_append = "c"
14PR = "${MACHINE_KERNEL_PR}"
15
16DEFAULT_PREFERENCE = "-1"
17
18# Select the corresponding hardfp/softfp filename and checksums based on tune flags
19BINFILE_SOFTFP = "Graphics_SDK_setuplinux_${SGXPV}_minimal_demos.bin"
20MD5SUM_SOFTFP = "bd35e9d8843aff3a2aca9d41e7db1c7d"
21SHA256SUM_SOFTFP = "eb37f75ddde4640b09e760fa86e689beb394330ecdf68786188c34f249247647"
22
23BINFILE_HARDFP = "Graphics_SDK_setuplinux_${SGXPV}_hardfp_minimal_demos.bin"
24MD5SUM_HARDFP = "15a3ccb66e98580e474fc112565f66b6"
25SHA256SUM_HARDFP = "4d94d5a1869b228ce12027783fc5425c92e9b66685c501247889f1f167e66c9d"
26
27BINFILE = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${BINFILE_HARDFP}', '${BINFILE_SOFTFP}', d)}"
28
29SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \
30 file://Change-for-interfacing-with-SGX-DT-node.patch \
31 file://linux-3.8.patch \
32 file://0001-Graphics-SDK-04.10.00.01-AM335x-sgx-irq-change.patch \
33 "
34
35SRC_URI[md5sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${MD5SUM_HARDFP}', '${MD5SUM_SOFTFP}', d)}"
36SRC_URI[sha256sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${SHA256SUM_HARDFP}', '${SHA256SUM_SOFTFP}', d)}"
37
38TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}"
39S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM"
40
41PVRBUILD = "release"
42export KERNELDIR = "${STAGING_KERNEL_DIR}"
43
44INHIBIT_PACKAGE_STRIP = "1"
45
46TI_PLATFORM_omap3 = "omap3630"
47TI_PLATFORM_ti814x = "ti81xx"
48TI_PLATFORM_ti816x = "ti81xx"
49TI_PLATFORM_ti33x = "ti335x"
50
51MODULESLOCATION_omap3 = "dc_omapfb3_linux"
52MODULESLOCATION_ti814x = "dc_ti81xx_linux"
53MODULESLOCATION_ti816x = "dc_ti81xx_linux"
54MODULESLOCATION_ti33x = "dc_ti335x_linux"
55
56MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=0"
57
58MAKE_TARGETS_append_ti33x = " PM_RUNTIME=1"
59
60do_install() {
61 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
62 cp ${S}/pvrsrvkm.ko \
63 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
64 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
65 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
66}