summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras/recipes/libgles/libgles-omap3_4.09.00.01.bbappend
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-09-23 12:34:23 +0300
committerSamuli Piippo <samuli.piippo@digia.com>2014-09-25 15:22:18 +0300
commit0dded51636b689237af7fdcda1719790c7fb3aa7 (patch)
treee3eb3b08771005311ca9157882ff2dad6cb733f8 /meta-ti-extras/recipes/libgles/libgles-omap3_4.09.00.01.bbappend
parent841eaa73863184bba6c805fc622e242f367609f7 (diff)
downloadmeta-boot2qt-0dded51636b689237af7fdcda1719790c7fb3aa7.tar.gz
Move meta-ti specific files to separate layer
Create new layer for recipes and files that required only when meta-ti layer is used. For now, the bblayers.conf template still includes the new layer as well. Change-Id: Iab8f6b3a61578e7a9579066ae7facca5a9a1f33b Reviewed-by: Eirik Aavitsland <eirik.aavitsland@digia.com>
Diffstat (limited to 'meta-ti-extras/recipes/libgles/libgles-omap3_4.09.00.01.bbappend')
-rw-r--r--meta-ti-extras/recipes/libgles/libgles-omap3_4.09.00.01.bbappend43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes/libgles/libgles-omap3_4.09.00.01.bbappend b/meta-ti-extras/recipes/libgles/libgles-omap3_4.09.00.01.bbappend
new file mode 100644
index 0000000..0646e73
--- /dev/null
+++ b/meta-ti-extras/recipes/libgles/libgles-omap3_4.09.00.01.bbappend
@@ -0,0 +1,43 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23BINLOCATION_omap3 = "${S}/gfx_rel_es5.x"
24
25LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FLIPWSEGL.so.1"
26
27do_install_append() {
28 echo "ParamBufferSize=33554432" >> ${D}${sysconfdir}/powervr.ini
29}
30
31# Inhibit warnings about files being stripped.
32INHIBIT_PACKAGE_STRIP = "1"
33
34pkg_postinst_${PN}_append() {
35ESREV=$(echo ${BINLOCATION} | grep -Po '(\d+)(?!.*\d)' )
36echo ${ESREV} > $D${sysconfdir}/powervr-esrev
37}
38
39RRECOMMENDS_${PN} = "omap3-sgx-modules"
40RRECOMMENDS_${PN}-blitwsegl = ""
41RRECOMMENDS_${PN}-flipwsegl = ""
42RRECOMMENDS_${PN}-frontwsegl = ""
43RRECOMMENDS_${PN}-linuxfbwsegl = ""