summaryrefslogtreecommitdiffstats
path: root/meta-tegra-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-10-13 13:06:09 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-10-14 10:22:37 +0000
commitf956591bbe246fae0dc4ed9b6d911bcec526463f (patch)
tree6a0da0066d8b9850cf913287ea55872041c67411 /meta-tegra-extras
parent776b174f4b54f8913933a67392f1cc3fa1085506 (diff)
downloadmeta-boot2qt-f956591bbe246fae0dc4ed9b6d911bcec526463f.tar.gz
Revert "tegra: update to latest vibrante pdk"
Problems with eglfs, so revert back to previous PDK. This reverts commit 323408406d9133a5462a24fea4ec86e649088180. Change-Id: I3ee36809cb823aefdc03f8a24d052c2a76f308db Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-tegra-extras')
-rw-r--r--meta-tegra-extras/recipes/libdrm-nv/libdrm-nv/libdrm.pc11
-rw-r--r--meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend40
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv/libdrm.pc b/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv/libdrm.pc
new file mode 100644
index 0000000..6fe139e
--- /dev/null
+++ b/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv/libdrm.pc
@@ -0,0 +1,11 @@
1prefix=/usr
2exec_prefix=${prefix}
3libdir=${exec_prefix}/lib
4includedir=${prefix}/include
5
6Name: libdrm
7Description: Userspace interface to kernel DRM services
8Version: 2.4.66
9Libs: -L${libdir} -ldrm
10Cflags: -I${includedir} -I${includedir}/libdrm
11
diff --git a/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend b/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend
new file mode 100644
index 0000000..f346a6b
--- /dev/null
+++ b/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend
@@ -0,0 +1,40 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
31
32SRC_URI += " file://libdrm.pc"
33SRC_URI_remove_nvidia-logan = "file://${PLATFORM_TOPDIR}/include/drm_fourcc.h"
34
35do_install_append() {
36 install -d ${D}/usr/lib/pkgconfig
37 install -m 0776 ${WORKDIR}/libdrm.pc ${D}/usr/lib/pkgconfig/libdrm.pc
38}
39
40PACKAGES += "${PN}-dev"