summaryrefslogtreecommitdiffstats
path: root/meta-tegra-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-11-07 16:32:24 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-11-13 08:00:12 +0000
commitb2ad8c55f806ff3c5b1b9c1f628c8740d9f28534 (patch)
tree89007632519cac6735824fc91dcec4078ebb9162 /meta-tegra-extras
parent190955330c1b86ede20c206fdd6b8cc1bb699d35 (diff)
downloadmeta-boot2qt-b2ad8c55f806ff3c5b1b9c1f628c8740d9f28534.tar.gz
jetson: update to Linux For Tegra R28.1
Use the latest release for Jetson TX1 and TX2. Task-number: QTBUG-64136 Change-Id: I39bb2592a20694befc721b202ee3f7b33623ee1d Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-tegra-extras')
-rw-r--r--meta-tegra-extras/recipes/drm/libdrm_%.bbappend32
-rw-r--r--meta-tegra-extras/recipes/linux/linux-tegra/0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch12
-rw-r--r--meta-tegra-extras/recipes/linux/linux-tegra/jetson-tx2/0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch46
-rw-r--r--meta-tegra-extras/recipes/qt5/qtbase_git.bbappend7
-rw-r--r--meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend6
5 files changed, 7 insertions, 96 deletions
diff --git a/meta-tegra-extras/recipes/drm/libdrm_%.bbappend b/meta-tegra-extras/recipes/drm/libdrm_%.bbappend
deleted file mode 100644
index 940c931..0000000
--- a/meta-tegra-extras/recipes/drm/libdrm_%.bbappend
+++ /dev/null
@@ -1,32 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30do_install_append() {
31 rm -f ${D}${libdir}/libdrm.so.2
32}
diff --git a/meta-tegra-extras/recipes/linux/linux-tegra/0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch b/meta-tegra-extras/recipes/linux/linux-tegra/0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch
index c700e0e..dd58eed 100644
--- a/meta-tegra-extras/recipes/linux/linux-tegra/0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch
+++ b/meta-tegra-extras/recipes/linux/linux-tegra/0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch
@@ -16,14 +16,14 @@ NULL pointer dereference in fbcon_switch.
16Fix the issue by using the variable screen info structure also when adding 16Fix the issue by using the variable screen info structure also when adding
17new mode to the modelist. 17new mode to the modelist.
18--- 18---
19 drivers/video/modedb.c | 7 ++++--- 19 drivers/video/fbdev/core/modedb.c | 7 ++++---
20 1 file changed, 4 insertions(+), 3 deletions(-) 20 1 file changed, 4 insertions(+), 3 deletions(-)
21 21
22diff --git a/drivers/video/modedb.c b/drivers/video/modedb.c 22diff --git a/drivers/video/fbdev/core/modedb.c b/drivers/video/fbdev/core/modedb.c
23index 12dadab..e5093cf 100644 23index f5a53a6..a8fd871 100644
24--- a/drivers/video/modedb.c 24--- a/drivers/video/fbdev/core/modedb.c
25+++ b/drivers/video/modedb.c 25+++ b/drivers/video/fbdev/core/modedb.c
26@@ -2190,13 +2190,14 @@ int fb_add_videomode(const struct fb_videomode *mode, struct list_head *head) 26@@ -2187,13 +2187,14 @@ int fb_add_videomode(const struct fb_videomode *mode, struct list_head *head)
27 { 27 {
28 struct list_head *pos; 28 struct list_head *pos;
29 struct fb_modelist *modelist; 29 struct fb_modelist *modelist;
diff --git a/meta-tegra-extras/recipes/linux/linux-tegra/jetson-tx2/0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch b/meta-tegra-extras/recipes/linux/linux-tegra/jetson-tx2/0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch
deleted file mode 100644
index 1bce6d7..0000000
--- a/meta-tegra-extras/recipes/linux/linux-tegra/jetson-tx2/0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch
+++ /dev/null
@@ -1,46 +0,0 @@
1From 75a27373962e24424bcd2781568e6c6c5715ca92 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Ilari=20=C3=84ngeslev=C3=A4?= <ilari.angesleva@qt.io>
3Date: Tue, 17 Oct 2017 14:13:02 +0300
4Subject: [PATCH] fbcon: Compare variable screen info instead of modes (FIX)
5
6Previous commit changed behavior, so that when trying to match a mode to a
7variable screen info structure, the mode was first converted to a variable
8screen structure rather than the variable screen info structure to a mode.
9
10However, when new mode was being added to the modelist, matching was still
11being done using mode structure. This could cause situation, where existing
12mode would match when comparing with mode structure, but not when compared
13using variable screen info structure. This would eventually result in a
14NULL pointer dereference in fbcon_switch.
15
16Fix the issue by using the variable screen info structure also when adding
17new mode to the modelist.
18---
19 drivers/video/fbdev/core/modedb.c | 7 ++++---
20 1 file changed, 4 insertions(+), 3 deletions(-)
21
22diff --git a/drivers/video/fbdev/core/modedb.c b/drivers/video/fbdev/core/modedb.c
23index f5a53a6..a8fd871 100644
24--- a/drivers/video/fbdev/core/modedb.c
25+++ b/drivers/video/fbdev/core/modedb.c
26@@ -2187,13 +2187,14 @@ int fb_add_videomode(const struct fb_videomode *mode, struct list_head *head)
27 {
28 struct list_head *pos;
29 struct fb_modelist *modelist;
30- struct fb_videomode *m;
31+ struct fb_var_screeninfo v1, v2;
32 int found = 0;
33
34+ fb_videomode_to_var(&v1, mode);
35 list_for_each(pos, head) {
36 modelist = list_entry(pos, struct fb_modelist, list);
37- m = &modelist->mode;
38- if (fb_mode_is_equal(m, mode)) {
39+ fb_videomode_to_var(&v2, &modelist->mode);
40+ if (fb_var_is_equal(&v1, &v2)) {
41 found = 1;
42 break;
43 }
44--
452.7.4
46
diff --git a/meta-tegra-extras/recipes/qt5/qtbase_git.bbappend b/meta-tegra-extras/recipes/qt5/qtbase_git.bbappend
index 5b9f84b..d48d6ac 100644
--- a/meta-tegra-extras/recipes/qt5/qtbase_git.bbappend
+++ b/meta-tegra-extras/recipes/qt5/qtbase_git.bbappend
@@ -1,6 +1,6 @@
1############################################################################ 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
@@ -28,8 +28,3 @@
28############################################################################ 28############################################################################
29 29
30PACKAGECONFIG += "kms" 30PACKAGECONFIG += "kms"
31
32# Disable getentropy for jetson-tx1 because of older than 3.17 kernel.
33# The kernel version in jetson-tx2 is 4.4.
34
35QT_CONFIG_FLAGS_append_jetson-tx1 = " --no-feature-getentropy"
diff --git a/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend b/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend
index 1f375e6..84a817c 100644
--- a/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend
+++ b/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend
@@ -27,8 +27,6 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa', '', d)}"
31
32PACKAGES += "${PN}-dev" 30PACKAGES += "${PN}-dev"
33RRECOMMENDS_${PN}-dev += "\ 31RRECOMMENDS_${PN}-dev += "\
34 libgles1-mesa-dev \ 32 libgles1-mesa-dev \
@@ -37,7 +35,3 @@ RRECOMMENDS_${PN}-dev += "\
37 libegl-mesa-dev \ 35 libegl-mesa-dev \
38 libgl-mesa-dev \ 36 libgl-mesa-dev \
39 " 37 "
40
41do_install_append() {
42 install -m 0644 ${DRVROOT}/tegra/libdrm* ${D}${libdir}
43}