summaryrefslogtreecommitdiffstats
path: root/meta-tegra-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-01-31 08:24:30 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-02-15 08:32:05 +0000
commit505d8414e11d4da9d8fc485931f2af6fdfd5912f (patch)
tree743f22f93422748f243c125908c1eaf90af6e8f6 /meta-tegra-extras
parentcbfd8dd6a9ff034ec1e2839c1e72ee0973163195 (diff)
downloadmeta-boot2qt-505d8414e11d4da9d8fc485931f2af6fdfd5912f.tar.gz
Rename nvidia extra layers
Reserve meta-tegra-extras for the open source meta-tegra layer used for Jetson TX1 and TK1. Change-Id: I78b168105f306ee342671b612205d68b56016c14 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-tegra-extras')
-rw-r--r--meta-tegra-extras/conf/layer.conf40
-rw-r--r--meta-tegra-extras/recipes/connman-conf/connman-conf.bbappend40
-rw-r--r--meta-tegra-extras/recipes/connman-conf/connman-conf/main.conf4
-rw-r--r--meta-tegra-extras/recipes/egl-gles-nv/egl-gles-nv_1.0.bbappend33
-rw-r--r--meta-tegra-extras/recipes/firmware/tegra-firmware_1.0.bbappend35
-rw-r--r--meta-tegra-extras/recipes/graphics-headers/graphics-headers_1.0.bbappend30
-rw-r--r--meta-tegra-extras/recipes/qt5/qtbase_git.bbappend30
-rw-r--r--meta-tegra-extras/recipes/qt5/qtwebengine_git.bbappend31
-rw-r--r--meta-tegra-extras/recipes/tegra-drivers/tegra-drivers/egl.pc12
-rw-r--r--meta-tegra-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend49
10 files changed, 0 insertions, 304 deletions
diff --git a/meta-tegra-extras/conf/layer.conf b/meta-tegra-extras/conf/layer.conf
deleted file mode 100644
index c170570..0000000
--- a/meta-tegra-extras/conf/layer.conf
+++ /dev/null
@@ -1,40 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30# We have a conf and classes directory, append to BBPATH
31BBPATH .= ":${LAYERDIR}"
32
33# We have a recipes directory, add to BBFILES
34BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
35 ${LAYERDIR}/recipes*/*/*.bbappend \
36"
37
38BBFILE_COLLECTIONS += "b2qt_tegra"
39BBFILE_PATTERN_b2qt_tegra := "^${LAYERDIR}/"
40BBFILE_PRIORITY_b2qt_tegra = "20"
diff --git a/meta-tegra-extras/recipes/connman-conf/connman-conf.bbappend b/meta-tegra-extras/recipes/connman-conf/connman-conf.bbappend
deleted file mode 100644
index 3cfe234..0000000
--- a/meta-tegra-extras/recipes/connman-conf/connman-conf.bbappend
+++ /dev/null
@@ -1,40 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31
32FILES_${PN} += "etc/connman/main.conf"
33
34SRC_URI += "file://main.conf \
35 "
36
37do_install_append() {
38 install -d ${D}${sysconfdir}/connman
39 install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/connman/main.conf
40}
diff --git a/meta-tegra-extras/recipes/connman-conf/connman-conf/main.conf b/meta-tegra-extras/recipes/connman-conf/connman-conf/main.conf
deleted file mode 100644
index a1e45b9..0000000
--- a/meta-tegra-extras/recipes/connman-conf/connman-conf/main.conf
+++ /dev/null
@@ -1,4 +0,0 @@
1[General]
2PreferredTechnologies=ethernet,wifi,cellular
3NetworkInterfaceBlacklist=eth0
4
diff --git a/meta-tegra-extras/recipes/egl-gles-nv/egl-gles-nv_1.0.bbappend b/meta-tegra-extras/recipes/egl-gles-nv/egl-gles-nv_1.0.bbappend
deleted file mode 100644
index 4314a20..0000000
--- a/meta-tegra-extras/recipes/egl-gles-nv/egl-gles-nv_1.0.bbappend
+++ /dev/null
@@ -1,33 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30PROVIDES = "virtual/egl virtual/libgles2"
31RPROVIDES_${PN} = "libegl libegl-dev libgles2 libgles2-dev"
32RCONFLICTS_${PN} = "libegl-mesa libegl-mesa-dev libgles2-mesa libgles2-mesa-dev"
33RREPLACES_${PN} = "libegl-mesa lbegl-mesa-dev libgles2-mesa libgles2-mesa-dev"
diff --git a/meta-tegra-extras/recipes/firmware/tegra-firmware_1.0.bbappend b/meta-tegra-extras/recipes/firmware/tegra-firmware_1.0.bbappend
deleted file mode 100644
index d3e2337..0000000
--- a/meta-tegra-extras/recipes/firmware/tegra-firmware_1.0.bbappend
+++ /dev/null
@@ -1,35 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30# WARNING: FILESEXTRAPATHS-variable, must always use _prepend (or _append)
31FILESEXTRAPATHS_tegra-x1_prepend = "__default:"
32FILESEXTRAPATHS_tegra-t18x_prepend = "__default:"
33
34# ERROR: QA Issue: Files/directories were installed but not shipped in any package
35FILES_${PN}-gk20a = "${FILES__${PN}-gk20a}"
diff --git a/meta-tegra-extras/recipes/graphics-headers/graphics-headers_1.0.bbappend b/meta-tegra-extras/recipes/graphics-headers/graphics-headers_1.0.bbappend
deleted file mode 100644
index df91dfe..0000000
--- a/meta-tegra-extras/recipes/graphics-headers/graphics-headers_1.0.bbappend
+++ /dev/null
@@ -1,30 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30ALLOW_EMPTY_${PN} = "1"
diff --git a/meta-tegra-extras/recipes/qt5/qtbase_git.bbappend b/meta-tegra-extras/recipes/qt5/qtbase_git.bbappend
deleted file mode 100644
index 8770c65..0000000
--- a/meta-tegra-extras/recipes/qt5/qtbase_git.bbappend
+++ /dev/null
@@ -1,30 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30PACKAGECONFIG += "kms"
diff --git a/meta-tegra-extras/recipes/qt5/qtwebengine_git.bbappend b/meta-tegra-extras/recipes/qt5/qtwebengine_git.bbappend
deleted file mode 100644
index 94178db..0000000
--- a/meta-tegra-extras/recipes/qt5/qtwebengine_git.bbappend
+++ /dev/null
@@ -1,31 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30CXXFLAGS +=" -DWIN_INTERFACE_CUSTOM"
31COMPATIBLE_MACHINE_aarch64 = "(.*)"
diff --git a/meta-tegra-extras/recipes/tegra-drivers/tegra-drivers/egl.pc b/meta-tegra-extras/recipes/tegra-drivers/tegra-drivers/egl.pc
deleted file mode 100644
index da1f5f7..0000000
--- a/meta-tegra-extras/recipes/tegra-drivers/tegra-drivers/egl.pc
+++ /dev/null
@@ -1,12 +0,0 @@
1prefix=/usr
2exec_prefix=${prefix}
3libdir=/usr/lib
4includedir=/usr/include
5
6Name: egl
7Description: Mesa EGL library
8Requires.private: libdrm >= 2.4.24
9Version: 9.1.6
10Libs: -L${libdir} -lEGL
11Libs.private: -lm -lpthread -ldl
12Cflags: -I${includedir}
diff --git a/meta-tegra-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend b/meta-tegra-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend
deleted file mode 100644
index 2cc22df..0000000
--- a/meta-tegra-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend
+++ /dev/null
@@ -1,49 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
31
32SRC_URI += " file://egl.pc"
33FILES_${PN} += "egl.pc"
34
35GRAPHICS_PACKAGES = " \
36 virtual/libgles2 \
37 virtual/libegl \
38 virtual/egl \
39 virtual/libgl \
40 virtual/libgles1 \
41 virtual/mesa \
42 libgbm \
43 libgbm-dev \
44 "
45
46do_install_append_tegra-t18x() {
47 install -d ${D}/usr/lib/pkgconfig
48 install -m 0775 ${WORKDIR}/egl.pc ${D}/${libdir}/pkgconfig
49}