summaryrefslogtreecommitdiffstats
path: root/meta-tegra-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-09-26 10:56:59 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-09-28 08:58:06 +0000
commit4fba985f5877320a2354f85646ec145804fe8c28 (patch)
tree60bcf765888b09ee8e33502171edc10d3469a1bd /meta-tegra-extras
parent5e33d73dcdaa1b622460bb082cb011dc9e589d09 (diff)
downloadmeta-boot2qt-4fba985f5877320a2354f85646ec145804fe8c28.tar.gz
jetson: update to sumo
Update meta-tegra layer to the latest revision on sumo branch and make the necessary adaptations. Change-Id: I4119fdf43507645ae3c02da01e3695cdbedf6321 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-tegra-extras')
-rw-r--r--meta-tegra-extras/recipes/drm/libdrm_%.bbappend15
-rw-r--r--meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend4
-rw-r--r--meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend37
3 files changed, 1 insertions, 55 deletions
diff --git a/meta-tegra-extras/recipes/drm/libdrm_%.bbappend b/meta-tegra-extras/recipes/drm/libdrm_%.bbappend
deleted file mode 100644
index bf4cc08..0000000
--- a/meta-tegra-extras/recipes/drm/libdrm_%.bbappend
+++ /dev/null
@@ -1,15 +0,0 @@
1inherit update-alternatives
2
3do_install_append() {
4 mv ${D}${libdir}/libdrm.so.2.4.0 ${D}${libdir}/libdrm-freedesktop.so.2.4.0
5 rm ${D}${libdir}/libdrm.so
6 rm ${D}${libdir}/libdrm.so.2
7 ln -sf libdrm-freedesktop.so.2.4.0 ${D}${libdir}/libdrm.so
8 ln -sf libdrm-freedesktop.so.2.4.0 ${D}${libdir}/libdrm.so.2
9}
10
11ALTERNATIVE_${PN} = "libdrm.so.2.4.0 libdrm.so.2"
12ALTERNATIVE_LINK_NAME[libdrm.so.2.4.0] = "${libdir}/libdrm.so.2.4.0"
13ALTERNATIVE_LINK_NAME[libdrm.so.2] = "${libdir}/libdrm.so.2"
14ALTERNATIVE_TARGET = "${libdir}/libdrm-freedesktop.so.2.4.0"
15ALTERNATIVE_PRIORITY = "20"
diff --git a/meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend b/meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend
index d3c4803..1450622 100644
--- a/meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend
+++ b/meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend
@@ -1,6 +1,6 @@
1############################################################################ 1############################################################################
2## 2##
3## Copyright (C) 2017 The Qt Company Ltd. 3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
@@ -31,5 +31,3 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31SRC_URI += "\ 31SRC_URI += "\
32 file://0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch \ 32 file://0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch \
33 " 33 "
34
35require recipes-kernel/linux/linux-dtb.inc
diff --git a/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend b/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend
deleted file mode 100644
index 84a817c..0000000
--- a/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend
+++ /dev/null
@@ -1,37 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30PACKAGES += "${PN}-dev"
31RRECOMMENDS_${PN}-dev += "\
32 libgles1-mesa-dev \
33 libgles2-mesa-dev \
34 libgles3-mesa-dev \
35 libegl-mesa-dev \
36 libgl-mesa-dev \
37 "