summaryrefslogtreecommitdiffstats
path: root/meta-tegra-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-01-31 08:20:16 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-02-15 08:32:11 +0000
commit4d4427e3e76d64021d56e15e1c30185b8f07e6fc (patch)
tree06eec0cda1e05a4be48f14a8953f9bfc0e91d293 /meta-tegra-extras
parent505d8414e11d4da9d8fc485931f2af6fdfd5912f (diff)
downloadmeta-boot2qt-4d4427e3e76d64021d56e15e1c30185b8f07e6fc.tar.gz
Support for NVIDIA Jetson TX1
Change-Id: Ic84d78d201c48aff296715fa6ce0a7ea5e5921c3 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-tegra-extras')
-rw-r--r--meta-tegra-extras/conf/layer.conf40
-rw-r--r--meta-tegra-extras/recipes/drm/libdrm_%.bbappend32
-rw-r--r--meta-tegra-extras/recipes/qt5/qtbase_git.bbappend30
-rw-r--r--meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend34
4 files changed, 136 insertions, 0 deletions
diff --git a/meta-tegra-extras/conf/layer.conf b/meta-tegra-extras/conf/layer.conf
new file mode 100644
index 0000000..c170570
--- /dev/null
+++ b/meta-tegra-extras/conf/layer.conf
@@ -0,0 +1,40 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30# We have a conf and classes directory, append to BBPATH
31BBPATH .= ":${LAYERDIR}"
32
33# We have a recipes directory, add to BBFILES
34BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
35 ${LAYERDIR}/recipes*/*/*.bbappend \
36"
37
38BBFILE_COLLECTIONS += "b2qt_tegra"
39BBFILE_PATTERN_b2qt_tegra := "^${LAYERDIR}/"
40BBFILE_PRIORITY_b2qt_tegra = "20"
diff --git a/meta-tegra-extras/recipes/drm/libdrm_%.bbappend b/meta-tegra-extras/recipes/drm/libdrm_%.bbappend
new file mode 100644
index 0000000..940c931
--- /dev/null
+++ b/meta-tegra-extras/recipes/drm/libdrm_%.bbappend
@@ -0,0 +1,32 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30do_install_append() {
31 rm -f ${D}${libdir}/libdrm.so.2
32}
diff --git a/meta-tegra-extras/recipes/qt5/qtbase_git.bbappend b/meta-tegra-extras/recipes/qt5/qtbase_git.bbappend
new file mode 100644
index 0000000..8770c65
--- /dev/null
+++ b/meta-tegra-extras/recipes/qt5/qtbase_git.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30PACKAGECONFIG += "kms"
diff --git a/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend b/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend
new file mode 100644
index 0000000..32a93ab
--- /dev/null
+++ b/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend
@@ -0,0 +1,34 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa', '', d)}"
31
32do_install_append() {
33 install -m 0644 ${DRVROOT}/tegra/libdrm* ${D}${libdir}
34}