summaryrefslogtreecommitdiffstats
path: root/meta-tegra-extras
diff options
context:
space:
mode:
authorKari Hormi <kari.hormi@qt.io>2017-06-07 15:04:30 +0300
committerKari Hormi <kari.hormi@qt.io>2017-06-08 12:24:51 +0000
commit3c007f28f42f80cd436338337fcb848b5baa4290 (patch)
tree0629408b635f15bfa71e51b1b4a98f4ec6b75358 /meta-tegra-extras
parentb852f57c001f4b0843e9df0ea60698b91cbc0bb8 (diff)
downloadmeta-boot2qt-3c007f28f42f80cd436338337fcb848b5baa4290.tar.gz
Jetson-TX1: Add ability to mount root via NFS
Added new init script that can also mount NFS root. The original init script from meta-tegra layer can only mount from local disk partitions, so an enhanced version of the script was written. While primarily written for RTA testing, end users may find the ability to mount from NFS useful. Task-number: QTBUG-61190 Change-Id: I76af558f2a528862ca1f88dcb4958a5686b508f5 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-tegra-extras')
-rw-r--r--meta-tegra-extras/recipes/initscripts/tegra210-minimal-init/init-boot.sh44
-rw-r--r--meta-tegra-extras/recipes/initscripts/tegra210-minimal-init_%.bbappend33
2 files changed, 77 insertions, 0 deletions
diff --git a/meta-tegra-extras/recipes/initscripts/tegra210-minimal-init/init-boot.sh b/meta-tegra-extras/recipes/initscripts/tegra210-minimal-init/init-boot.sh
new file mode 100644
index 0000000..3e43b60
--- /dev/null
+++ b/meta-tegra-extras/recipes/initscripts/tegra210-minimal-init/init-boot.sh
@@ -0,0 +1,44 @@
1#!/bin/sh
2PATH=/sbin:/bin:/usr/sbin:/usr/bin
3mount -t proc proc /proc
4mount -t devtmpfs none /dev
5mount -t sysfs sysfs /sys
6
7rootdev=""
8opt="rw"
9wait=""
10nfsroot=""
11nfsopts=""
12for bootarg in `cat /proc/cmdline`; do
13 case "$bootarg" in
14 root=*) rootdev="${bootarg##root=}" ;;
15 nfsroot=*)
16 nfsroot=$(echo ${bootarg##nfsroot=} | cut -d ',' -f 1)
17 nfsopts=$(echo ${bootarg##nfsroot=} | cut -d ',' -f 2-)
18 nfsopts=${nfsopts##${nfsroot}}
19 ;;
20 ro) opt="ro" ;;
21 rootwait) wait="yes" ;;
22 esac
23done
24if [ -n "$wait" -a ! -b "${rootdev}" ]; then
25 echo "Waiting for ${rootdev}..."
26 count=0
27 while [ $count -lt 25 ]; do
28 test -b "${rootdev}" && break
29 sleep 0.1
30 count=`expr $count + 1`
31 done
32fi
33echo "Mounting ${rootdev}..."
34if [ "$rootdev" = "/dev/nfs" ]; then
35 echo "Using NFS to boot..."
36 mount -t nfs -o "${opt},${nfsopts}" "${nfsroot}" /mnt || exec sh
37else
38 mount -t ext4 -o "$opt" "${rootdev}" /mnt || exec sh
39fi
40echo "Switching to rootfs on ${rootdev}..."
41mount --move /sys /mnt/sys
42mount --move /proc /mnt/proc
43mount --move /dev /mnt/dev
44exec switch_root /mnt /sbin/init
diff --git a/meta-tegra-extras/recipes/initscripts/tegra210-minimal-init_%.bbappend b/meta-tegra-extras/recipes/initscripts/tegra210-minimal-init_%.bbappend
new file mode 100644
index 0000000..788524a
--- /dev/null
+++ b/meta-tegra-extras/recipes/initscripts/tegra210-minimal-init_%.bbappend
@@ -0,0 +1,33 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31SRC_URI += "\
32 file://init-boot.sh \
33 "