summaryrefslogtreecommitdiffstats
path: root/meta-tegra-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-05-17 11:22:40 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2017-05-17 12:03:20 +0000
commit099d42603125dfa240b902967a66d453e8071351 (patch)
tree52fe4b0fa7e717d82f9312c3eb8262bda16d182b /meta-tegra-extras
parent1d6420978f10e5a3858edc3c692a0dc9fca86acb (diff)
downloadmeta-boot2qt-099d42603125dfa240b902967a66d453e8071351.tar.gz
tegra: use v8 API for libjpeg
The binary-only gstreamer plugins for jetson tx1 are compiled against v8 API of libjpeg and cause crash if used against the default v6 API. Task-number: QTBUG-60860 Change-Id: I3be0a0389b31710bdf89b90a2a35028f0937164b Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-tegra-extras')
-rw-r--r--meta-tegra-extras/recipes/jpeg/libjpeg-turbo_%.bbappend31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-tegra-extras/recipes/jpeg/libjpeg-turbo_%.bbappend b/meta-tegra-extras/recipes/jpeg/libjpeg-turbo_%.bbappend
new file mode 100644
index 0000000..c92eafa
--- /dev/null
+++ b/meta-tegra-extras/recipes/jpeg/libjpeg-turbo_%.bbappend
@@ -0,0 +1,31 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30# Enable v8 API
31EXTRA_OECONF_append_class-target = " --with-jpeg8"